VirtualBox

Ticket #18258 (closed defect: wontfix)

Opened 3 years ago

Last modified 5 months ago

VirtualBox does not respect dark themes

Reported by: OxOOCOFFEE Owned by:
Component: documentation Version: VirtualBox 6.0.0
Keywords: Cc:
Guest type: X11 Host type: Linux

Description

I just installed fresh Linux Mint Cinnamon 19.1 with Virtual Box 6. After starting vbox I noticed all text in vbox and help is gray on white background witch is very hard to read for me. I am attaching my screen shots

Attachments

VBoxOnCinnamon19.png Download (104.1 KB) - added by OxOOCOFFEE 3 years ago.
VirtualBox 6 test on Cinnamon 19.1
Cinamon 19.1 Theme.png Download (25.8 KB) - added by OxOOCOFFEE 3 years ago.
Cinnamon 19.1 Theme
VBox6_Main_MouseOver.png Download (86.0 KB) - added by digifuzzy 3 years ago.
Main Window with mouse over settings toolbar button
VBox6_Settings.png Download (41.8 KB) - added by digifuzzy 3 years ago.
Settings Dialog display
2019-06-14_09-39.png Download (129.9 KB) - added by Ore 2 years ago.
Screenshot of the main UI with Gnome Dark Mode.
Screenshot at 2020-03-03 13-53-24.png Download (180.8 KB) - added by franksmcb 21 months ago.
Virtualbox 6.x and dark themes Ubuntu MATE
Screenshot at 2020-03-02 12-41-50.png Download (84.1 KB) - added by franksmcb 21 months ago.
Dark theme 20.04
VirtualBox-6.1.97-136310-Linux_amd64_on_Ubuntu_MATE_20.04.jpg Download (435.9 KB) - added by Jags 21 months ago.
Screenshot: VirtualBox-6.1.97-136310-Linux_amd64 on Ubuntu MATE 20.04 64bit
Vbox_2020-05-18.png Download (98.2 KB) - added by edwho 19 months ago.
Screen Capture of VirtualBox
Mate.png Download (55.3 KB) - added by gtrider 14 months ago.
Ubuntu Mate 20.04
2021-06-18_15-38_VBOX_with_Adwaita-Dark_Mode_Gnome_Theme_Unusable.png Download (181.0 KB) - added by kpm 6 months ago.
Screen grab showing issue on RHEL8.4 using default dark mode Gnome theme

Change History

Changed 3 years ago by OxOOCOFFEE

VirtualBox 6 test on Cinnamon 19.1

Changed 3 years ago by OxOOCOFFEE

Cinnamon 19.1 Theme

Changed 3 years ago by digifuzzy

Main Window with mouse over settings toolbar button

Changed 3 years ago by digifuzzy

Settings Dialog display

comment:1 Changed 3 years ago by digifuzzy

As suggested from forum  post, adding more details and screenshots regarding this problem.

System: Artix Linux (Arch derivative).
Desktop: XFCE
Qt version: 5.12.0
VBox: 6.0.0r127442

qt5ct and qt5-styleplugins installed correctly. Variable QT_QPA_PLATFORMTHEME has been set. VLC and other qt5-based applications display normally with theme settings.

Screenshots added:

1) VBox6_Main_MouseOver - shows main virtualbox window with the mouse positioned over the settings toolbar button.
2) VBox6_Settings - shows the settings dialog presented

Last edited 3 years ago by digifuzzy (previous) (diff)

comment:2 Changed 3 years ago by janitor

  • Summary changed from VirtualBox on Mint Cinnamon 19.1 to VirtualBox does not respect dark themes

Summary changed at socratis behest.

comment:3 Changed 3 years ago by socratis

Thank you janitor! ;)

Idea from #18301 a duplicate of this one...

Changed 2 years ago by Ore

Screenshot of the main UI with Gnome Dark Mode.

comment:4 Changed 2 years ago by Ore

This also impacts Gnome's dark mode. Generally dark mode is much easier on the eyes but with virtualbox it makes the UI all but unusable!

comment:5 Changed 2 years ago by rokm

On Fedora, this issue is caused by incorrect QPalette::Mid color returned by the Adwaita-dark Qt theme. The issue has been fixed in the adwaita-qt git master:  https://github.com/FedoraQt/adwaita-qt/issues/128

Changed 21 months ago by franksmcb

Virtualbox 6.x and dark themes Ubuntu MATE

Changed 21 months ago by franksmcb

Dark theme 20.04

comment:6 Changed 21 months ago by franksmcb

This is occuring on VirtualBox 6.x releases using dark themes on Ubuntu MATE 18.04, 19.10, and 20.04.

comment:7 in reply to: ↑ description Changed 21 months ago by franksmcb

Last edited 21 months ago by franksmcb (previous) (diff)

Changed 21 months ago by Jags

Screenshot: VirtualBox-6.1.97-136310-Linux_amd64 on Ubuntu MATE 20.04 64bit

comment:8 Changed 21 months ago by Jags

Added a screenshot for VirtualBox-6.1.97-136310-Linux_amd64 on Ubuntu MATE 20.04 64bit.

It still doesn't respect dark theme as of build 6.1.97-136310. Thanks.

comment:9 Changed 19 months ago by OxOOCOFFEE

Not the best solution but better then default colors Tested on Ubuntu Mate 20.04

$ VirtualBox -style Fusion %U

Changed 19 months ago by edwho

Screen Capture of VirtualBox

comment:10 Changed 19 months ago by edwho

Experiencing the same issue with Ubuntu 20.04 with yaru-dark theme on VirtualBox 6.1.6 (official version)

looking forward to have this issue resolved soon.

Last edited 19 months ago by edwho (previous) (diff)

comment:11 Changed 19 months ago by csx

Same issue for me (same as above screenshots, very white VBox GUI).

ubuntu 20.04 with 'virtualbox/focal,now 6.1.6-dfsg-1 amd64' installed from ubuntu repo.

comment:12 follow-up: ↓ 13 Changed 18 months ago by alain pannetier

Workaround...

$ VirtualBox -style Fusion %U

...works... but you have to re-edit /usr/share/applications/virtualbox.desktop after each update.

comment:13 in reply to: ↑ 12 Changed 18 months ago by abletech-sb

Replying to alain pannetier:

...works... but you have to re-edit /usr/share/applications/virtualbox.desktop after each update.

To avoid to re-edit desktop file after each update, you can copy it to user local folder:

cp /usr/share/applications/virtualbox.desktop ~/.local/share/applications/

comment:14 Changed 14 months ago by gtrider

This is not only about dark theme. I just installed Ubuntu Mate 20.04 and have the same problem with every theme: white letters on white background.

Changed 14 months ago by gtrider

Ubuntu Mate 20.04

comment:15 Changed 6 months ago by liar666

2 years later...

Exact same problem : white text on white background.. Totally unusable :{{

It was usable a few days ago, before system upgrade => is it on the VBox side of Qt side (I've got lots of problems in other softwares because of Qt upgrade :{ )

FYI:

VirtualBox Graphical User Interface Version 6.1.16_Ubuntu r140961 © 2004-2021 Oracle Corporation (Qt5.12.8)

Under Linux Mint 20...

comment:16 Changed 6 months ago by kpm

+1 for fixing this please. I can confirm that this bug seems to be present on very latest RHEL8.4 release. When first opening Virtualbox Manager I get unusable white text on a white background, only when dragging the window can I see the white text items in the window turn light grey. This is using the default built-in dark mode Gnome theme called Adwaita-dark.

Changed 6 months ago by kpm

Screen grab showing issue on RHEL8.4 using default dark mode Gnome theme

comment:17 Changed 5 months ago by gombara

This is most probably happening since the Qt lib. distributed with VirtualBox does not include gtk2 platform plugin and gtk2 style library files. This has been solved in our development branch which uses another version of Qt than 6.1 branch. Unfortunately we don't have time to tackle this on 6.1 branch.

comment:18 Changed 5 months ago by gombara

  • Status changed from new to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use