VirtualBox

Ticket #18170 (closed defect: duplicate)

Opened 5 months ago

Last modified 4 months ago

install of VirtualBox-5.2-5.2.22_126460_fedora26-1.x86_64.rpm fails; libvpx.so.4 missing -> duplicate of #18113

Reported by: obiewan Owned by:
Component: other Version: VirtualBox 5.2.22
Keywords: Cc:
Guest type: other Host type: other

Description

I have tried several of the builds VB 5.2.20 and VB 5.2.22) in order to get VB installed but NONE but the development version (which has a console problem) works. This host is a fresh Fedora 30 x86_64 installation and libvpx is at the libvpx-1.7.0-7.fc29.x86_64 level. I had to make a .so.4 link to the .so.5 library but this doesn't work for some reason. Even after running ldconfig.

fc30-bash 4.4 /isos# rpm -Uvh VirtualBox-5.2-5.2.22_126460_fedora26-1.x86_64.rpm warning: VirtualBox-5.2-5.2.22_126460_fedora26-1.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 98ab5139: NOKEY error: Failed dependencies:

libvpx.so.4()(64bit) is needed by VirtualBox-5.2-5.2.22_126460_fedora26-1.x86_64

fc30-bash 4.4 /isos# ls -al /usr/lib64/libvpx.* lrwxrwxrwx 1 root root 15 Jul 20 01:55 /usr/lib64/libvpx.so -> libvpx.so.5.0.0 lrwxrwxrwx 1 root root 15 Dec 4 22:10 /usr/lib64/libvpx.so.4 -> libvpx.so.5.0.0 lrwxrwxrwx. 1 root root 15 Jul 20 01:55 /usr/lib64/libvpx.so.5 -> libvpx.so.5.0.0 lrwxrwxrwx. 1 root root 15 Jul 20 01:55 /usr/lib64/libvpx.so.5.0 -> libvpx.so.5.0.0 -rwxr-xr-x. 1 root root 2382120 Jul 20 01:55 /usr/lib64/libvpx.so.5.0.0

Change History

comment:1 Changed 4 months ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from install of VirtualBox-5.2-5.2.22_126460_fedora26-1.x86_64.rpm fails; libvpx.so.4 missing to install of VirtualBox-5.2-5.2.22_126460_fedora26-1.x86_64.rpm fails; libvpx.so.4 missing -> duplicate of #18113

Duplicate of #18113.

comment:2 Changed 4 months ago by michael

And fixed with 6.0, which adds a Fedora 29 build.

comment:3 Changed 4 months ago by obiewan

Hi,

Thanks for your help with this.

I'm running Fedora 30 now and VB at this level has installed and IS running successfully.

VirtualBox-6.0.0_RC1-127494-Linux_amd64.run

Thanks again for your help.

George...

comment:4 Changed 4 months ago by obiewan

My kernel is at: 4.20.0-0.rc6.git2.1.fc30.x86_64

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use