VirtualBox

Ticket #18072 (closed defect: fixed)

Opened 13 months ago

Last modified 7 months ago

VNC Broken on VirtualBox 5.2.20 OSE -> fixed in 5.2.22

Reported by: GabrielVlasiu Owned by:
Component: RDP Version: VirtualBox 5.2.20
Keywords: Cc:
Guest type: all Host type: Linux

Description

Hi.

VNC Broken on VirtualBox 5.2.20 OSE (Linux host). Worked fine up to version 5.2.18. All I get now is a black rectangle. Tried on several machines and I get the same result.

Sincerely, Gabriel

Attachments

VBox.log Download (70.7 KB) - added by GabrielVlasiu 13 months ago.

Change History

comment:1 Changed 13 months ago by socratis

  1. It's usually better and faster, if issues get first addressed in the  VirtualBox forums, a lot more eyes there. More than 95% of the issues are resolved over there, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of.
  1. You were supposed to follow these steps when you filed the bug, and provide a VBox.log:

    Attach a (full) log file ("Machine" menu/"Show Log" in the main VirtualBox Manager window) straight away to save time for you and for us. The log file contains a lot of useful information about both the host and the guest systems as well as information about what happened during a particular machine run. Please do not cut and paste it.

Changed 13 months ago by GabrielVlasiu

comment:2 follow-up: ↓ 3 Changed 13 months ago by GabrielVlasiu

Sure. And get answers like reinstall windows (I run Linux), reinstall VirtualBox (compiled myself and is a rpm and rpm internal verification pass), reboot or other crap! Or no answer at all because I'm not sure how many people use VNC. No thx. I'm a developer myself and I want to talk with developers, thank you very much.

There is _no_ error related to VNC in VBox.log otherwise I would attached the file. The damn thing worked up to 5.2.18 (since I first start compiling VirtualBox, years ago! - version 4.1.x). It does not work now. There is a change in 5.2.20 that broke VNC. I can do a do a diff between 5.2.18 and 5.2.20 and find the problem myself. Fix my code and move one. But _others_ may encounter the same bug and maybe they are not that skilled to fix the code them self. That's why I reported the bug.

Anyway, I attached the file. Please tell-me if you need anything new. Or close the ticket because right now I don't care anymore.

comment:3 in reply to: ↑ 2 Changed 13 months ago by socratis

Replying to GabrielVlasiu:

...because right now I don't care anymore.

At least/last we agree on something...

comment:4 Changed 13 months ago by gv1

Excellent! So let's go one step further: close the ticket so we, both, don't waste our time.

comment:5 Changed 13 months ago by horst769

On the FreeBSD.org ports mailing list there are two reports of this. One is from myself. I found out one additional thing. Keyboard input works, but as the OP suggested, VNC only shows at black window.

The only change was upgrading from 5.2.18 to 5.2.20. I'm willing to debug this further, what else is needed?

The host in this case is FreeBSD the guests are Linux and Windows.

comment:6 Changed 13 months ago by flv

Well, I care. And I can confirm the issue. I upgraded to 5.2.20 on FreeBSD 11.2-STABLE. VNC is black at probably 640x480, regardless of guests resolution. Keyboard input works. 3D/2D accelleration is disabled. Same with newly created guest. Logfile shows nothing, even when running vboxheadless from the shell.

Last edited 13 months ago by flv (previous) (diff)

comment:7 Changed 13 months ago by socratis

FYI, there's a ticket open in the FreeBSD site as well:  https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=232528

comment:8 Changed 12 months ago by DarkAGeS

I confirm this problem on FreeBSD 12 beta 2 (amd64)

comment:9 Changed 12 months ago by VVD

Same here: 5.2.18 work fine, 5.2.20, 5.2.22 - black screen 640x480, but keyboard work.

comment:10 Changed 12 months ago by janitor

  • Status changed from new to closed
  • Resolution set to duplicate

comment:11 Changed 12 months ago by janitor

  • Status changed from closed to reopened
  • Resolution duplicate deleted

On the second thought, keep it separate for now.

comment:12 Changed 12 months ago by VVD

Patch from #18153 work for me with 5.2.22.

comment:13 Changed 7 months ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Summary changed from VNC Broken on VirtualBox 5.2.20 OSE to VNC Broken on VirtualBox 5.2.20 OSE -> fixed in 5.2.22
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use