VirtualBox

Ticket #17981 (new defect)

Opened 5 months ago

Last modified 5 months ago

VB Guest Additions Kernel 4.18 Error Building the Module

Reported by: hmoller Owned by:
Component: guest additions Version: VirtualBox 5.2.18
Keywords: Kernel 4.18 Cc:
Guest type: Linux Host type: Windows

Description

I upgraded to Kernel 4.18 but VirtualBoxGuestAditions failed to build. First I got the error: Makefile:965: "Cannot use CONFIG_STACK_VALIDATION=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel" (*.log.2)

Then I installed libelf-dev nad th build still doesn't work. (*log.1)

Attachments

vboxadd-setup.log.1 Download (26.3 KB) - added by hmoller 5 months ago.
error after installing libelf-dev
vboxadd-setup.log.2 Download (25.7 KB) - added by hmoller 5 months ago.
error before installing libelf-dev

Change History

Changed 5 months ago by hmoller

error after installing libelf-dev

Changed 5 months ago by hmoller

error before installing libelf-dev

comment:1 Changed 5 months ago by michael

Have you tried the most recent Guest Additions test build<1>? I am uploading a new one now, so you might want to wait for an hour or so.

  1. wiki:Testbuilds

comment:2 Changed 5 months ago by hmoller

I tried but VBoxLinuxAdditions.run is note executable in the iso and since the filename is read only don't let me do $chmod +x VBoxLinuxAdditions.run

comment:3 Changed 5 months ago by hmoller

with 5.2.97 worked ok, thanks for all. 5.2.19 has the executable problem.

comment:4 Changed 5 months ago by rkuczwara

Just wanted to add that I ran into the same errors building the shared folder module as in the attached vboxadd-setup.log.1 after updating my Fedora 27 guest from Linux 4.17.17 to Linux 4.18.7 and re-installing Guest Additions from the most recent VirtualBox release 5.2.18.

Using the test build of GuestAdditions (5.2.97) as suggested above resolved the issue.

comment:5 Changed 5 months ago by michael

5.2.97 is the test build for the development (i.e. unstable) branch. The test build for 5.2.19 (stable branch) should solve the problem too, unless I have messed something up. I will take a look at the executable problem reported by hmoller. As a workaround, execute "sudo sh VBoxLinuxAdditions.run" instead of "sudo VBoxLinuxAdditions.run" (adapt as needed).

comment:6 Changed 5 months ago by MiloMak

sh VBoxLinuxAdditions.run is not solving the problem for me on debian sid

running 5.2.18

Last edited 5 months ago by MiloMak (previous) (diff)

comment:7 Changed 5 months ago by socratis

@MiloMak
Please read the thread from the beginning, but more carefully this time. 5.2.18 has the problem, 5.2.19 (the test build) has the problem, you should try 5.2.97, *not* 5.2.18...

comment:8 Changed 5 months ago by michael

I just checked and the current 5.2 Additions test build ISO contains:

-r-xr-xr-x 1 michael michael 7321037 Sep 26 16:30 VBoxLinuxAdditions.run

Is this different for other people?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use