VirtualBox

Ticket #17878 (closed defect: worksforme)

Opened 16 months ago

Last modified 16 months ago

[Debian Testing/Buster][Regression] VirtualBox 5.2.16-123759 libcurl4 broken dependencies -> please use Ubuntu 18.04 package

Reported by: 0xDEADBEEF Owned by:
Component: installer Version: VirtualBox 5.2.16
Keywords: libcurl, libcurl3, libcurl4 Cc:
Guest type: other Host type: Linux

Description

VirtualBox 5.2.16-123759 won't update/install on Debian Testing/Buster due to broken depencies:

sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcurl4 : Conflicts: libcurl3 but 7.60.0-1 is to be installed
E: Broken packages
sudo apt  depends virtualbox-5.2 | grep libcurl

[...]

  Depends: libcurl3 (>= 7.16.2)

Please build the package against libcurl4, thank you!

Change History

comment:1 Changed 16 months ago by michael

  • Status changed from new to closed
  • Resolution set to worksforme
  • Summary changed from [Debian Testing/Buster][Regression] VirtualBox 5.2.16-123759 libcurl4 broken dependencies to [Debian Testing/Buster][Regression] VirtualBox 5.2.16-123759 libcurl4 broken dependencies -> please use Ubuntu 18.04 package

As discussed on the forums, please use the Ubuntu 18.04 package on Debian Testing rather than the Debian 8 one.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use