VirtualBox

Ticket #17759 (closed defect: fixed)

Opened 2 months ago

Last modified 2 weeks ago

Kernel error messages (fixed in svn)

Reported by: Feline Owned by:
Priority: major Component: other
Version: VirtualBox 5.2.12 Keywords:
Cc: Guest type: all
Host type: Linux

Description

Both VirtualBox 5.2.10 and 5.2.12 produce the following error messages in the kernel log

kernel: [ 92.635587] AssertLogRel /home/vbox/vbox-5.2.12/src/VBox/VMM/VMMAll/PGMAllPhys.cpp(2345) VBOXSTRICTRC pgmPhysReadHandler(PVM, PPGMPAGE, RTGCPHYS, void*, size_t, PGMACCESSORIGIN): PGM_HANDLER_PHYS_IS_VALID_STATUS(rcStrict, false) kernel: [ 92.635592] rcStrict=2624 GCPhys=00000000f0804030

These are repeated hundreds of times over a five second period. They appear after the guest has started but not actually at initialisation of the virtual machine. Attached is kernel log showing the messages starting at 14:19:41 which was nineteen seconds after starting the virtual machine and once the desktop was displayed within the guest.

It happens on both a self-built machine (Asus motherboard) and a ThinkCentre M91p. Hosts on both machines are running Debian 9 with the 4.16.5 kernel from backports. Guests affected are both Windows 7 Professional (32 bit) and various Debian distros.

I've tried running the kernels with both KPI (Kernel Page Table Isolation) off and on with the same result. I have also switched off Large Page Tables within the VM guest config but still get the same error.

I have attached both the kernel log (edited to remove the vast majority of repeated error messages) and the VM guest release log. The release log includes the wall clock time so as to make it easier to match activity with the kernel log.

Problem did not occur with 5.2.8 and below.

Attachments

Kernel log extracted Download (108.9 KB) - added by Feline 2 months ago.
Debian Test-2018-05-12-14-20-19.log Download (137.7 KB) - added by Feline 2 months ago.

Change History

Changed 2 months ago by Feline

Changed 2 months ago by Feline

comment:1 Changed 8 weeks ago by WFV

Is there a means to prevent the journal from logging the error? Other than the journal filling 100k+ lines of repetition very quickly, the guests seem to work without issue. Linux guests repeat after rebooting the guest, Windows (7 & XP) don't. Host = Arch 4.16.10-1, guests are: Win7pro64, WinXP, Ubuntu 16.04, Fedora (latest), and an Arch guest too. pc is desktop Asus M5A88-M, AMD-FX8350, 32GB ram, Radeon RX550 gfx. Thank you. Ok, i did more research regarding ignoring the error message, and journalctl doesn't support "NOT" logic per se. Thank you for your consideration. Switching the Linux Guest (on Linux Host) to use ICH AC97 stops the HDA errors but is choppy audio (as mentioned in other VBox forums ~2016)

Last edited 7 weeks ago by WFV (previous) (diff)

comment:2 Changed 8 weeks ago by bird

  • Summary changed from Kernel error messages to Kernel error messages (fixed in svn)

Thanks for the report. This seems to caused by some audio optimizations we did in 5.2.12. Should be addressed in 5.2.14.

comment:3 Changed 2 weeks ago by Feline

Tested with 5.2.14 and no more error messages.

Please close this ticket - Thank you.

comment:4 Changed 2 weeks ago by janitor

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use