Ticket #17741 (new defect)

Opened 4 years ago

Last modified 4 years ago

Raw-mode is unavailable courtesy of Hyper-V

Reported by: micahagilent Owned by:
Component: other Version: VirtualBox 5.2.10
Keywords: hyper-v,raw-mode Cc:
Guest type: other Host type: Windows


Hi, I am getting the famous error when trying to boot a VM:

"Raw-mode is unavailable courtesy of Hyper-V. (VERR_SUPDRV_NO_RAW_MODE_HYPER_V_ROOT)"

Here are all the steps I have already done with no success: 1 - bcdedit /set hypervisorlaunchtype off 2 - Remove all "hyper-v" features through the add/remove programs GUI 3 - Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V-All 4 - dism.exe /Online /Disable-Feature:Microsoft-Hyper-V-All 5 - sfc /scannow 6 - A few other DISM commands to clean the file system. 7 - Un/re installed virtualox

I'm not sure what else I can try? My guess is this happened at some point after I installed RSAT package for Windows which may have also installed Hyper-V with it despite me disabling it all. I would be happy to attach logs or other items you need to help.


Change History

comment:1 Changed 4 years ago by micahagilent

PC = Windows 10 Version 1709 Build 16299.371

comment:2 Changed 4 years ago by socratis

After making 110% sure that Hyper-V is disabled in the Windows Features, you might want to  make sure that Fast Boot is disabled and do a cold boot (i.e. shut down the host for a minute or two).

You also must make sure that nothing else is using Hyper-V, things like antivirus, debuggers, emulators, etc. Check out the articles " Diagnosing VirtualBox Hardening Issues" and " I have a 64bit host, but can't install 64bit guests" to get some ideas...

comment:3 Changed 4 years ago by micahagilent

Confirmed, I have verified no Hyper-V checkboxes and the other links you mention with the same issue.

comment:4 Changed 4 years ago by socratis

I don't think that you read the whole thing. Because as I said, it's not just Hyper-V. You got to keep on searching and keep on eliminating suspects. Something is using your VT-x, and unfortunately there isn't an easy way to tell who's that something, you got to do some digging.

Hint: It's not going to be Firefox or Notepad++. Look for more "invasive" software. Sometimes even OEM software has done that. The possibilities are endless...

comment:5 follow-up: ↓ 6 Changed 4 years ago by micahagilent

I did read the whole thing I just didn't type out everything those articles said for sake of brevity - Antivirus, BIOS settings, fast boot, etc. The only thing I know for sure is "out of the box" (new PC) VirtualBox worked fine for a while as-is and then I installed RSAT which installed Hyper-V by default. At some point after that (didn't test Virtualbox right away) that's when everything broke. In other words, all the extra links/items mentioned are very likely not the issue since it worked with them before but I still tried them anyway.

I'll say that I even opened a Premiere Microsoft ticket and checked a lot of the same things and are still looking in to it since they claim removing the checkboxes to Hyper-V is all that is needed. I suspect that the binaries for Hyper-V still exist, just are in a dormant state causing the issue somehow.

comment:6 in reply to: ↑ 5 Changed 4 years ago by socratis

Replying to micahagilent:

In other words, all the extra links/items mentioned are very likely not the issue since it worked with them before but I still tried them anyway.

Maybe not in your specific case, but this article has to cover multiple cases. I don't even know what RSAT is for example (looked it up: Remote Server Administration Tools), but if it becomes common enough, it will find its way into the FAQ, like the rest of them.

since they claim removing the checkboxes to Hyper-V is all that is needed

I could say a thing or two to them about that setting, but self-censorship wouldn't let me... ;)

So, I take it you are all set now? Did you remove RSAT? And why on earth does this thing require hardware acceleration?!? Is everybody getting "cuckoo" these days?

comment:7 Changed 4 years ago by micahagilent

Negative, tried removing RSAT as well and still the same issue.

comment:8 Changed 4 years ago by socratis

You got to find what's using Hyper-V. There's no tool to do that for you, you got to start digging yourself unfortunately. We can only give you some pointers, that's all. The rest is up to you...

comment:9 Changed 4 years ago by chrysophylax

We had the same issue yesterday on an office laptop running Win10 Enterprise build 1703.

The following steps were taken multiple times (in a slight chaotic manner) to remove everything:

  1. Find and disable every single windows service mentioning Hyper-V or Virtualization or Device Guard. Reboot.
  2. Run 'gpedit.msc' and go to Local Computer Policy > Computer Configuration > Administrative Templates > System > Device Guard > Turn on Virtualization Based Security. Disable it.
  3. Run regedit and remove the following keys

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\LSA\LsaCfgFlags HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DeviceGuard\EnableVirtualizationBasedSecurity HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DeviceGuard\RequirePlatformSecurityFeatures

  1. Turn off both credential guard and virt security by running the following from an elevated command prompt
mountvol X: /s

copy %WINDIR%\System32\SecConfig.efi X:\EFI\Microsoft\Boot\SecConfig.efi /Y

bcdedit /create {0cb3b571-2f2e-4343-a879-d86a476d7215} /d "DebugTool" /application osloader

bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} path "\EFI\Microsoft\Boot\SecConfig.efi"

bcdedit /set {bootmgr} bootsequence {0cb3b571-2f2e-4343-a879-d86a476d7215}

bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} loadoptions DISABLE-LSA-ISO,DISABLE-VBS

bcdedit /set {0cb3b571-2f2e-4343-a879-d86a476d7215} device partition=X:

mountvol X: /d
  1. Reboot, go into BIOS, verify that any Microsoft Device Guard setting-y is disabled.
  2. On boot, you should be asked to verify that you wish to disable both security and credential guard, press F3 to confirm (It offers using the Windows Key as well but that didn't jive with our thinkpad), twice to confirm both.
  3. Start Windows and start VirtualBox. Hopefully you should see working 64-bit machines ready to be spun up.

(8.) Double check that the services didn't start up again, disable them all if so.

Best of luck.

Last edited 4 years ago by chrysophylax (previous) (diff)

comment:10 Changed 4 years ago by JonWVBPD

So with the new version of Windows (17134.112), in Windows AV there is a new setting for 'Core Isoloation' which you can read about here:

The good bit is at the bottom: " Memory integrity protection using virtualization-based security is one of the ways in which we continue to harden the platform against sophisticated attacks. "

Once I turned this off, through a registry edit (the On/Off button was greyed out) and rebooted VirtualBox allowed me to open my VMs again.

The registry key is:


You would change that from '1' to '0' then reboot.

Last edited 4 years ago by JonWVBPD (previous) (diff)
Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use