VirtualBox

Ticket #17729 (new defect)

Opened 4 years ago

Last modified 4 years ago

Current GuestAdditions have problems with resolutions on CentOS 6.2 guests

Reported by: MatsBoekelund Owned by:
Component: guest additions/x11/graphics Version: VirtualBox 5.2.8
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

Hi. Plse see this discussion for additional details, log files and a duplication procedure:  https://forums.virtualbox.org/viewtopic.php?f=6&t=87685&start=15

In short, on a CentOS 6.2 guest I am stuck with only three display resolution settings if I use GuestAdditions >= 5.1.0. GAs version 5.0.40 work fine and offer a multitude of resolutions and although I have not tried it, I suspect that using 5.0.40 I could also use xrandr to add additional modes. Moderator socratis has reproduced the issue also in 5.2.10. I have not tried this on other hosts than my Win7 laptop. socratis is on a MAC if I remember correctly, I doubt the host matters here. For me personally the priority could be set to minor since there is a workaround, on the other hand, many users may depend on other GAs-stuff fixed in newer versions.

Attachments

xorg.conf.gz Download (275 bytes) - added by MatsBoekelund 4 years ago.

Change History

comment:1 Changed 4 years ago by socratis

Related discussion in the forums:  https://forums.virtualbox.org/viewtopic.php?f=6&t=87685
(yes, I know that it was already reported, it's simply that I'm searching for these keywords, plus it puts me on the Cc: list)

As 'MatsBoekelund' mentioned, I tried it too (host OSX 10.11.6, don't think it matters), with the latest 5.2.11 r122401 (the latest test build available as of now). I did not expect that it would be fixed, since if anyone was seriously impacted, it would have been reported since the 5.1.x days (2016-07-12).

I'll keep on looking, mainly comparing where the 5.0.40 (2017-04-29) and the 5.1.22 (2017-04-28) GAs differ. Not in the source per se, but in the ".run" module. I'll see if I can dig up anything...

Changed 4 years ago by MatsBoekelund

comment:2 Changed 4 years ago by MatsBoekelund

Attached an xorg.conf. As hinted in the forum discussion, placing that xorg.conf in /etc/X11/ my CentOS 6.2 guests no longer have the original problem also with newer GAs. I have tried with 5.2.12 GAs too. Caution: With the xorg.conf in place but no GAs installed, the guest seems to hang when trying to start the graphics.

comment:3 Changed 4 years ago by michael

I don't have a CentOS 6 guest handy to check just now, but I am surprised that there is an xorg.conf file at all - I would expect X.Org of that vintage not to need or want one. Perhaps you can try removing it?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use