VirtualBox

Ticket #17726 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Shared folder read errors

Reported by: zxcvgm Owned by:
Component: shared folders Version: VirtualBox 5.2.8
Keywords: Cc:
Guest type: Linux Host type: Windows

Description

File reads from shared folder in the Linux kernel encounters errors. An easy way to test this is with a loop device.

root@VirtualBox:~# dd if=/dev/zero of=/media/sf_z/test.dd count=1024
1024+0 records in
1024+0 records out
524288 bytes (524 kB, 512 KiB) copied, 0.0408967 s, 12.8 MB/s
root@VirtualBox:~# losetup -f /media/sf_z/test.dd

Errors will occur, and the kernel would not be able to identify the partitions because it can't read the image:

[ 1174.109112] print_req_error: I/O error, dev loop0, sector 0
[ 1174.109141] print_req_error: I/O error, dev loop0, sector 0
[ 1174.109157] Buffer I/O error on dev loop0, logical block 0, async page read
[ 1174.109255] print_req_error: I/O error, dev loop0, sector 0
[ 1174.109271] Buffer I/O error on dev loop0, logical block 0, async page read
[ 1174.109293] print_req_error: I/O error, dev loop0, sector 0
[ 1174.109308] Buffer I/O error on dev loop0, logical block 0, async page read
[ 1174.109329] print_req_error: I/O error, dev loop0, sector 0
[ 1174.109343] Buffer I/O error on dev loop0, logical block 0, async page read
[ 1174.109365] print_req_error: I/O error, dev loop0, sector 0
[ 1174.109379] Buffer I/O error on dev loop0, logical block 0, async page read
[ 1174.109401] print_req_error: I/O error, dev loop0, sector 0
[ 1174.109415] Buffer I/O error on dev loop0, logical block 0, async page read
[ 1174.109442] print_req_error: I/O error, dev loop0, sector 24
[ 1174.109457] Buffer I/O error on dev loop0, logical block 3, async page read
[ 1174.146072] print_req_error: I/O error, dev loop0, sector 0
[ 1174.146103] print_req_error: I/O error, dev loop0, sector 0
[ 1174.146119] Buffer I/O error on dev loop0, logical block 0, async page read
[ 1174.146145] Buffer I/O error on dev loop0, logical block 0, async page read
[ 1174.146168] Buffer I/O error on dev loop0, logical block 0, async page read

There is no problem if the image is copied from the shared folder into the VM first, then using losetup on the copied file.

Other information can be found here:

[    5.343584] vboxsf: Successfully loaded version 5.2.10 (interface 0x00010004)
[    5.606238] VBoxService 5.2.10 r122406 (verbosity: 0) linux.amd64 (Apr 27 2018 11:36:11) release log
               00:00:00.000045 main     Log opened 2018-05-02T07:56:09.478284000Z
[    5.606265] 00:00:00.000098 main     OS Product: Linux
[    5.606279] 00:00:00.000116 main     OS Release: 4.13.0-21-generic
[    5.606295] 00:00:00.000130 main     OS Version: #24-Ubuntu SMP Mon Dec 18 17:29:16 UTC 2017
[    5.606321] 00:00:00.000146 main     Executable: /opt/VBoxGuestAdditions-5.2.10/sbin/VBoxService
               00:00:00.000147 main     Process ID: 697
               00:00:00.000147 main     Package type: LINUX_64BITS_GENERIC
[    5.607246] 00:00:00.001076 main     5.2.10 r122406 started. Verbose level = 0
[    5.624085] 00:00:00.017888 automount vbsvcAutoMountWorker: Shared folder 'z' was mounted to '/media/sf_z'

This bug has existed since 5.2.8; upgraded to 5.2.10 and it was still present.

Attachments

Screenshot_2252_09_13_06_06_07.png Download (19.8 KB) - added by Vlijmen Fileer 4 years ago.
Screenshot_2252_09_13_06_07_25.png Download (59.5 KB) - added by Vlijmen Fileer 4 years ago.

Change History

Changed 4 years ago by Vlijmen Fileer

Changed 4 years ago by Vlijmen Fileer

comment:1 Changed 4 years ago by Vlijmen Fileer

Possibly related: Problem accessing host hosted TrueCrypt file container from guest via shared folder.

Before environment: host 64bit Debian Stretch 9.3 + VirtualBox 5.2.6 / guest Ubuntu LTS 17: I have an Ubuntu guest from which I access a TrueCrypt container file on the host, made accessible to it via a shared folder. Using both veracrypt and zulumount. On Ubuntu 17 LTS this worked fine.

Upgrade of the guest to Ubuntu 18 LTS gave errors, so I upgraded VirtualBox 5.2.6 to 5.2.10.

After environment: host 64bit Debian Stretch 9.3 + VirtualBox 5.2.10 / guest Ubuntu LTS 17, also Debian Stretch 9.3 The TrueCrypt file can not be accessed anymore from within the guest. Accessing it from the host works OK.

comment:2 Changed 4 years ago by socratis

One thing that caught my attention was that you mentioned a loop device. Not sure if it's related, but take a look at #17360.

comment:3 Changed 4 years ago by zxcvgm

Looks like this is indeed a duplicate of #17360, and from the looks of that ticket, this feature has been broken since 5.2.x.

comment:4 Changed 4 years ago by janitor

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use