VirtualBox

Ticket #17678 (closed defect: fixed)

Opened 7 months ago

Last modified 6 months ago

Guest Additions won't build in Fedora 28 (Kernel 4.16.1) -> fixed in 5.2.12

Reported by: Jimav Owned by:
Priority: major Component: guest additions
Version: VirtualBox 5.2.8 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Host: Ubuntu 18.04 (64-bit) Guest: Fedora 28 beta

Installing GA fails with compilation errors like the one below. I will attach /var/log/vboxadd-setup.log

/tmp/vbox.0/vbox_ttm.c:495:8: error: too many arguments to function ‘ttm_bo_validate’

ret = ttm_bo_validate(&bo->bo, &bo->placement, false, false);

In file included from /tmp/vbox.0/vbox_drv.h:65,

from /tmp/vbox.0/vbox_ttm.c:31:

./include/drm/ttm/ttm_bo_api.h:338:5: note: declared here

int ttm_bo_validate(struct ttm_buffer_object *bo,

cc1: some warnings being treated as errors

STEPS TO REPRODUCE:

  1. (On HOST. I used Ubuntu but probably the host does not matter)

wget  https://download.fedoraproject.org/pub/fedora/linux/releases/test/28_Beta/Workstation/x86_64/iso/Fedora-Workstation-Live-x86_64-28_Beta-1.3.iso

  1. Create new Virtualbox VM. I used 40G dynaimcally-allocated vdi, 4GB ram, 6 CPUs, enabled PAE/NX. Attach the iso image to the virtual DVD drive
  1. Start the VM. Install fedora taking all default. Shut down the guest.
  2. Remove the .iso from the virtual DVD drive
  3. Boot the guest
  4. Open terminal (Activities in upper left->grid of dots->"Terminal") sudo dnf install dkms gcc kernel-devel kernel-headers Reboot the guest
  5. Devices->Insert Guest Additions agree to install

RESULTS: Insmod fails (because module compilation did not succeed). Look at the end of /var/log/vboxadd-setup.log

Using Virtualbox version 5.2.8_Ubuntu r120774

Attachments

vboxadd-setup.log Download (269.3 KB) - added by Jimav 7 months ago.
/var/log/vboxadd-setup.log

Change History

Changed 7 months ago by Jimav

/var/log/vboxadd-setup.log

comment:1 Changed 7 months ago by michael

The current Guest Additions test build[1] should build on Fedora 28 Beta. A question from my side: Fedora 28 Beta comes with Guest Additions installed and maintained by Fedora, and I would expect our Additions installer to warn you about that. Did you see a warning, and if so, did you uninstall the Fedora Additions before installing ours?

[1] wiki:Testbuilds

comment:2 Changed 7 months ago by michael

  • Summary changed from Guest Additions won't build in Fedora 28 (Kernel 4.16.1) to Guest Additions won't build in Fedora 28 (Kernel 4.16.1) -> fixed after (not in) 5.2.10

comment:3 Changed 6 months ago by robatino

I had a Fedora 28 Workstation VM with virtualbox-guest-additions installed for several months and never saw a warning when installing the Oracle guest additions. (At the time I wasn't even aware that Fedora HAD its own version of the guest additions.)

comment:4 Changed 6 months ago by socratis

In my Fedora 28 installation, there was a clear warning about installing the VirtualBox GAs over the existing F28 GAs. Not the F28 beta, but the release version.

comment:5 Changed 6 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Guest Additions won't build in Fedora 28 (Kernel 4.16.1) -> fixed after (not in) 5.2.10 to Guest Additions won't build in Fedora 28 (Kernel 4.16.1) -> fixed in 5.2.12
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use