VirtualBox

Ticket #17554 (closed defect: fixed)

Opened 8 months ago

Last modified 5 weeks ago

Version 5.2.6 prebuilt RPM fails to install on openSUSE Leap 15.0 and Tumbleweed -> fixed after (not in) 5.2.14

Reported by: Larry998 Owned by:
Priority: major Component: other
Version: VirtualBox 5.2.6 Keywords:
Cc: Guest type: other
Host type: other

Description

When one tries to install a downloaded RPM for openSUSE Leap 15.0 or Tumbleweed, it fails because "Problem: nothing provides libvpx.so.1()(64bit) needed by VirtualBox-5.2-5.2.6_120293_openSUSE132-1.x86_64". The openSUSE versions in question provide libvpx4, not libvpx1. The install works correctly for Leap 42.3. I have not tested any versions older than that.

Attachments

vbox-install.log.gz Download (130.2 KB) - added by jimoe 5 months ago.
installation log for vbox driver

Change History

Changed 5 months ago by jimoe

installation log for vbox driver

comment:1 Changed 5 months ago by jimoe

The issue continues with LEAP 15.0 and VB 5.2.12 with a different failure.

I have attached the installation log after running /sbin/vboxconfig.

comment:2 Changed 4 months ago by janitor

Does the patch from #16872 help?

comment:3 follow-up: ↓ 4 Changed 4 months ago by michael

comment:4 in reply to: ↑ 3 Changed 3 months ago by maestro

Replying to michael:

Sorry this took a while. Could you give this build a try?

https://www.virtualbox.org/download/testcase/VirtualBox-5.2-5.2.15_123465_openSUSE150-1.x86_64.rpm

The same problem for me with openSUSE 15.0. The testcase build rpm installed and works fine for me.

comment:5 Changed 3 months ago by michael

  • Summary changed from Version 5.2.6 prebuilt RPM fails to install on openSUSE Leap 15.0 and Tumbleweed to Version 5.2.6 prebuilt RPM fails to install on openSUSE Leap 15.0 and Tumbleweed -> fixed after (not in) 5.2.14

comment:6 Changed 3 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed

comment:7 Changed 6 weeks ago by hgf_m

running Leap 15.0 with Kernel 4.18.5-3.1.geaff7e2 the same error occurs with VirtualBox-5.2-5.2.18_124319_openSUSE132-1.x86_64.rpm

version VirtualBox-5.2-5.2.16_123759_openSUSE150-1.x86_64.rpm is running fine!

comment:8 Changed 5 weeks ago by hgf_m

running kernel 4.18.7-1.g952d850-default no problems yet with VirtualBox-5.2-5.2.18_124319_openSUSE150-1.x86_64.rpm thanks

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use