VirtualBox

Ticket #17409 (closed defect: fixed)

Opened 7 months ago

Last modified 2 months ago

MODIFYVM_AUDIOOUT in VBoxManageModifyVM.cpp, a copy of MODIFYVM_AUDIOIN -> fixed in 5.2.12

Reported by: socratis Owned by:
Priority: major Component: other
Version: VirtualBox 5.2.0 Keywords: audio out, settings
Cc: Guest type: all
Host type: all

Description

This was brought to my attention from an IRC user (jerryaldrichiii) that when setting "--audioout on", it wasn't working. I verified it that the wrong setting was written in the .vbox file. I was also pointed to a forums topic, " 5.2.0 r118431 Sound Problem" which was talking about the same thing.

Digging a little bit more, I found out that the two cases MODIFYVM_AUDIOOUT and MODIFYVM_AUDIOIN in "VBoxManageModifyVM.cpp", seem to be a copy/paste. The line:

CHECK_ERROR(audioAdapter, COMSETTER(EnabledIn)(ValueUnion.f));
                                           ^^

in the MODIFYVM_AUDIOOUT case should be:

CHECK_ERROR(audioAdapter, COMSETTER(EnabledOut)(ValueUnion.f));
                                           ^^^

I put the version as 5.2.0, since according to the forum post, this must have been going on since the 5.2.0 days.

Change History

comment:1 Changed 2 months ago by socratis

#17733 is probably a duplicate of this one. Can someone please take a look at this? It's an unrealistically obvious problem / easy resolution.

I mean *I* managed to find the culprit... :D

comment:2 Changed 2 months ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from MODIFYVM_AUDIOOUT in VBoxManageModifyVM.cpp, a copy of MODIFYVM_AUDIOIN to MODIFYVM_AUDIOOUT in VBoxManageModifyVM.cpp, a copy of MODIFYVM_AUDIOIN -> fixed in 5.2.12

Thanks Socratis!

comment:3 Changed 2 months ago by socratis

Thanks Michael, confirmed! Forum post updated as well.

For those interested in the actual changeset: https://www.virtualbox.org/changeset/72143/vbox

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use