VirtualBox

Ticket #1734 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

XML invalid after deleting a Snapshot

Reported by: masru Owned by:
Priority: minor Component: VM control
Version: VirtualBox 1.6.2 Keywords:
Cc: Guest type: other
Host type: other

Description

Error message when starting VirtualBox:

Hard disk 'E:\Virtual Machines\VirtualBox\VDI\OpenSolaris 2008.5.vdi' with UUID {c39af329-f5d2-4a8c-84c5-636e471e8869} is already attached to a machine with UUID {5065ee74-f4d9-4770-b88f-a575962f95b2} (see 'E:\Virtual Machines\VirtualBox\Machines\OpenSolaris 2008.5\OpenSolaris 2008.5.xml').

Fehlercode: E_FAIL (0x80004005) Komponente: Machine Interface: IMachine {f95c0793-7737-49a1-85d9-6da81097173b}

Last thing I did yesterday was deleting the first of two snapshots and setting a new snapshot. I attach the xml. Additionally the shutting down of Opensolaris 2008.5 doesn't work in any cases.

Attachments

OpenSolaris 2008.5.xml Download (11.6 KB) - added by masru 6 years ago.
LVM Testbed.xml Download (6.2 KB) - added by Kira 6 years ago.

Change History

Changed 6 years ago by masru

comment:1 Changed 6 years ago by frank

  • Component changed from other to VM control

comment:2 Changed 6 years ago by Kira

I can confirm this with VirtualBox 1.6.2 (full binary, non-OSE) on a Windows XP SP2 host (1.3-windows - the same as the previous commenter, I notice), as I have the same problem on one of my VMs, "LVM Testbed". I'll attach the XML file.

Unfortunately I'm not entirely sure how to recreate the issue, although I'm trying my hardest to find out. However, I'm fairly sure that at some point I did the same thing, deleting the first of two snapshots and setting another.

I do know that one of the last actions I took on the machine was to save the machine state - after which I may have deleted/setted snapshots, though I can't remember. However, since the previous commenter doesn't appear to have done that (judging from the XML), this may be a red herring.

It gets worse, though. This isn't just a case of the XML being invalid - the snapshot VDI that is supposed to be in Machines/*/Snapshots doesn't exist (just the .sav file for the machine state), meaning that the only course of action is to delete the offending snapshot from the XML, as it is not recoverable. I do not know whether the snapshot was merged into the main VDI file or not.

I'm thinking that somewhere along the line it may be possible that deleting a snapshot and thus merging the changes into the main VDI file may accidentally cause a child snapshot to reference that VDI. My own experiments haven't been able to replicate this, though.

Changed 6 years ago by Kira

comment:3 Changed 6 years ago by Kira

Oops, forgot to mention what the actual error in my case was:

Hard disk 'C:\Documents and Settings\ciaran.TNAUKNRC\.VirtualBox\VDI\LVM Testbed.vdi' with UUID {e0c4f0b7-dec1-4553-94d7-a0bdb41427b4} is already attached to a machine with UUID {d4a0b324-75bc-4b73-887a-2f2a1e19796c} (see 'C:\Documents and Settings\ciaran.TNAUKNRC\.VirtualBox\Machines\LVM Testbed\LVM Testbed.xml').

comment:4 Changed 6 years ago by pgimeno

I'm getting pretty much the same problem with VirtualBox 2.0.2:

Hard disk '/home/pgimeno/.VirtualBox/VDI/Kubuntu.vdi' with UUID
{312eadaf-e617-4add-90a0-f89c5b95acd1} is already attached to a machine with
UUID {b316cbb9-678d-4fc5-999a-a2d62bf7afea} (see
'/home/pgimeno/.VirtualBox/Machines/Kubuntu/Kubuntu.xml').


Result Code:   NS_ERROR_FAILURE (0x80004005)
Component:     Machine
Interface:     IMachine {1e509de4-d96c-4f44-8b94-860194f710ac}

This is the second time it happens to me. The last time I had to delete and recreate the machine, losing all snapshots, so the priority of this issue should not just be "minor" due to the data loss.

comment:5 Changed 6 years ago by tdjones

I am having the same problem as pgimeno but with an XP guest. running VirtualBox 2.0.2

Hard disk '/home/tdjones/.VirtualBox/VDI/Windows_XP.vdi' with UUID {933e1446-4901-4c40-75b6-81e8a4d13b22} is already attached to a machine with UUID {1b6e5c09-6a3f-4d6f-0ab7-181a34790f8d} (see '/home/tdjones/.VirtualBox/Machines/Windows_XP/Windows_XP.xml').

Result Code: NS_ERROR_FAILURE (0x80004005) Component: Machine Interface: IMachine {1e509de4-d96c-4f44-8b94-860194f710ac}

comment:6 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if such a problem persists with the latest release 2.2.0.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use