VirtualBox

Ticket #1726 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Seamless mode doesn't work on linux

Reported by: michal123 Owned by:
Priority: major Component: GUI/seamless
Version: VirtualBox 1.6.2 Keywords: seamless mode
Cc: Guest type: other
Host type: other

Description

The version 1.5.4 was last, where the seamless mode worked. In all newer versions when I choose the mode, all virtualbox windows disappears (like it was minimized, but it can't be restored), and with the 1.6.2 version (and 1.6.2 guest additions) I even can't choose the mode (it is gray). I'm running virtualbox on Gentoo, kernel 2.6.25, I'm using xinerama, the system in the virtualbox is windows XP.

Change History

comment:1 Changed 6 years ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1543. Seamless does not work on the second screen of a Xinerama display.

comment:2 Changed 6 years ago by michal123

Why it worked before with 1.5.4 and with 1.6.2 not? I thing that this regression should be solved

comment:3 Changed 6 years ago by michael

Just to be sure there - you are talking about the second screen in a Xinerama setup, aren't you? If not, please reopen this ticket.

comment:4 Changed 6 years ago by michal123

  • Status changed from closed to reopened
  • Resolution duplicate deleted

With the version 1.5.4 it worked on both screens, with 1.6.2 it doesn't work on any. Even when remove xinerama setting still the button with seamless mode is gray and I can't choose it. It looks that the problem is not connected with xinerama.

comment:5 Changed 6 years ago by frank

  • Component changed from other to GUI/seamless

comment:6 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

If seamless does not work on any screen the guest additions are not properly installed. You might also check the VM Video RAM settings, maybe you assigned not enough video RAM. Please could you check with a more recent release (2.2.2) and re-open this ticket if you still are not able to enter the seamless mode. But note that seamless for two screens is still not supported.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use