VirtualBox

Ticket #17218 (closed defect: wontfix)

Opened 3 years ago

Last modified 3 years ago

Virtualbox 5.2 does not honor the user's Qt theme

Reported by: roland651 Owned by:
Component: GUI Version: VirtualBox 5.2.0
Keywords: Cc:
Guest type: all Host type: Linux

Description

Under Ubuntu 16.04, VirtualBox version 5.1 makes use of the user's custom Qt theme but version 5.2 always uses the default Fusion theme, whatever the user's theme.

See attached screenshots.

Note that other Qt5 apps do not have this problem.

Attachments

vb51.png Download (104.0 KB) - added by roland651 3 years ago.
VirtualBox 5.1.30 screenshot
vb52.png Download (98.3 KB) - added by roland651 3 years ago.
VirtualBox 5.2 screenshot

Change History

Changed 3 years ago by roland651

VirtualBox 5.1.30 screenshot

Changed 3 years ago by roland651

VirtualBox 5.2 screenshot

comment:1 Changed 3 years ago by vushakov

  • Status changed from new to closed
  • Resolution set to wontfix

Your system doesn't have minimum Qt version required for our GUI to work, so our fallback Qt library is used instead. Unfortunately it is not integrated with host system so it doesn't pick up theme, fonts, and other custom settings.

This forum  thread may have a bit more details.

comment:2 Changed 3 years ago by roland651

OK, I understand. I'll wait the new Ubuntu LTS version next year, hoping the issue will disappear.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use