VirtualBox

Ticket #17090 (closed enhancement: fixed)

Opened 14 months ago

Last modified 4 weeks ago

Disable-Enable Physical Machine Network Adapter Disable the VM Network Adapter in Bridge Mode -> fixed in 5.2.20

Reported by: xguimax Owned by:
Priority: minor Component: network
Version: VirtualBox 5.0.12 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

Physical Machine OS: Windows 7 x64. VM OS: Tested with Windows 7 x64 and Windows XP Professional. VM OS Network Configuration: 1 Network Adapter, Bridge Mode

Problem: When disabling -> enabling - in control panel - the network adapter from the physical machine, the VM network adapter goes offline and does not return - even after re-enabling the network adapter from the physical machine and the physical machine network working.

Change History

comment:1 Changed 14 months ago by xguimax

VM Network Adapter used in test: Intel PRO/1000 MT Desktop (82540EM)

comment:2 Changed 14 months ago by socratis

Is the VirtualBox version that you filled in the bug report correct, are you using 5.0.12? Because that's kind of an old version. Can you replicate the issue with the latest version (5.1.28 as of this writing)?

I used to do that all the time on my guests and I have not observed a similar behavior. Host was OSX 10.9.5 and now it is 10.11.6, as I said I've been following that practice for years.

comment:3 Changed 14 months ago by aleksey

This behaviour is, sort of, by design on Windows hosts. Disabling an adapter on Windows causes it to destroy the driver stack along with a corresponding instance of VirtualBox bridging filter driver. Since our filter attached to the adapter gets destroyed (and the driver itself potentially unloaded) the corresponding internal network becomes detached from the physical adapter. Re-enabling the adapter creates a new filter instance which is not attached to the internal network. A possible workaround is to switch to "Not attached", then back to "Bridged Adapter", when the adapter becomes available again. It can be done by right-clicking on network settings icon (two monitors, one behind another) in VirtualBox status bar of running VM.

comment:4 Changed 14 months ago by aleksey

  • Priority changed from major to minor
  • Type changed from defect to enhancement

comment:5 Changed 7 weeks ago by aleksey

Could you please try any test build later than r125350 from here?

comment:6 Changed 4 weeks ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from Disable-Enable Physical Machine Network Adapter Disable the VM Network Adapter in Bridge Mode to Disable-Enable Physical Machine Network Adapter Disable the VM Network Adapter in Bridge Mode -> fixed in 5.2.20
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use