VirtualBox

Ticket #17020 (new defect)

Opened 5 years ago

Last modified 5 years ago

dd on USB drive results in Input/output error

Reported by: fkbreitl Owned by:
Component: USB Version: VirtualBox 5.1.26
Keywords: Input/output error Cc:
Guest type: Linux Host type: Windows

Description

Since version 5.1.22 and probably earlier I cannot write images to my USB SD card adapter anymore. Especially when writing larger images such as 4 GB of Raspbian I see the following error after some minutes:

debianguest:~$ time sudo dd if=/dev/loop0p2 |pv -s 4300M |sudo dd of=/dev/sdc2
dd: writing to '/dev/sdc2': Input/output error                ] 34% ETA 0:17:38
3068849+0 records in
3068848+0 records out
1571250176 bytes (1.6 GB, 1.5 GiB) copied, 567.657 s, 2.8 MB/s
1.46GiB 0:09:27 [2.64MiB/s] [==========>                      ] 34%            

real    9m27.844s
user    0m5.073s
sys     0m43.153s

Something with the USB driver seems to be broken on Windows 10 hosts. It used to work correctly with earlier versions.

This is an update of bug #17019 with corrected fields.

Change History

comment:1 Changed 5 years ago by ranchhand6

This also seems to be happening with an Ubuntu 16.04 guest VirtualBox 5.1.28 r117968 (Qt5.6.2) on an OS X High Sierra (10.13) host. Both dd and mbtools fail. The transfers work on a Ubuntu 16.04 VM running under Parallels, so the OS X install and the hardware appear to be good.

Agree that this worked in earlier versions, March of 2017 was the last time this worked for me.

Last edited 5 years ago by ranchhand6 (previous) (diff)

comment:2 Changed 5 years ago by ranchhand6

Bug still present in VirtualBox 5.1.30 and 5.2.0 r118431 (Qt5.6.3).

comment:3 Changed 5 years ago by ranchhand6

Last working version for us on OS X seems to be VirtualBox 5.0.32 (released January 17th 2017).

This is truly annoying. This worked, then it didn't work. Obviously not OS X update because we re-installed the older version of VitualBox and everything worked correctly.

Last edited 5 years ago by ranchhand6 (previous) (diff)

comment:4 Changed 5 years ago by aeichner

If this is still an issue you might try the latest 5.2 or 5.1 testbuild from the Testbuilds page, we identified and fixed an issue in the OHCI and EHCI controller emulations which could explain your issue.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use