VirtualBox

Ticket #16778 (closed defect: fixed)

Opened 5 months ago

Last modified 3 months ago

Cannot run VirtualBox version >= 5.1.20 on iMac mid 2010 with i3 Processor

Reported by: morac Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.20 Keywords:
Cc: socratis Guest type: all
Host type: Mac OS X

Description

When i run VirtualBox on iMac 27” mid 2010 via LaunchPad its icon bounces on dock for few second and then disappears; i try to run VBox via Terminal and i get the message: “segmentation fault: 11” then it exits.

I posted this issue on forum then socratis recommended me to open this bug ticket.

It follows the link to forum thread:  https://forums.virtualbox.org/viewtopic.php?f=8&t=83144

The iMac processor is: 3,2GHz Intel Core i3

This issue appeared from ver 5.1.20 (same behaviour for ver 5.1.22), the version 5.1.18 works fine.

Best regards

Change History

comment:1 Changed 5 months ago by aeichner

Please attach a VBox.log and the OS X crash report from OS X for the VM process.

comment:2 Changed 5 months ago by socratis

@aeichner
Alexander, sorry if I step in here, but I did the  initial investigation on this and it's not your usual crash, and I couldn't figure out how to decipher it, that's why I suggested a new ticket (that's rare for me ;) ).

There's no VBox.log (since VirtualBox crashes at launch) and there's no OSX crash report (at least in the usual place). That's the problem. The VirtualBox process crashes early on when run from the Terminal as well with a "segfault 11".

At the beginning I thought it was the 5.1.20 114628 vs. 114629 builds (see #16665 and  Virtualbox 5.1.20 application crashes on OSX ≥ 10.12.4), but the OP tried 5.1.22 and that crashes as well.

Usual checks for the installation log and the permissions in the usual-suspect places revealed nothing out of the ordinary. I have a 10.9.5 system as well, plus a clean 10.9.5 VM and there seem to be identical. The only thing I saw being different was the i3 core and/or other hardware changes between the OP's system and mine.

And again, 5.1.18 works fine. It's ≥5.1.20 that fails.

Last edited 5 months ago by socratis (previous) (diff)

comment:3 Changed 5 months ago by aeichner

Can you please try a a recent testbuild from here? I was able to reproduce the issue with 5.1.22 but not with our latest testbuild from 5.1

comment:4 follow-up: ↓ 5 Changed 5 months ago by morac

I tried the testbuild 5.1.23 and it WORKS!!!! I re-installed the 5.1.18 because i prefer to work with stable versions. I'll wait impatient the 5.1.24 version.

Many thanks.

comment:5 in reply to: ↑ 4 Changed 5 months ago by socratis

Replying to morac:

because i prefer to work with stable versions

and from the test builds page:

Regularly installing test builds and using them in your day-to-day work is one of the best ways you can help us improve the VirtualBox user experience. These builds are expected to be almost as stable as released versions, and we accept bug reports against them.

And for what it's worth, I almost never run stable versions, I'm always on the test builds ;)

So, don't be afraid of them, they're not experimental, they're the preview of the next stable version. Even the manual is up to date!!! :D

comment:6 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 5.1.24.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use