VirtualBox

Ticket #16697 (closed defect: duplicate)

Opened 3 months ago

Last modified 3 months ago

Guest Additions shared folders broken with 5.1.20 on RHEL 7

Reported by: cknz Owned by:
Priority: major Component: guest additions
Version: VirtualBox 5.1.20 Keywords: vboxsf sf_read_super_aux mount symlink broken
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

Blogged at  http://distracted-it.blogspot.co.nz/2017/04/virtualbox-5120-bug-with-shared-folders.html

After installing GA for 5.1.20, shared folders no longer mount:

# mount host_home
mount: wrong fs type, bad option, bad superblock on host_home,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

# dmesg | tail
...
[  334.616717] vboxsf: Successfully loaded version 5.1.20 (interface 0x00010004)
[  343.413650] sf_read_super_aux err=-22

Looking around the problem is caused by a broken symlink to mount.vboxsf

# updatedb

# locate mount.vbox
/opt/VBoxGuestAdditions-5.1.20/lib/VBoxGuestAdditions/mount.vboxsf
/usr/sbin/mount.vboxsf

# ls -l /usr/sbin/mount.vboxsf 
lrwxrwxrwx. 1 root root 49 Apr 26 10:04 /usr/sbin/mount.vboxsf 
    -> /opt/VBoxGuestAdditions-5.1.20/other/mount.vboxsf

Aha, it seems that mount.vboxsf is a broken link; the following are not the same:

/opt/VBoxGuestAdditions-5.1.20/lib/VBoxGuestAdditions/mount.vboxsf  <--- available
/opt/VBoxGuestAdditions-5.1.20/other/mount.vboxsf                   <--- pointed at

Bit of a quicky fix:

# rm -f /usr/sbin/mount.vboxsf

# ln -s /opt/VBoxGuestAdditions-5.1.20/lib/VBoxGuestAdditions/mount.vboxsf \
    /usr/sbin/mount.vboxsf

# ls -l /usr/sbin/mount.vboxsf 
lrwxrwxrwx. 1 root root 66 Apr 26 10:16 /usr/sbin/mount.vboxsf 
    -> /opt/VBoxGuestAdditions-5.1.20/lib/VBoxGuestAdditions/mount.vboxsf
Moment of truth:

# mount host_home

$ mount
...
host_home on /home/ckerr/host_home type vboxsf (rw,nodev,relatime)

Change History

comment:1 Changed 3 months ago by frank

  • Description modified (diff)

comment:2 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #16670 and fixed in the most recent 5.1.x Guest Additions.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use