VirtualBox

Ticket #1669 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

Seamless mode breaks when running on external display (Mac) -> Fixed in SVN

Reported by: calum Owned by:
Priority: major Component: GUI/multiview
Version: VirtualBox 3.1.6 Keywords:
Cc: Guest type: other
Host type: other

Description

I have an external monitor connected to my MacBook Pro. When running a Linux or Solaris guest VM on the external monitor, switching to Seamless mode causes the application windows to move to my laptop display and shrink to an unusable size.

Attachments

VBox.log Download (60.9 KB) - added by calum 4 years ago.
Latest Vbox.log prior to Seamless Mode crash
VirtualBoxVM_2009-12-01-131341_localhost.crash Download (45.8 KB) - added by calum 4 years ago.
Latest OS X Crash Report prior to Seamless Mode crash
Screen shot 2009-12-01 at 1 Dec 13.26.14.jpg Download (171.9 KB) - added by calum 4 years ago.
Screenshot of Seamless Mode "not working" on external monitor, in 3.1.0
VBox.2.log Download (39.9 KB) - added by calum 4 years ago.
Log file from 3.1.4 when entering seamless mode (at 00:28:49.178)
display.log Download (1.0 KB) - added by calum 4 years ago.
display.log file when switching to seamless mode and back (v3.2.0 b1)
seamless.log Download (24.9 KB) - added by calum 4 years ago.
seamless.log file when switching to seamless mode and back (v3.2.0 b1)

Change History

comment:1 Changed 6 years ago by frank

  • Component changed from other to GUI

comment:2 Changed 6 years ago by frank

  • Component changed from GUI to GUI/multiview

comment:3 Changed 4 years ago by Technologov

  1. Retry with VBox 3.1.0
  1. please post VBox log
  1. please post screenshot (or photo)

-Technologov

Changed 4 years ago by calum

Latest Vbox.log prior to Seamless Mode crash

comment:4 Changed 4 years ago by calum

It worked fine again in 2.x and 3.0.x, but behaviour is worse in 3.1.0 -- now Seamless mode just either doesn't work, or crashes.

Changed 4 years ago by calum

Latest OS X Crash Report prior to Seamless Mode crash

Changed 4 years ago by calum

Screenshot of Seamless Mode "not working" on external monitor, in 3.1.0

comment:5 Changed 4 years ago by calum

Have just also noticed:

  • With 3D accel enabled, Seamless munges the display, but at least munges it on the correct (i.e. external) monitor.
  • With 3D accel disabled, Seamless still munges the display, but moves it to the laptop's internal screen as well.

This is all on OS X 10.6.2 host, btw.

comment:6 Changed 4 years ago by calum

Still not working in 3.1.4, either on internal or external monitor. The behaviour is a little 'better' in 3.1.4 in that the screen doesn't end up in a messed up state; VirtualBox just tries for a few seconds, then reverts to non-seamless mode.

comment:7 Changed 4 years ago by michael

Sorry, I'm afraid that I didn't see this particular ticket. It looks like you are seeing several different issues there. I can't tell you much about the crash in the Qt code, but I can tell you that the failure to enter seamless which you are seeing with 3.1.4 is a recent regression which should be fixed in our development tree soon. Regarding the messed up screen shown in your screen shot, I will try to get some extra logging into the seamless guest tools this week and supply you with an updated version so that we can try to track this down.

comment:8 Changed 4 years ago by michael

The logging code I mentioned has been added and will be in any releases of VirtualBox after 3.1.4. You can activate it (after installing the new Additions) by restarting VBoxClient --display and VBoxClient --seamless as

$ VBOX_RELEASE_LOG_DEST=file=~/display.log VBoxClient --display
$ VBOX_RELEASE_LOG_DEST=file=~/seamless.log VBoxClient --seamless

By the way, if you can still reproduce the issue with the scrambled seamless mode using VBox 3.1.2, it would be great if you could attach a logfile for that session (or alternatively, one from the current version when you fail to enter seamless).

Changed 4 years ago by calum

Log file from 3.1.4 when entering seamless mode (at 00:28:49.178)

comment:9 Changed 4 years ago by calum

(Just to confirm, do you mean the new logging code should be in 3.1.4 as well, or not?)

comment:10 Changed 4 years ago by calum

Hmm, I upgraded to 3.1.6 this morning, updated the additions, restarted, and seamless initially still wasn't working. As soon as I ran those two VBoxClient commands, it started working... but neither of the log files specified by those commands were actually created or written to.

comment:11 Changed 4 years ago by calum

Okay, now that I've upgraded again to the non-broken v3.1.6 (b59351), seamless is broken again. But those two VBoxClient commands still aren't generating any log files for me.

comment:12 Changed 4 years ago by michael

What about the following (just to be really sure):

$ export VBOX_RELEASE_LOG=all.e.l.l2.l3.f
$ export VBOX_RELEASE_LOG_DEST=file=/home/<whatever>/display.log
$VBoxClient --display
$ export VBOX_RELEASE_LOG_DEST=file=/home/<whatever>/seamless.log
$VBoxClient --seamless

comment:13 Changed 4 years ago by michael

Calum, did those commands get you anything?

comment:14 Changed 4 years ago by calum

Sorry, my old MacBook died a couple of weeks ago, and my new one has been delayed by volcanic ash :/ I'll report back as soon as I can try this out.

comment:15 Changed 4 years ago by calum

When I run those commands, both logfiles just contain the single line:

'Failed to create a pidfile. Exiting.'

comment:16 Changed 4 years ago by poetzsch

  • Summary changed from Seamless mode breaks when running on external display (Mac) to Seamless mode breaks when running on external display (Mac) -> Fixed in SVN

Fixed in the next major release.

comment:17 Changed 4 years ago by calum

It's not fixed in the 3.2.0 beta, if that's what you mean -- I've just tried it.

comment:18 Changed 4 years ago by poetzsch

You have updated to the newest guest additions as well? What are the symptoms now? The same as before?

comment:19 Changed 4 years ago by calum

Yes, guest additions are updated. Symptoms similar, if not quite identical. With VM running on external display, entering Seamless mode causes entire VM to migrate to laptop display. VirtualBox window decorations disappear, but guest background remains visible. VM remains in this state until exiting Seamless mode, at which point everything moves back to external display.

comment:20 Changed 4 years ago by poetzsch

Ok, might be 2 problems. Please use Host+Home when in seamless mode and check the new view menu. Try to set the other monitor as output. Still Linux guest, right?

comment:21 Changed 4 years ago by calum

It's an OpenSolaris guest (as it was when I posted those screenshots before).

Okay, I can move the VM back to the external monitor using that View menu, but the guest wallpaper still doesn't disappear, so I still can't see the host desktop.

comment:22 Changed 4 years ago by michael

  • Version changed from VirtualBox 1.6.2 to VirtualBox 3.1.6

Calum, did you stop the currently running copies of the daemons before starting the new ones? Not doing so is the normal reason for that message (the daemons place an advisory lock on the pidfiles to prevent additional instances from starting).

comment:23 Changed 4 years ago by calum

No, I just ran the commands I was told to run. Since I have no idea what they do, I was unable to surmise that they weren't sufficient :)

Attaching display.log and seamless.log files now. Note I did not have an external display attached when generating these, but seamless mode fails in the same way (without the screen-jumping behaviour, of course)-- in fact, if anything, it's worse, as the VBox window just mostly turned black whilst in 'seamless' mode this time.

Changed 4 years ago by calum

display.log file when switching to seamless mode and back (v3.2.0 b1)

Changed 4 years ago by calum

seamless.log file when switching to seamless mode and back (v3.2.0 b1)

comment:24 Changed 4 years ago by calum

(The 'turning black' thing appears to have been a one off, I haven't been able to subsequently reproduce that.)

comment:25 Changed 4 years ago by michael

What are the resolutions of your external monitor and built-in display?

comment:26 Changed 4 years ago by calum

My current MacBook Pro display is 1680x1050. External monitor is either 1920x1200 (office), or 1920x1080 (home).

(My old MacBookPro, which I had when I originally reported the bug, was 1440x900.)

comment:27 Changed 4 years ago by poetzsch

calum, we fixed also the second problem internally. I just tested it with a OpenSolaris VM on a second external monitor with a different resolution in Mac OS X. In fact your setup & it worked. Please give 3.2 beta 2 a try when it comes out. Thanks for your help.

comment:28 Changed 4 years ago by calum

Confirmed -- seamless mode seems to work very nicely in 3.2.0 Beta 2, with and without an external monitor. Thanks!

comment:29 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use