VirtualBox

Ticket #1662 (reopened defect)

Opened 6 years ago

Last modified 2 years ago

vbox goes to 100% CPU after resume on Ubuntu Hardy, 2.6.24-17-generic

Reported by: mw46 Owned by:
Priority: major Component: other
Version: VirtualBox 3.2.10 Keywords: Linux suspend
Cc: Guest type: other
Host type: Linux

Description

After some OS updates, my vboxes behave badly after a suspend/resume cycle. The vbox starts to use 100% CPU (basically one core on a dual-core laptop) but it does not do much anymore. It's very slow to respond and getting it to cleanly shut down is impossible.

VirtualBox: 1.6.0 (downloaded)

Host: Kubuntu 8.04, patched as of today, Linux kernel 2.6.24-17-generic

Guests:

  • Linux 2.6.23??
  • OpenSolaris release

Change History

comment:1 Changed 6 years ago by frank

Does this still happen? Can you make sure that this is not clipboard-related, that is, kill the VBoxClient process in the guest and check if that makes any difference to the CPU load.

comment:2 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

comment:3 Changed 5 years ago by brettbender

  • Status changed from closed to reopened
  • Resolution fixed deleted

I reproduced this issue today. Host is XP SP3, guest is Ubuntu Hardy 8.04.

On host, CPU was 50% utilization (VirtualBox.exe hogging one core of a Core 2 Duo), and on the guest a VBoxClient process was pegged at 98-100%.

Killing the VBoxClient process returned load to idle in guest and host.

Not related to suspend / resume, since I had done a cold boot a few hours earlier.

Possibly related to the clipboard, since I had been using the bi-di clipboard.

If this happens again, what sort of trace or debug info can I gather?

comment:4 Changed 5 years ago by michael

If you are up to it, a stack trace with gdb while it is going wild would be great. Make sure that you are using the additions from 2.0.4 (or at least that you know which version you are using!), since I would have to match addresses to functions "by hand".

comment:5 Changed 5 years ago by michael

I meant a stack trace of VBoxClient of course.

comment:6 Changed 5 years ago by cygn

I experienced the same as brettbender. Host is Vista SP2, guest Ubuntu Intrepid 8.10. I was copying text from a firefox in vista to a texteditor on ubuntu and then the clipboard sharing between windows and ubuntu stopped working. VBoxClient was at 98-100% cpu. This happened yesterday and today also. I'd make stack traces, but I'd like to know the steps for how to do this. Do I have to start VBoxClient with gdb or can I attach gdb later when the bug appears?

comment:7 Changed 5 years ago by cygn

I forgot to mention that this was on the must current Virtual Box Version 2.0.6 with corresponding guest additions.

comment:8 Changed 5 years ago by dannystaple

I was seeing this on an Ubuntu guest (Intrepid 8.10) and vista host. It turned out that there were 3 VBoxClient processes running. This also meant that the clipboard failed to share too. After killing all the VBoxClient processes, and manually starting one, it seems to be okay. I am watching to see if I have to do it again.

comment:9 Changed 5 years ago by michael

Is this still an issue?

comment:10 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing.

comment:11 Changed 4 years ago by asmbuster

  • Status changed from closed to reopened
  • Resolution fixed deleted

with my windows 7 guest on 3.2.8 VirtualBox on 2.6.34 kernel host this is still an issue

comment:12 Changed 3 years ago by yorua007

This is also an issue on my ubuntu10.04 with virtualbox 3.2.10.After suspend/resume cycle, the guest XP boot and respond very slowly,I can not even turn it off.

comment:13 Changed 3 years ago by frank

  • Host type changed from other to Linux
  • Version changed from VirtualBox 1.6.0 to VirtualBox 3.2.10

comment:14 Changed 2 years ago by pfong

I see the same issue. I hibernated my Xubuntu 11.04 64 bit guest with guest additions installed. This caused the VM to close. Then I started it again. Now in the guest "VBoxService" and "VBoxClient --clipboard" are using lots of CPU which causes Virtual Box to use lots of CPU on the host. I also noticed that now the Session Information box shows that the guest additions are not detected.

Summary:

Host: Windows 7 64 Bit

Guest: Xubuntu 11.04 64 bit (2 processors allocated)

VirtualBox: 4.1.4r74291

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use