VirtualBox

Ticket #16593 (closed defect: fixed)

Opened 9 months ago

Last modified 5 months ago

VM window size not being restored for jessie VMs -> fixed in releases higher than 5.1.22

Reported by: Bard0 Owned by:
Priority: minor Component: GUI
Version: VirtualBox 5.1.18 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Host is jessie (debian 8), VBox version is 5.1.18 (just recently updated from 5.0)

All VM's save and restore their window positions and size properly upon restarting them, except for the ones using jessie as guest too. Only the VM GUI position stays, the size gets reset to some (small) standard.

I am not familar enough with the virtualbox.xml file format (or vmname.vbox for that matter) to determine, if the problem exists at save time or at restore time.

Attachments

TVBrowser 3.4.4 auf debian-jessie-2017-03-23-18-24-36.log Download (133.2 KB) - added by Bard0 9 months ago.
GUI position restored, window size crippled
VBox.log Download (116.3 KB) - added by Bard0 7 months ago.
most recent logfile - with faulty resize + all black
Pure-jessie-2017-05-09-03-22-06.log Download (171.5 KB) - added by Bard0 7 months ago.
another (fresh) jessie-VM's log

Change History

comment:1 Changed 9 months ago by frank

A few questions:

  1. Do you have VirtualBox Guest Additions installed in the guest?
  2. Is this problem reproducible?
  3. How do you start the guest: Do you start from a saved state or do you boot your guest every time?

Would be also nice to have a VBox.log file of such a VM session (when the VM size was not properly retored).

Changed 9 months ago by Bard0

GUI position restored, window size crippled

comment:2 Changed 9 months ago by Bard0

  • Guest Additions are installed
  • Problem reproduces for EVERY jessie VM i am running
  • i always shutdown a guest, no live snapshots taken

luckily, i saw your question. can i ask for email notification, pls?

Last edited 9 months ago by Bard0 (previous) (diff)

comment:3 Changed 9 months ago by Bard0

just to let you know:

i created a new vm for jessie today (desktop gnome), installed it, updated it and installed guest additions into it, and without anything else being done, the crippled resize reoccurs. Definitely, that did not happen in the 5.0 branch, while i was still using it (until recently). the guest machines repositioned and resized properly.

the issue appeared with the switch to 5.1.18 (my starting point). Strangely, in the 60 other vm's i am using occasionally (no jessie among them), the problem does NOT exhibit itself!

looks like a very special weird interaction occurring between virtualbox and jessie only.

Last edited 9 months ago by Bard0 (previous) (diff)

comment:4 Changed 8 months ago by Bard0

Another observation:

For reasons, that do not matter here, i just had a peep at another OS (Ubuntu) and without changing anything (only mounting the virtualbox folders at the proper places), the problem did not exhibit itself! All the VM's opened where expected and with the size appropriate. - That shows, neither are the VM's defect nor any settings, nor virtualbox repositionning. But - the combination of a jessie host + vbox 5.1.18 + jessie guest was necessary to see the problem. I lack the skills to investigate that further, but my previous assumptions appear to be bogus. And, of course, there is a possibility showing up, that it *could* be related to the current jessie OS.

But this observation seems to be relevant for the assessment of the problem. :-)

comment:5 Changed 8 months ago by Bard0

From debian bug report system: Bug#860178 closed by Adrian Bunk <bunk@…> (Please report this to virtualbox.org)

This is, what i did in the first place. Sorry guys, it bounces back on you. Nonetheless: changing any part in the equation (host os, guest os, vbox version to 5.0) and the problem disappears. Looks like a regression to me!

comment:6 Changed 8 months ago by michael

So if I understand right, you used the same VM image in a different host OS and things worked? Does changing the version of the Additions installed (other versions should work fine even without changing the version of the host software) also make a difference?

comment:7 Changed 8 months ago by michael

Guest size restoring is mainly controlled by the Guest Additions by the way; the host part sends a request which the Additions carry out, which should be visible in the machine log in a line containing the word "resendSizeHint".

By the way, are you getting notifications for this bug ticket now?

comment:8 Changed 8 months ago by michael

I see in the log file that the guest is setting a resolution of 800x600 despite getting a different initial size hint. Some versions of GNOME tended to get stuck on a particular resolution. My memory says that they kept a file called monitors.xml somewhere in the user home directory, and that deleting that helped.

comment:9 Changed 8 months ago by Bard0

reply to comment no 6 - no 8: no 6: yes, same vm image + virtualbox.xml did work fine from ubuntu i didnt try installing the 5.0.x guest additions, although... if they work, (and they did in the past) that would confirm your theory. will give it a try...

no 7: i found no such entries in logs, but plenty of these: 00:00:44.707117 GUI: UIMachineView::sltPerformGuestResize: Sending guest size-hint to screen 0 as 1177x827 00:00:44.877604 GUI: UIMachineView::sltPerformGuestResize: Sending guest size-hint to screen 0 as 1206x787 00:00:44.884454 Display::handleDisplayResize: uScreenId=0 pvVRAM=00007faa30000000 w=1177 h=827 bpp=32 cbLine=0x1264 flags=0x5 00:00:44.887267 Display::handleDisplayResize: uScreenId=0 pvVRAM=00007faa30000000 w=1206 h=787 bpp=32 cbLine=0x12D8 flags=0x1 00:00:44.974262 GUI: UIFrameBufferPrivate::performResize: Size=1177x827, Directly using source bitmap content 00:00:45.089110 GUI: UIMachineView::sltPerformGuestResize: Sending guest size-hint to screen 0 as 1206x787

The VM in question has much more than other vms, since i had to manually resize it everytime

  • unfortunately, no notifications yet. i was lucky once again to have looked this up today by chance

no 8: in the VM, there is no monitors.xml file - nowhere.

comment:10 Changed 8 months ago by Bard0

Ok, here we go: with GA 5.0.38 the VM still doesnt resize properly on jessie

BUT: the exact same vm files + config do, while run from by backup OS (ubuntu trusty)

do not get confused: the vbox version used is 5.1.20 all the time by now

what i observe are several resize events:

  • initial size (maybe 640x..) during boot
  • next standard (maybe 800x...) happens on both systems
  • finally correct size (user configured from last shutdown) happens only on ubuntu

hope, this helps

Last edited 8 months ago by Bard0 (previous) (diff)

comment:11 Changed 8 months ago by michael

Interesting: you do not see the "resendSizeHint" line in the log files, but there is one in the log file you attached to this ticket (take a look to compare). Are they present when you boot with the Ubuntu host?

comment:12 Changed 8 months ago by Bard0

Hi Michael,

shame on me: my check for the resendSizeHint-lines failed due to a spelling error. Thanks for pointing out my mistake. using

find VirtualBox\ VMs/ -name \*.log -print0 | xargs -0 grep -ic resendSizeHint

i found every VM (except 4/63) have exactly one such line, which seems to indicate, that the size gets communicated to the vm, just not properly set on jessie-gnome (if on host AND on guest). Quite weird!

Could you NOT reproduce the behavior? I could with a fresh install (see above).

Last edited 8 months ago by Bard0 (previous) (diff)

comment:13 Changed 7 months ago by Bard0

This problem got worse! And this now appears quite serious:

Before the update to 5.1.22 (on .20), it was as described earlier, it showed as a simple resize-problem showing on jessie-gnome vs jessie-gnome.

After the update to 5.1.22, the same (working fine from Ubuntu, wrong size on jessie). But: After updateing the VM's guest additions, the jessie VM's (i did check several) only show a black window, and i could not determine the status of the VM, doesnt look like it is even getting to the resize.

Problem still affecting the jessie vm's only, AFAICT, but this is clearly worse than before, as the guest additions cannot be installed without basically killing the vm. Happy, i had a snapshot from before the update!

BTW: The black VM window now happens from jessie AND ubuntu-trusty (host) as well.

Last edited 7 months ago by Bard0 (previous) (diff)

comment:14 Changed 7 months ago by Bard0

Please raise the priority: this now is more serious, than just a GUI resize defect!

comment:15 Changed 7 months ago by Bard0

confusing discovery:

I just discovered, that i have ONE VM, which does NOT display the behavior described above, although it is a jessie-gnome based one.

To be more precise: no black window, only the wrong resize after starting up. And since it was maximized by default, the size did not matter anyway.

ATM, this leaves me clueless, as to what might cause the difference, but until i can pinpoint the latter, i just want to let you know about this.

The one vm is only used in very rare circumstances, as it gets created as an (almost) exact copy of my host prior to configuration experiments, i don't want to use the real host for. Hum... But this will take some time, as i am very busy these days. :-(

Last edited 7 months ago by Bard0 (previous) (diff)

comment:16 follow-ups: ↓ 17 ↓ 18 Changed 7 months ago by frank

Please attach another VBox.log file of your faulting VM running with VBox 5.1.22.

Changed 7 months ago by Bard0

most recent logfile - with faulty resize + all black

comment:17 in reply to: ↑ 16 Changed 7 months ago by Bard0

Replying to frank:

Please attach another VBox.log file of your faulting VM running with VBox 5.1.22.

hi, there it is: done with the new GA.

btw: in the meantime, i found: the black window must come from the machine itself, and i am in the process of rebuilding all my jessie based ones, as indicated earlier, the new ones don't go black. But the missing (last) resize remains. But only for jessie. on stretch, it works just fine.

Changed 7 months ago by Bard0

another (fresh) jessie-VM's log

comment:18 in reply to: ↑ 16 Changed 7 months ago by Bard0

Replying to frank:

Please attach another VBox.log file of your faulting VM running with VBox 5.1.22.

Hi again, i just added another log from a fresh jessie. This one no longer goes black, but it restores wrong screen size. From reading inside the log, i see plenty of

GUI: UIMachineView::storeGuestSizeHint: Storing guest-screen size-hint for screen 0 as 800x600

which is wrong. The correct numbers were there at the beginning:

SetVideoModeHint: Got a video mode hint (1163x776x32)

hope this helps somewhat. Bard0

comment:19 Changed 7 months ago by Bard0

* IMPATIENCE * After communication such a clear reproducer, it is hard to not get anything back. As switching to stretch is not an option for me (due to software incompatibilities), i found a way to work around the problem locally by using vboxmanage in combination with wmctrl. not elegant, even unstable in some circumstances, but it alleviates the pain somewhat.

comment:21 Changed 7 months ago by Bard0

Hi, and sorry for being late: without receiving notifications, it always is by chance of me noticing communication here.

I force-installed the 64-bit version, ignoring quite some messages, due to the installation not finding the expected environment. But since it was just for testing... who cares :)

And after running the test version from commandline, i can confirm: hooray! This time the screen position and size got treated properly with host+guest being debian jessie. Congrats! You got your hands on it.

After this test, i am going to rollback to the official release, waiting for the fix to make it to 5.1.24 hopefully. :-)

comment:22 Changed 6 months ago by michael

  • Summary changed from VM window size not being restored for jessie VMs to VM window size not being restored for jessie VMs -> fixed in releases higher than 5.1.22

Thank you for testing.

comment:23 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 5.1.24.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use