VirtualBox

Ticket #1655 (closed defect: fixed)

Opened 6 years ago

Last modified 3 years ago

Critical Error when Starting in XP 32-bit

Reported by: cubsftw Owned by:
Priority: critical Component: other
Version: VirtualBox 1.6.0 Keywords: COM object, assertion failed
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

I've been trying to get Virtual Box versions 1.4-1.6 working on my Windows XP SP2 32-bit machine for a while with no success. I've tried the methods in the FAQ's and forums and they haven't worked (i.e.: starting VBoxSVC.exe manually). This is the error message that comes up after I try to start the program:

Virtual Box- Critical Error Failed to Create the VirtualBox COM object. The Application Will Now Terminate.

Assertion failed at 'C:\vbox\32\w32-rel\src\VBox\Main\VirtualBoxImpl.cpp' (271) in VirtualBox::init.
Unknown exception
.
Please contact the product vendor!.

Result Code: E_FAIL (0x80004005) Component: VirtualBox Interface: IVirtualBox {2d3b9ea7-25f5-4f07-a8e1-7dd7e0dcf667} Callee RC: E_NOINTERFACE (0x80004002)

I appreciate your help in resolving this ticket.

Best Regards,

Peien Liu

Attachments

f27c_appcompat.xml Download (22.7 KB) - added by lwesker 6 years ago.
XML file of active process detected by dwwin.
CCE714.dmp Download (91.5 KB) - added by lwesker 6 years ago.
Dwwin dump file in binary. I couldn't capture equivalent on-screen text.
LVCOMSX.LOG Download (6.6 KB) - added by lwesker 6 years ago.
COM related file created at same time as dump.
VBoxSVC.dmp Download (33.6 KB) - added by dcarpman 5 years ago.
minidump when plugging in a USB hard drive
9e39_appcompat.txt Download (34.9 KB) - added by Michael Wakileh 4 years ago.
5667_appcompat.txt Download (35.5 KB) - added by pkx 4 years ago.
MS crash report after attaching USB while VBox GUI is running
VBox.log Download (57.4 KB) - added by pkx 4 years ago.
regular VBox.log without USB disk attached

Change History

comment:1 follow-up: ↓ 33 Changed 6 years ago by andrei.tulai

I am also having this issue.

My problem was my external HDD. If I keep it plugged in, then attempt to run VirtualBox, I get the exact error mentioned above. If I don't have the external HDD connected, then it works perfectly. If I then try to plug in the HDD, it crashes and becomes unusable.

I am also using XP Pro SP3 32 bit. I will try this in Vista to see if there is any difference.

comment:2 Changed 6 years ago by frank

Andrei, was your external HDD a USB device? And did you set up any USB filters? cubsftw, from which version did you report the above error?

comment:3 Changed 6 years ago by andrei.tulai

Yes, the HDD was a USB device and no I didn't set up any filters. VirtualBox itself won't start up because of my HDD being connected to the computer, so unless I can set a USB filter for the HDD without the HDD being connected, there is no way for me to set a filter anyway.

Although I'm fairly sure I tried removing or making sure that no USB devices were enabled in VBox and then tried it only to get the same thing.

comment:4 Changed 6 years ago by andrei.tulai

This is not an XP only issue, nor is it a 32bit only issue. It's happening on my Vista Business 64 installation also. The error was a little different though. I will post it as soon as I get the chance.

comment:5 Changed 6 years ago by andrei.tulai

In Vista Business 64 I get:

Failed to create the VirtualBox COM object.

The application will now terminate.

Callee RC: CO_E_SERVER_EXEC_FAILURE 0x80080005

Changed 6 years ago by lwesker

XML file of active process detected by dwwin.

Changed 6 years ago by lwesker

Dwwin dump file in binary. I couldn't capture equivalent on-screen text.

Changed 6 years ago by lwesker

COM related file created at same time as dump.

comment:6 Changed 6 years ago by lwesker

I have nearly the same problem described (the callee code is different), with the same conflict with the USB subsystem appended by "andrei.tulai". I am not sure if this should be a different ticket since the error code differs from the originator "cubsftw", but since he has not replied if his problem matches, I am assuming the ticket has evolved. This bug is still not fixed as of v2.0.0. My problem history is in forum topic:

 VirtualBox fails to start, assertion failure

A fresh install of VirtualBox (with no machines and empty .VirtualBox directory) crashes on start with:

Assertion failed at 'C:\vbox\32\w32-rel\src\VBox\Main\VirtualBoxImpl.cpp' (301)
 in VirtualBox::init.

I get more detail on the error using VBoxManage:

C:\Program Files\Sun Microsystems\xVM VirtualBox>vboxmanage createvdi
 -filename xxx -size 64
VirtualBox Command Line Management Interface Version 2.0.0
(C) 2005-2008 Sun Microsystems, Inc.
All rights reserved.

[!] Failed to create the VirtualBox object!
[!] Primary RC  = E_FAIL (0x80004005) - Unspecified error
[!] Full error info present: true , basic error info present: true
[!] Result Code = E_FAIL (0x80004005) - Unspecified error
[!] Text        = Assertion failed at 'C:\vbox\32\w32-rel\src\VBox\Main\
VirtualBoxImpl.cpp' (301) in VirtualBox::init.
Unknown exception
.
Please contact the product vendor!
[!] Component   = VirtualBox, Interface: IVirtualBox, {557a07bc-e6ae-4520-
a361-4a8493199137}
[!] Callee      = <NULL>, {00000000-0000-0000-0000-000000000000}

C:\Program Files\Sun Microsystems\xVM VirtualBox>

As indicated by "andrei.tulai", the conflict is with having an attached USB hard drive. With the drive attached, VirtualBox fails to start. With the drive removed, all runs OK. If the USB hard drive is attached while VirtualBox is running, it immediately crashes with the Microsoft error window:

Error signature
    AppName: vboxsvc.exe    AppVer: 1.0.0.1    ModName: vboxrt.dll
    ModVer: 0.0.0.0    Offset: 00027676

I have also attached the debug and trace files that XP would phone home to report the crash to Microsoft.

Interesting, the problem does not occur on other computers with similar attached USB hard drives. So there must still be some third party catalyst that is triggering the conflict on select systems and preventing Sun from duplicating the problem. Hopefully, I have attached enough information to finally trace the bug through a debugger and source code.

Also interesting is the problem is not all USB drives. With a 16 GB flash, the program runs, but with a 300 GB hard disk, the program fails.

comment:7 Changed 6 years ago by sflynn

I'm also having the exact same problem as lwesker above.

VirtualBox just dies when my Seagate 120gb usb drive is plugged in.

comment:8 Changed 6 years ago by lwesker

I found the problem follows the drive. I moved it to four other VirtualBox installations. In all cases, the program fails to start when the drive is attached. In my case it is a Seagate 300 GB. Maybe its a Seagate conspiracy ;-)

comment:9 Changed 6 years ago by andrei.tulai

Hmmm that's kinda funny mine is also a Seagate HDD, except it's inside a Western Digital MyBook Case.

comment:10 Changed 6 years ago by LNRDGHN

I got this exact problem (Assertion Failed) too when trying to open VirtualBox 2.0.2. In my case it was due to my USB modem.

I reinstalled with the USB support option disabled and it starts up fine for me now.

comment:11 Changed 6 years ago by colderthanice

Also I got this problem. I have closed USB support and reinstalled. But nothing changed. It is again crashing.

comment:12 Changed 6 years ago by frank

  • Host type changed from other to Windows
  • Description modified (diff)

So most people except colderthanice agree that this has something to do with USB support, right? Please could you test this with VBox 2.0.2 and attach a minidump in case VBoxSVC crashes again?

comment:13 Changed 6 years ago by lwesker

Interesting andrei.tulai, my SATA 300 GB Seagate drive causing this problem is also in a Western Digital MyBook case. Frank, since I have rearranged my components (swapping the problem drive with a different machine at another location), it may take me a few days to pull all the pieces back together to test VBox 2.0.2.

comment:14 Changed 6 years ago by lwesker

No change with v2.0.2, except the error line number is now 306.

As mentioned earlier, the crash seems to be in vboxrt.dll. When the USB drive is disconnected, VirtualBox starts up normally. If the drive is plugged in while VirtualBox is running, it crashes. The Microsoft error box shows:

Error signature
    AppName: vboxsvc.exe    AppVer: 1.0.0.1    ModName: vboxrt.dll
    ModVer: 0.0.0.0    Offset: 00027676

Note the offset changed from v2.0.0 which was 00027606.

Frank, please elaborate on what file and where is the "minidump" you want sent. All I could find were the Microsoft error report XML and DMP files which I already attached for v2.0.0.

comment:15 Changed 6 years ago by frank

lwesker, please check the minidump section of our FAQ. It might be that you have to enable minidumps at first.

comment:16 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

No reply for three months. Closing. Please try again with 2.1.0 and reopen if required.

comment:17 Changed 5 years ago by christoph.schmidt

  • Status changed from closed to reopened
  • Resolution worksforme deleted

I have a similar Problem with my KVM Switch. When it is plugged in VirtualBox won't startup.

Just installed "VirtualBox-2.1.0-41146-Win_x86" on my MacBook Pro C2D. I run it on Windows XP SP2. The KVM Switch is an LevelOne KVM-0420. It is connected via USB.

It even doesn't help to unplug it and reconnect it after startup of virtualbox. It crashes 1 second after i plug in the kvm switch ;-(

Is there a fix for this?

comment:18 Changed 5 years ago by frank

Christoph, what does that mean, VirtualBox won't startup? Will the GUI refuse to start or does any VM crash? If the latter, could you attach a VBox.log file?

comment:19 Changed 5 years ago by christoph.schmidt

I'm sorry. Here are more details:

It crashes on startup of the gui (i don't get to the point that i can create an virtual machine).

An ErrorMsg appears (i didn't manage to copy the text from it, so there may be typing errors...) that tells me:

Assertion failed at C:\vbox\32\w32-rel\src\VBox\Main\VirtualBoxImpl.cpp (309) in VirtualBox::Init

Unknown Exception

Fehlercode: E_FAIL (0x80004005) Komponente: VirtualBox Interface: IVirtualBox {339abca2-f47a-4302-87f5-7bc324e6bbde} Callee RFT: E_NOINTERFACE (0x80004002)

comment:20 Changed 5 years ago by christoph.schmidt

Fehlercode: E_FAIL (0x80004005)

Komponente: VirtualBox

Interface: IVirtualBox {339abca2-f47a-4302-87f5-7bc324e6bbde}

Callee RC: E_NOINTERFACE (0x80004002)

comment:21 Changed 5 years ago by lwesker

I see the problem still has not been examined or fixed, despite all the clues and pointers where to look (USB initialization) and very specific part numbers that VB crashes on. It does not appear that Sun has done any debug triage yet.

I notice it is not just HDD but USB KVM and Modems. Just saying "try version x.y.z and let us know if by some miracle the problem went away" is a waste of the user community's life.

When I see status closed due to "resolved" instead of closed due to "no reply", then I will try the latest version. Until then, VirtualBox is abandoned. There are plenty of competing products to use instead.

comment:22 Changed 5 years ago by frank

lwesker, you might believe that the current information is enough to debug this problem but you are wrong. As it seems to me this has something to do with a specific USB device and as long as we cannot reproduce the problem we cannot fix it. When I ask you or other users to check if a bug was resolved then not because I believe in miracles.

I asked you to add a minidump and even provided you a link where to find the information on how to create a minidump (2008-09-24) but so far no response from your side. Therefore I find it kind of surprising that you are talking of wasting the user community's life. The information which was provided in this ticket does not have much use for us, even if you think that it is specific. The important thing is that VBoxSVC crashed and a minidump could help to investigate.

comment:23 Changed 5 years ago by sandervl73

lwesker: support for the *free* version of VirtualBox is on a best effort basis only. This also implies that users reporting problems actively participate in the search for useful information. Most users actually do and are grateful for the help we can provide in between our busy schedule. And we do appreciate their efforts.

It seems you feel this is a waste of your time and that's unfortunate. Posting insulting remarks does not help.

comment:24 Changed 5 years ago by dcarpman

Hi, I have a similar problem with USB Hard disks connected to the host. Version: VirtualBox-3.0.2-49928-Win.exe Host: Windows XP 32bit Guest: Fedora 11 32bit

When I have my USB hard disk connected (Seagate ST912082 2A) and try to start Virtualbox, I get a popup: Failed to create the VirtualBox COM object.

The application will now terminate.

Assertion failed at 'C: \vbox\branch\win-3.0\src\VBox\Main\VirtualBoxImpl.cpp' (331) in VirtualBox::init.

Unknown exception.

Please contact the product vendor!. Details

Result Code: E_FAIL (0x80004005) Component: VirtualBox Interface: IVirtualBox {3f4ab53a-199b-4526-a91a-93ff62e456b8}

-- If I disconnect the USB drive, VirtualBox starts and all is good. If I then plug in the drive, I get a crash. The Guest seems to continue to run even though VBoxSVC crashed.

I'll attach the minidump file VS2005 wrote for me.

Thanks!

Changed 5 years ago by dcarpman

minidump when plugging in a USB hard drive

comment:25 Changed 4 years ago by sky_hit

I have a new one:) my virtual box 3.0.6 was working fine with my PC till two weeks ago. now when I start it, it give me the same error you are talking about. so I try removing any new software istallation or hardware HDD or DVD-ROM. but still not solved. I even tryed to reinstall virtualbox with not USB support but no use. any help!?

comment:26 Changed 4 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please reopen if this problem persists with VBox 3.1.6.

Changed 4 years ago by Michael Wakileh

comment:27 Changed 4 years ago by Michael Wakileh

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hi...unfortunately this problem still persists when starting up Virtual box 3.1.6. on a Windows XP SP3 host system with Western Digital ext. usb harddrive attached:

Fehlercode: E_FAIL (0x80004005

Komponente: VirtualBox Interface:

IVirtualBox {2158464a-f706-414b-a8c4-fb589dfc6b62}

Virtual box does not start up.


When starting VBOX FIRST and then attaching the usb drive VBOX has the following problem: a window pops up indicating VBOX Interface has had a problem and must be ended. "VirtualBox Interface hat ein Problem festgestellt und muss beendet werden."

the microsoft crash report shows Problem signature : AppName: vboxsvc.exe AppVer: 3.1.6.0 ModName: vboxrt.dll ModVer: 0.0.0.0 Offset: 0003ff56

I have attached technical log of the problem report (9e39_appcompat.txt)...unfortunately the dump file could not be copied... The virtual box application does not close... it persists.

Virtual Box 3.1.6 is a fresh install and I have not created any Virtual Machines with it yet...

Changed 4 years ago by pkx

MS crash report after attaching USB while VBox GUI is running

comment:28 follow-up: ↓ 29 Changed 4 years ago by pkx

I can also reliably reproduce the problem - happens when starting VBox GUI with USB disk attached. I tried different disks with different USB adapters and the problem only happens with one specific combination of 100GB Seagate disk and WD USB adapter.

I was trying to get a minidump, but FAQ only refers to article describing how to enable and read minidumps (i have them enabled), but VBox crash does not create any minidump (i also checked via procmon).

I only get the Critical Error message:

Failed to create the VirtualBox COM object. The application will now terminate.

Unknown exception.

D:\tinderbox\win-3.2\src\VBox\Main\VirtualBoxImpl.cpp[535] (VirtualBox::init).

Details: Result Code: E_FAIL (0x80004005) Component: VirtualBox Interface: IVirtualBox {3f36e024-7fed-4f20-a02c-9158a82b44e6}

When plugging the USB disg while VBOX UI is running - i get microsoft crash report (attached 5667_appcompat.txt). Regular vbox.log from session without USB disk attached is also attached. Please advise how could i provide more useful info.

Changed 4 years ago by pkx

regular VBox.log without USB disk attached

comment:29 in reply to: ↑ 28 Changed 4 years ago by pkx

VirtualBox 3.2.4 r62467 win.x86 (Jun 8 2010 13:29:15) release log OS Product: Windows XP Professional, OS Release: 5.1.2600, OS Service Pack: 3 Host RAM: 3070MB RAM, available: 1937MB

comment:30 Changed 4 years ago by darkwedder

Hi all. Under Windows 7 I got: Result Code: E_FAIL (0x80004005) That happened after chipset drivers update.

Though, after disabling "Use host I/O cache" option, it got working again.

comment:31 Changed 4 years ago by kickmyjiminy

I was also getting this error and couldn't at first understand why. Then I had realized that I had taken the guest OS's cd out of the drive, and that's when the problem started. So I removed the dvd drive from the list of virtual drives, and presto, the guest OS booted up no problem. Running Windows 7 64 bit VBox 3.2.6 OpenSuse 11.2 guest OS

On another note, for some reason Virtual Box had my dvd drive as an IDE device when it is actually SATA.

comment:32 Changed 4 years ago by pottedmeat

I am running version 3.2.4 r62467. I've been using VirtualBox with no issues for months, then suddenly I received the "Result Code: E_FAIL (0x80004005)" message when trying to start my Linux VM. After reading all of the posts above, I decided to closely examine the devices configured for my VM, and noticed that there were two network interfaces - one for the built-in ethernet port and one for wireless. The wireless adapter on my laptop had been disabled by me a couple of days ago. After enabling it, the VM started up with no problems. I guess VirtualBox needs to see an exact match between the list of devices for a VM and the actual available devices on the host OS.

comment:33 in reply to: ↑ 1 Changed 4 years ago by petrjung

Replying to andrei.tulai:

I am also having this issue.

My problem was my external HDD. If I keep it plugged in, then attempt to run VirtualBox, I get the exact error mentioned above. If I don't have the external HDD connected, then it works perfectly. If I then try to plug in the HDD, it crashes and becomes unusable.

I am also using XP Pro SP3 32 bit. I will try this in Vista to see if there is any difference.

Solved in my case. The McAfee anti-virus revoke users permition on creating the COM+ object. Just administrator can. Please test if it is possible to install and run it as an Administrator. If yes, replace the regedit permissions all to CURRENT_USER root key. Petr

comment:34 Changed 3 years ago by bd

Also happens for me with 3.2.10 trying to start an debian lenny image. Enabling the USB Controller in the VMs configuration made this problem go away. However performance is now low. really low.

comment:35 Changed 3 years ago by frank

bd, please attach a VBox.log file of such a VM session.

comment:36 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use