Ticket #16549 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

Shared folder became case sensitive after update to 5.1.16 (Centos 7.3 Hosts/Win10 Guest)

Reported by: HRZunibi Owned by:
Component: shared folders Version: VirtualBox 5.1.16
Keywords: Cc:
Guest type: Windows Host type: Linux


After update to the latest version of VBox my shared folder became nearly unusable as it is now working as case sensitive. Prior to the update it was running as "case insensitive". This results in protable executables not finding their DLLs any longer. I read that this was a very old bug and fixed several relases ago...


Logs_from_ucrasher2.7z Download (28.0 KB) - added by ucrasher2 6 years ago.
name case still fails even with 5.1.17 xxx68

Change History

comment:1 Changed 6 years ago by HRZunibi

After downgrading to 5.1.14 via yum downgrade VirtualBox-5.1 (Guest Additions still 5.1.16 on Guest). Everything is now working again.

comment:2 Changed 6 years ago by JackieKu

I am suffering from this bug, too. With Windows 8.1 guest and 5.1.16/5.1.14 guest additions installed, the host is Linux 4.9.13.

It should be noted not all usage patterns become case sensitive, perhaps only a subset of Windows API is affected.

VirtualBox 5.1.14 was fine.

comment:3 Changed 6 years ago by CoolBalance

FYI. I'm experiencing the same issue. Ubuntu 16.10 host, various microsoft windows guests. VirtualBox 5.1.14 is fine. 5.1.16 is when the issue occurs.

comment:4 Changed 6 years ago by frank

Confirmed. The more recent 5.1.x test builds have a fix. And there are also fixed builds for EL7 and Ubuntu 16.10. Could you confirm the fix?

comment:5 Changed 6 years ago by fluid

I had the same problem with 5.1.16 on Opensuse Leap42.1 linux host with Windows 2000 as guest. As all my files were upper case anyhow, I only needed to add a couple of upper case symbolic links to the mixed case directory names in the path. The problem did not exist in 5.1.14 or earlier releases. (I reported this in the forum first, but reported the problem solved after I discovered origin and tested my work around.)

Regards, Fluid

comment:6 Changed 6 years ago by s0u1

Host Debian 8.7 3.16.0-4-amd64, guest Win 7 x 32 SP1, VirtualBox 5.1.16 r113841 (Qt5.3.2), guest additions installed - Error exists!

Version 0, edited 6 years ago by s0u1 (next)

comment:7 Changed 6 years ago by HRZunibi

I just tried the test build 5.1.17_113974 and tested some folders on my virtual Win10. So far it works. (GuestAdditions still stable version 5.1.16). THX! Regards, Peter.

Changed 6 years ago by ucrasher2

name case still fails even with 5.1.17 xxx68

comment:8 Changed 6 years ago by ucrasher2

Here the GA 113868 still does not help. I went back to GA from 5.1.14, but that did not help as well. In my case the compiler(MSVC2014) does not find include files if the name cases do not match the files. I zipped both logs and attached (Logs_from_ucrasher2.7z).

I fear I must go back to 5.1.14 for now.

PS: Let me say thanks a million for all the hard work the VB team does.

comment:9 Changed 6 years ago by HRZunibi

@ucrasher2: Have you tried 5.1.17 113974 instead of 113868? That was the build that worked for me.

comment:10 Changed 6 years ago by sunlover

ucrasher2, r113868 does not contain the fix. Please use r113974 or newer.

comment:11 Changed 6 years ago by frank

And keep in mind: The fix is at the host side, not at the guest side!

comment:12 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in VBox 5.1.18.

comment:13 Changed 6 years ago by HRZunibi


comment:14 Changed 6 years ago by ucrasher2

5.1.18 works fine regarding name cases here. Thanks!

comment:15 Changed 6 years ago by fluid

same here: 5.1.18 works fine again, my work-around (symbolic links) removed. Thanks.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use