VirtualBox

Ticket #16505 (closed defect: fixed)

Opened 17 months ago

Last modified 13 months ago

Chapter 3.3.2 “Advanced” tab, needs editing. And "User Interface" settings is missing.

Reported by: socratis Owned by:
Priority: major Component: documentation
Version: VirtualBox 5.0.0 Keywords:
Cc: Guest type: all
Host type: all

Description

For Ch. 3.3.2

  • The "Mini-toolbar" settings are not there, they're under "User Interface".
  • The "Removable Media" settings are not there, they're nowhere to be found. AWOL...
  • There is no chapter about the "User Interface" settings. At all.

I suspect this in a quite old one, and although we're on 5.1.14, I filed it with the version set as 5.0.0, so that the 5.0.x series manual can be fixed as well...

Change History

comment:1 Changed 16 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the information. Fixed in VBox 5.1.16.

comment:2 Changed 16 months ago by socratis

  • Status changed from closed to reopened
  • Resolution fixed deleted

Hmm... Unless the changes in the User Manual didn't make it, neither the PDF itself, nor a source code comparison show any modifications in that area.

  1. I'm looking at the 5.1.4 and 5.1.6 PDFs side-by-side, no change.
  1. The only modification in the User Manual between versions 5.1.14 and 5.1.16 when comparing the source code trees, is in "doc/manual/user_ChangeLogImpl.xml" with 7 entries; 1 for the 5.1.16 release notes, and 6 more cosmetic ones.
  1. In the trunk there's nothing there to indicate a change: https://www.virtualbox.org/browser/vbox/trunk/doc/manual/en_US?order=date&desc=1 . On the other hand this is not the most accurate/recent one, since the latest changelog describes version 5.1.4! Oops...

So, with all due respect, I believe that this is not fixed and I'm reopening it.

comment:3 Changed 16 months ago by frank

I'm sorry. You are right and I'm wrong. I was 100% sure that I backported r65861 to 5.1. Must have forgotten this.

comment:4 Changed 16 months ago by socratis

OK, got it in the tree, including your changes. Two questions:

  1. What do you mean "backported to 5.1"? Are you working on 6.4.x already? :) (of course I don't expect an answer on this one)
  1. Why is the change log not updated in the source code browser? (https://www.virtualbox.org/browser/vbox/trunk/doc/manual/user_ChangeLogImpl.xml)

comment:5 Changed 16 months ago by frank

  1. For our daily work we use a development repository. In subversion this is usually 'trunk'. This development repository is the target for all commits including unstable and untested code. Dedicated changesets which are treated as eligible are backported to a stable branch. 5.1 is a stable branch for all 5.1.x maintenance releases. Of course we try to backport only changesets which can be treated as safe. Most parts of the development repository is mirrored to here. The stable branches are not accessible for public users.
  2. The changelog of trunk is only relevant for trunk changes. Because we backport certain changes from trunk to stable branches it does not make sense to update the trunk changelog as long as the next relesae is not build from trunk.

Regarding this ticket my change is now part of 5.1.18. Section 3.12 User Interface was added. Would be nice if you could have a short look in case I forgot something. Thanks!

comment:6 Changed 16 months ago by socratis

Checked and confirmed in all three places: User Manual (PDF), source code, trunk browser. This can now be put to rest...

comment:7 Changed 16 months ago by socratis

Actually it would be better if I could also check it in the GUI as well, but that's another ticket, #16504.

comment:8 Changed 13 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use