VirtualBox

Ticket #16348 (closed defect: fixed)

Opened 19 months ago

Last modified 3 weeks ago

VM crash with segfault on host

Reported by: kaese Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.12 Keywords:
Cc: Guest type: all
Host type: Linux

Description

Hi,

following problem:

Host: "vanilla" Debian Jessie 8.6 kernel 3.16.0-4-amd64 (as of 'uname -r') VirtualBox 5.1.12-112440 (installed from virtualbox.org repos)

Guest: fresh install of Archlinux (64 bit) with guest additions

Issue: As soon as the X-server comes up in the guest, the virtual machine crashes going to state "Aborted".

dmesg shows something like this:

VirtualBox[1776]: segfault at 20 ip 00007f2a34b2f5b0 sp 00007fff7d3a6470 error 4 in libxcb-image.so.0.0.0[7f2a34b2d000+4000]

VM logfile attached.

The issue also occured under 5.1.10.

Here you can find a report from an other user with the same problem - but with a Windows guest:  https://forums.virtualbox.org/viewtopic.php?f=2&t=78834

Attachments

Arch-2017-01-03-03-52-05.log Download (75.6 KB) - added by kaese 19 months ago.
Logfile of crashed VM

Change History

Changed 19 months ago by kaese

Logfile of crashed VM

comment:1 Changed 19 months ago by kaese

New finding: When I deinstall guest additions in the guest (Archlinux), then the issue is gone. This is 100% reproducable.

Things obviously are linked to guest additions.

comment:2 Changed 18 months ago by frank

Does this still happen with VBox 5.1.14? Can you provide a core dump?

comment:3 Changed 18 months ago by kaese

Yes, just upgraded everything (VirtualBox and guest additions). Still the same problem on 5.1.14.

I will check if I can create a core dump.

comment:4 Changed 18 months ago by kaese

Ok, got a dump. It's about 7 MB compressed. So where to put it? ftp.oracle.com:/appsdev/incoming as mentioned in the wiki seems to be down. Can't ping, can't connect.

comment:5 Changed 18 months ago by ark

I'm seeing something very similar with 5.1.14, with one interesting distinction: the segfault occurs for me only when I'm viewing VirtualBox Manager and the VM over VNC (as in, VNC to host X11). Viewing it on the physical hardware works just fine. I'm also on Debian Jessie.

By the way, the reason I say "viewing" is that, when the VM is started in headless or detachable mode, it's only the viewer that crashes - not the VM host process.

EDIT: I can confirm that this also happens on Ubuntu 16.04.1, again only over VNC. This is on two very different machines - Debian on a newer AMD CPU and AMD GPU desktop, and Ubuntu on an older Intel CPU and nVidia GPU laptop. VirtualBox 5.0.32 does not have the issue.

Last edited 18 months ago by ark (previous) (diff)

comment:6 Changed 18 months ago by kaese

Yesssssss! Same here, too. Since my host is a (real) headless server, all I do is always over VNC. Also starting VirtualBox. Didn't mention it, since I didn't think it makes any difference. But since there is no monitor connected to the server hardware, never tried it "locally" either.

Thanks for hinting on this crucial detail!

EDIT: BTW, still waiting for something to send the dump to.

Last edited 18 months ago by kaese (previous) (diff)

comment:7 follow-up: ↓ 9 Changed 18 months ago by imbs

Over the past couple of days, I have seen this segfault several times as well. The really bad thing about this is that it aborts my Windows 7 VM, and aborts X11 on the LinuxMint host, so ALL of my work in both the guest AND the host is lost.

Very frustrating!!!

One thing that changed that might be related is that VirtualBox hasn't been restoring the window size of the second virtual monitor when I boot the Guest OS. I have to resize the window manually, but then the bottom VB status line doesn't get positioned at the bottom like it should be. I can correct that by maximizing, then unmaximizing the second virtual monitor. The segfault happens much later, not immediately.

I have attached a few pertinent lines below from my LinuxMint dmesg log, which shows a segfault happening on two different occasions since my last reboot of Linux. Let me know if you need more info.

Host: LinuxMint 18, AMD Phenom II X4 965, 24Gb RAM, 512Gb SSD Guest: Windows 7 x64 all updates applied VirtualBox: Version 5.0.32-dfsg-0ubuntu1.16.04.2

GUI Version 5.1.14r112924 (Qt5.5.1)

I'm not sure why the VB runtime is 5.0.32 and the GUI is 5.1.14; I did a clean install a couple of weeks ago from the virtualbox dot org site and that has to be what was installed at the time...

dmesg log excerpt:

[   12.974403] vboxdrv: Found 4 processor cores
[   12.993781] vboxdrv: TSC mode is Invariant, tentative frequency 3655034147 Hz
[   12.993784] vboxdrv: Successfully loaded version 5.1.14 (interface 0x00280000)
[   13.244071] VBoxNetFlt: Successfully started.
[   13.246076] VBoxNetAdp: Successfully started.
[   13.247433] VBoxPciLinuxInit
[   13.252574] vboxpci: IOMMU not found (not registered)
[  547.358868] vboxdrv: ffffffffc13db020 VMMR0.r0
[  548.448859] vboxdrv: ffffffffc1320020 VBoxDDR0.r0
[  548.721628] VBoxNetFlt: attached to 'enp6s0' / xx:xx:xx:xx:xx:xx
[  548.792319] vboxdrv: ffffffffc0006020 VBoxEhciR0.r0
[ 5266.989188] VirtualBox[3709]: segfault at 18 ip 00007fd0253f3730 sp 00007ffecc709798 error 4 in libxcb.so.1.1.0[7fd0253e5000+21000]
[ 5266.990151] VirtualBox[3655]: segfault at 18 ip 00007fe1c6f57730 sp 00007ffd091fe078 error 4 in libxcb.so.1.1.0[7fe1c6f49000+21000]
[ 5267.550870] vboxnetflt: 0 out of 55929 packets were not sent (directed to host)
[ 5330.814999] vboxdrv: ffffffffc13db020 VMMR0.r0
[ 5331.897327] vboxdrv: ffffffffc1320020 VBoxDDR0.r0
[ 5332.228278] VBoxNetFlt: attached to 'enp6s0' / xx:xx:xx:xx:xx:xx
[ 5332.330920] vboxdrv: ffffffffc0006020 VBoxEhciR0.r0
[17915.903974] VirtualBox[6199]: segfault at 0 ip 00007f5082d46a20 sp 00007fffca951600 error 4 in libQt5Gui.so.5.5.1[7f50829d3000+527000]
[17915.926581] VirtualBox[6124]: segfault at 18 ip 00007f8a7acdd730 sp 00007ffd6468c5b8 error 4 in libxcb.so.1.1.0[7f8a7accf000+21000]
[17916.691317] vboxnetflt: 30 out of 80722 packets were not sent (directed to host)
Last edited 16 months ago by frank (previous) (diff)

comment:8 Changed 17 months ago by itchybox

+1

My config is three monitors, Win 7 VM using the right two, X11 VM on the left one. I was cutting and pasting between them at the time and probably crowding the RAM with so much stuff at once. Symptom was all focus was lost, I could move my mouse around but it wouldn't then highlight a window. RightCrtl-F worked once to make the X11 go from full screen to window mode, but then everything was unresponsive except moving around the mouse.

CentOS 6.8 x86_64 host O.S., all RPMs current. VirtualBox-5.1-5.1.14_112924_el6-1.x86_64 plus matching extension pack.

I had to Ctrl-Alt-Backspace to kill the underlying host X11 and it then rebooted immediately.

The crash data didn't hang around...

Feb 21 16:27:47 moist kernel: VirtualBox[7505]: segfault at 18 ip 0000003d0940eb10 sp 00007ffd105d73a8 error 4 in libxcb.so.1.1.0[3d09400000+1e000]
Feb 21 16:27:47 moist kernel: VirtualBox[7561]: segfault at 18 ip 0000003d0940eb10 sp 00007ffe0e7d72b8 error 4 in libxcb.so.1.1.0[3d09400000+1e000]
Feb 21 16:27:47 moist kernel: VirtualBox[7613]: segfault at 18 ip 0000003d0940eb10 sp 00007ffcd41f6298 error 4 in libxcb.so.1.1.0[3d09400000+1e000]
Feb 21 16:27:48 moist abrt[8768]: Saved core dump of pid 7505 (/usr/lib/virtualbox/VirtualBox) to /var/spool/abrt/ccpp-2017-02-21-16:27:47-7505 (81281024 bytes)
Feb 21 16:27:48 moist abrtd: Directory 'ccpp-2017-02-21-16:27:47-7505' creation detected
Feb 21 16:27:49 moist abrt[8769]: Saved core dump of pid 7561 (/usr/lib/virtualbox/VirtualBox) to /var/spool/abrt/ccpp-2017-02-21-16:27:47-7561 (162832384 bytes)
Feb 21 16:27:49 moist abrtd: Directory 'ccpp-2017-02-21-16:27:47-7561' creation detected
Feb 21 16:27:50 moist abrt[8770]: Saved core dump of pid 7613 (/usr/lib/virtualbox/VirtualBox) to /var/spool/abrt/ccpp-2017-02-21-16:27:47-7613 (245469184 bytes)
Feb 21 16:27:50 moist abrtd: Directory 'ccpp-2017-02-21-16:27:47-7613' creation detected
Feb 21 16:27:50 moist abrtd: Package 'VirtualBox-5.1' isn't signed with proper key
Feb 21 16:27:50 moist abrtd: 'post-create' on '/var/spool/abrt/ccpp-2017-02-21-16:27:47-7505' exited with 1
Feb 21 16:27:50 moist abrtd: Deleting problem directory '/var/spool/abrt/ccpp-2017-02-21-16:27:47-7505'

Edit: I'll have to invalidate this report, I found out that 5.0.26 guest additions were still in the X11 VM so that pollutes the purity of the installation, not a supported software combination. Everything is now at 5.1.14 so we'll have to wait and see if it happens again.

Last edited 17 months ago by itchybox (previous) (diff)

comment:9 in reply to: ↑ 7 Changed 16 months ago by frank

Replying to imbs:

I'm not sure why the VB runtime is 5.0.32 and the GUI is 5.1.14; I did a clean install a couple of weeks ago from the virtualbox dot org site and that has to be what was installed at the time...

Please clean-up your environment. I suggest you to remove the Ubuntu-shipped VirtualBox package (5.0.32-dfsg-0ubuntu1.16.04.2), then remove virtualbox-5.1, then re-install virtualbox-5.1 (update to 5.1.18 while you are at it). Then double-check that only the official Oracle package is installed.

comment:10 Changed 14 months ago by ark

This issue is still happening as of 5.1.22, but I found a workaround: TigerVNC's Xvnc server appears to be unaffected. So while "normal" VNC servers will still cause the libxcb-image.so crash, Xvnc doesn't - presumably because it is itself an X server.

comment:11 Changed 14 months ago by frank

  • Priority changed from critical to major

comment:12 Changed 12 months ago by aphra

Hello, this keeps happening to me even in a server-only linux vm, WITHOUT X.

Host is Ubuntu Xenial 16.04 with 4.8 updated kernel, x86 64 bit, Virtualbox 5.1.22.

Guest is Ubuntu Xenial 16.04 with 4.4 kernel, guest extensions are installed.

I have restarted the vm several times, but this keeps happening after a few hours from boot.

[ 544.105774] SUPR0GipMap: fGetGipCpu=0xb
[  545.952098] vboxdrv: 0000000000000000 VMMR0.r0
[  546.299115] vboxdrv: 0000000000000000 VBoxDDR0.r0
[  546.397721] VBoxNetFlt: attached to 'eno1' / 00:fd:45:fc:13:d4
[  546.671057] device eno1 entered promiscuous mode
[13168.896425] perf: interrupt took too long (2510 > 2500), lowering kernel.perf_event_max_sample_rate to 79500
[16552.942498] perf: interrupt took too long (3145 > 3137), lowering kernel.perf_event_max_sample_rate to 63500
[22278.792227] show_signal_msg: 18 callbacks suppressed
[22278.792231] VirtualBox[6634]: segfault at 18 ip 00007f7ee5ad5730 sp 00007ffda1d9ecf8 error 4 in libxcb.so.1.1.0[7f7ee5ac7000+21000]
[22278.792684] VirtualBox[6576]: segfault at 18 ip 00007f27a10cb730 sp 00007ffdaceae3e8 error 4 in libxcb.so.1.1.0[7f27a10bd000+21000]
[22287.465702] device eno1 left promiscuous mode
[22287.485302] vboxnetflt: 0 out of 1514064 packets were not sent (directed to host)
[54649.237517] perf: interrupt took too long (3945 > 3931), lowering kernel.perf_event_max_sample_rate to 50500
[102999.371611] vboxdrv: 0000000000000000 VMMR0.r0
[102999.663900] vboxdrv: 0000000000000000 VBoxDDR0.r0
[102999.773498] VBoxNetFlt: attached to 'eno1' / 00:fd:45:fc:13:d4
[102999.788819] device eno1 entered promiscuous mode
[103031.770856] VBoxNetFlt: Failed to allocate packet buffer, dropping the packet.
[103033.771145] VBoxNetFlt: Failed to allocate packet buffer, dropping the packet.
[103033.771149] VBoxNetFlt: (the above error has occured 10 times so far)
[104253.190137] VirtualBox[18709]: segfault at 18 ip 00007fa72ac2e730 sp 00007ffd02cca398 error 4 in libxcb.so.1.1.0[7fa72ac20000+21000]
[104253.190751] VirtualBox[18413]: segfault at 18 ip 00007fe60b535730 sp 00007ffd7e8a74c8 error 4 in libxcb.so.1.1.0[7fe60b527000+21000]
[104255.606678] device eno1 left promiscuous mode
[104255.619878] vboxnetflt: 0 out of 576599 packets were not sent (directed to host)
[125218.465423] vboxdrv: 0000000000000000 VMMR0.r0
[125218.680096] vboxdrv: 0000000000000000 VBoxDDR0.r0
[125218.744890] VBoxNetFlt: attached to 'eno1' / 00:fd:45:fc:13:d4
[125218.761332] device eno1 entered promiscuous mode

comment:13 Changed 3 weeks ago by gombara

Fixed for VirtualBox versions > 5.2.12.

comment:14 Changed 3 weeks ago by janitor

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the update.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use