VirtualBox

Ticket #1622 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

hardy heron kernel bug -> fixed in 1.6.2

Reported by: teleskopix Owned by:
Priority: blocker Component: other
Version: VirtualBox 1.6.0 Keywords: kernelbug
Cc: Guest type: other
Host type: other

Description

I did update today 27.05.2008 hardy heron (ubuntu) when I started Virtualbox, I got this bug

VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-setup the kernel module by executing '/etc/init.d/vboxdrv setup' as root. VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).

Fehlercode: 0x80004005 Komponente: Console Interface: IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}

Change History

comment:1 Changed 6 years ago by frank

So did you execute this command as you were instructed by the message box?

comment:2 Changed 6 years ago by teleskopix

Vielen Dank für die schnelle Antwort sorry, I'm Linux Newbee, keine Erfahrung im Kernel ändern, anpassen brauche dazu eine Anleitung für Anfänger

comment:3 Changed 6 years ago by frank

Also auf Deutsch: Einfach

sudo /etc/init.d/vboxdrv setup

eingeben. Dann wird das Kernmodul neu gebaut. Wenn Du das Paket dkms installierst, sollte das Bauen nach dem nächsten Upgrade automatisch funktionieren.

comment:4 Changed 6 years ago by timtripcony

Seeing the same behavior. Was running fine until I updated Ubuntu this morning and was asked to restart. After restart, attempting to boot up a virtual machine displayed the error shown. Ran vboxdrv setup and received the following response:

Usage: /etc/init.d/vboxdrv {start|stop|restart|status}

Tried running vboxdrv start, received the following response:

Starting VirtualBox kernel module vboxdrv No suitable module for running kernel found.

comment:5 Changed 6 years ago by teleskopix

Super, vielen vielen Dank

MfG Teleskopix

comment:6 Changed 6 years ago by redtux

same here. its a bug in the debian paket:

sudo /etc/init.d/vboxdrv setup

  • Stopping VirtualBox kernel module * done.
  • Removing old VirtualBox kernel module * done.
  • Recompiling VirtualBox kernel module
  • Look at /var/log/vbox-install.log to find out what went wrong

there You can read: /etc/init.d/vboxdrv: 311: /opt/VirtualBox-1.3.8/src/build_in_tmp: not found

but the script is in /usr/share/virtualbox/src/build_in_tmp

so, the pfad has to be fixed frank :)

comment:7 Changed 6 years ago by frank

No, please remove the file /etc/vbox/vbox.cfg and execute the command again. And please install the dkms package (only available on Ubuntu) to perform automatic rebuilding of the vboxdrv kernel module after host kernel upgrade.

comment:8 Changed 6 years ago by choman

Just to jump back on the bandwagon, wacking the file resolved my issue. I am a bit shocked the upgrade from vbox 1.5.x to vbox 1.6 did not wack the file in question. Anyways, I am glad to hear that there will be a check for the file in future releases of vbox. Keep up the great work everyone.

comment:9 Changed 6 years ago by mgiacchetti

i had this problem in hardy 8.04 after doing an update... the fix was to go into synaptic package manager, and run a configure.

comment:10 Changed 6 years ago by eduardgrebe

I had this issue on Hardy as well.

comment:11 Changed 6 years ago by jwithana

i upgraded my hardy kernel (amd64 not i386) and did not see this issue, "sudo /etc/init.d/vboxdrv setup" worked fine

comment:12 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from hardy heron kernel bug to hardy heron kernel bug -> fixed in 1.6.2
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use