VirtualBox

Ticket #16218 (new defect)

Opened 3 years ago

Win10 host Ubuntu 16.04 guest, graphics problems

Reported by: Orionsg Owned by:
Component: guest additions/x11/graphics Version: VirtualBox 5.1.10
Keywords: ubuntu 16.04, graphics, display Cc:
Guest type: Linux Host type: Windows

Description

I have over the last couple of months set up several Ubuntu 16.04 guest and noticed a pattern of problems over all the version 5.X's of VirtualBox:

It seems to be generally slow at times. Sometimes 10-15 seconds to start up until one gets to login. After logging in another 10-15 seconds before the machine becomes fully available, i.e the app icon bar shows.

When using the front end of the OS (i.e. opening, closing or minimising windows), the machine becomes sluggish but not always. when checking processes running "Compiz" will typically be using a lot of CPU, e.g. 70-100% for some time, after which it drops and the OS front end becomes responsive/accessible again.

If one enables 3D Acceleration it sometimes help, but may have other consequences such as the Chromium browser just displaying large rectangular, black or white areas with no menu or anything else displayed. The front end of other running applications also becomes either sluggish or non-responsive.

I have also seen problems with videos, sometimes there sometimes not. Sometimes the sound may be out of sync with the picture. But the problems are intermittent.

So, in general it seems that graphics is not handled properly by VirtualBox and/or Ubuntu 16.04 itself, possibly a combination of the two. Since VirtualBox are handling the graphics in the form of special drivers, the solution probably has to come from VirtualBox.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use