VirtualBox

Ticket #16189 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Booting 32bit Debian Stretch guest with Linux kernel >= 4.7.8 hangs forever without IO-APIC

Reported by: PoByBolek Owned by:
Component: other Version: VirtualBox 5.1.8
Keywords: Cc:
Guest type: Linux Host type: other

Description

After upgrading some of my Debian Stretch VMs to the Linux kernel 4.7.8 or 4.8.5 they would hang forever during boot after loading the initial ramdisk. This only happens with 32bit guests and on both Linux and Windows hosts. After I enabled the IO-APIC in the machine settings, they booted successfully again.

More importantly, I can't even install a recent Debian Testing build without enabling IO-APIC first.

Steps to reproduce:

  1. Create a new Debian (32-bit) VM
  2. Check that IO-APIC is disabled
  3. Try to install a recent  Debian Testing build with a Linux kernel >= 4.7.8
  4. Wait forever...
  5. Enable IO-APIC in the machine settings
  6. Try to install Debian with the same CD image again
  7. Watch it succeed

I could also reproduce this with VirtualBox 5.1.9 and 5.0.28.

Attachments

VBox.log Download (98.4 KB) - added by PoByBolek 6 years ago.

Change History

Changed 6 years ago by PoByBolek

comment:1 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Linux bug. Duplicate of #15913.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use