VirtualBox

Ticket #16150 (closed defect: fixed)

Opened 9 months ago

Last modified 3 months ago

Cmd-Tab broken between builds 111660 and 111724 => Fixed in SVN

Reported by: socratis Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.8 Keywords: Cmd-Tab
Cc: Guest type: all
Host type: Mac OS X

Description

Host: Mac
Using Cmd-Tab in a guest (let's say Win, OSX) used to act as a Win/Cmd/Super-Tab shortcut key within the guest. That behavior changed between builds 111660 and 111724. Now Cmd-Tab "stays" in the host, i.e. switches between apps in the host. Not sure if it is intentional or not.

Change History

comment:1 Changed 9 months ago by socratis

Aha! I think I found the underlying reason. The keyboard is not captured when switching to the VM with build 111724. At least its state shows as uncaptured in the icon on the bottom-right corner, if you switch focus to the VM either via the mouse or the keyboard (Cmd-Tab on the host). So, if you press once the host key (default LeftCmd) and then Cmd-Tab, it works as in previous versions.

comment:2 Changed 8 months ago by flash77

I experience the same problem

Virtualbox 5.1.10 r112026 (Qt5.6.2)
Host macOs Sierra 10.12.1
Guest Win10 Version 1607

comment:3 Changed 8 months ago by frank

Should be fixed in the most recent Mac OS X test build (5.1 >= 112105). The problem is that moc does not warn if it doesn't find a header file. As a result of an unrelated change, a macro which was supposed to be defined was undefined (value 0) and an expression which depends on this value was incorrectly evaluated and incorrect code was generated (missing some Qt signals).

comment:4 Changed 8 months ago by socratis

Verified as fixed with 5.1.11 rev. 112114. Thanks!

comment:5 Changed 8 months ago by frank

  • Summary changed from Cmd-Tab broken between builds 111660 and 111724 to Cmd-Tab broken between builds 111660 and 111724 => Fixed in SVN

Thanks for confirming!

comment:6 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.1.12.

comment:7 Changed 7 months ago by AndDK

I'm a little confused as how to expect VirtualBox to behave. The fix also affects how it works with Windows as the host.

Before this fix, I would start VirtualBox, launch my Windows 7 guest and then press HostKey+Del to send the CTRL-Alt-Del command to the guest.

After this fix, I start VirtualBox, launch my Windows 7 VM, press HostKey once and then press HostKey+Del to send the CTRL-Alt-Del command to the guest.

I have always done the first thing for the last couple of years, but with 5.1.12 it have been switched to the other way. Can this be changed somewhere in the settings, so it works as it did before? Can't seem to find where I need to do the change.

comment:8 Changed 3 months ago by AndDK

Seems that VirtualBox 5.1.20 have fixed my problem (see comment 7), so now HostKey-Del works again, without first having to press HostKey once. I'm happy :)

comment:9 Changed 3 months ago by socratis

@AndDK
No, it wasn't 5.1.20, it was 5.1.12 as you can see a couple of posts above yours. Do you mean that something changed between 5.1.18 and 5.1.20?

Last edited 3 months ago by socratis (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use