VirtualBox

Ticket #15973 (closed defect: fixed)

Opened 10 months ago

Last modified 5 months ago

Windows 10 is not working since 14926 build

Reported by: Wacher Owned by:
Priority: blocker Component: 3D support
Version: VirtualBox 5.1.6 Keywords: Windows 10
Cc: Guest type: Windows
Host type: Linux

Description

If 3D acceleration is disabled then the installation is aborted somewhere in the middle of progess with BSOD "System Thread Exception Not Handled" VBoxVideoW8.sys(?), therefore installer rolling back to previous Windows build.

 https://forums.virtualbox.org/viewtopic.php?f=2&t=79761

feedback-hub:?contextid=158&feedbackid=dd9cd7c7-2bec-4193-98b0-38d9bdc7baef&form=1&src=2

Attachments

VirtualBox - 2016_1029 - Problems with Windows 10 display.jpg Download (135.1 KB) - added by ataraxy 9 months ago.
Windows 10 display not clear when using scaled mode
011117-30546-01.dmp Download (250.5 KB) - added by Squall Leonhart 6 months ago.
minidump for the vbox display driver bsod.

Change History

comment:1 Changed 10 months ago by Wacher

New build 14936 came out and still crashing.

comment:2 Changed 9 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed with VBox 5.1.8.

Changed 9 months ago by ataraxy

Windows 10 display not clear when using scaled mode

comment:3 Changed 9 months ago by ataraxy

I'm still seeing problems, even with v5.1.8.

While Windows 10 runs if 3D video acceleration is enabled, when I use scaled mode, the display is fuzzy, as shown in the screenshot. If 3D video acceleration is not enabled, then Windows 10 won't start.

comment:4 Changed 9 months ago by ataraxy

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:5 Changed 8 months ago by Wacher

Remove the video driver via device manager, use the MS Basic driver. I experience other problems with VBA driver as well, basic driver works good. (5.1.8)

comment:6 Changed 8 months ago by ataraxy

Thanks Wacher!

I uninstalled the Display Adapter driver in Device Manager, shutdown, switched off the 3D Acceleration in the VirtualBox settings, restarted. Everything works fine. When I check the Display Adapter in Device Manager, it's back to the VirtualBox one. So something obviously got mucked up when the problems started, and it needed the driver to be uninstalled to fix it.

So does that mean that this ticket should be closed again?

comment:7 Changed 8 months ago by Wacher

You can prevent VBox driver restoring if you check Remove driver files options when remove driver. I think this should not be closed, I think VBox driver is completely useless in some situation (for example my computer).

comment:8 Changed 8 months ago by StanT

Second Wacher, please leave this ticket open.

Removing the VB display driver and using the basic MS driver does work w/o 3D acceleration but MS driver has serious shortcomings : max. display resolution 1600x1200; limited to single display; seamless mode not available.

I have Windows 10 Insider latest (14965) running under VB 5.1.8 with Guest Additions in seamless mode with 2 FHD (1920x1080) displays following the advice on this forum for enabling 3D acceleration.

But:

1) I have to set the desktop background to "slideshow" which forces a desktop display update on boot otherwise Windows windows are not visible.

2) Seamless mode has never been truly seamless for Windows 10 guests (unlike Windows 7). Windows desktop background has always been displayed obscuring the underlying Linux desktop. However Linux application windows are displayed above the Windows desktop when they are in the foreground which is OK.

3) Modern UI apps, e.g. Edge, Feedback Hub, suffer from 'flicker' where window content disappears showing only the window frame. Window content comes and goes with mouse movement / keyboard input. It's as though there's some double buffering fault where the other buffer is empty. Other apps, e.g. File Explorer, Visual Studio, are fine. Display is sharp and Windows runs fine.

So VB display driver is very nearly there and was pretty good with Windows 10 up to the 14296 (and later) builds for the forthcoming Creator Update.

NVidia 352.79 with Linux 4.4.30 and Mate 1.8.1

Last edited 8 months ago by StanT (previous) (diff)

comment:9 Changed 8 months ago by ataraxy

I spoke too soon. When I restarted Windows 10 with the VirtualBox display drivers installed, Windows had the same problems as before, and wouldn't start.

So it appears that the problem is at start up, and if Windows starts without the VirtualBox display drivers, then they can be installed and Windows will keep running okay.

I've now uninstalled the VirtualBox display drivers and deleted them, and tested this by restarting twice. Everything is running okay.

So I will leave this open so that it is clear that there is still a problem.

comment:10 Changed 7 months ago by Wacher

upgraded to 5.1.12: After upgrade I started the Office 2016, Win10 crashed immediately (2D,3D on). I remove the VB video driver in Device Manager, windows install Basic Video Driver, everything is working, everybody is almost happy.

Last edited 7 months ago by Wacher (previous) (diff)

comment:11 follow-up: ↓ 13 Changed 7 months ago by tns2

Note: I have been seeing what appears to be the same bug Since this Windows 10 preview build came out. However My host environment is a WINDOWS 10 system. AND HAS NOTHING TO DO WITH THE 3d OPTION being set or not, as it happens either way.

Windows 10 has gone on to later versions and Virtualbox moved from 5.1.9 to first 5.1.10 and now 5.1.12

Pretty much have to boot windows 10 preview into safe mode and replace the driver, as the system doesn't stay up long before it fails and restarts with the VB Video driver.

Last edited 7 months ago by tns2 (previous) (diff)

Changed 6 months ago by Squall Leonhart

minidump for the vbox display driver bsod.

comment:12 Changed 6 months ago by Squall Leonhart

*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007e)
This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Some common problems are exception code 0x80000003.  This means a hard
coded breakpoint or assertion was hit, but this system was booted
/NODEBUG.  This is not supposed to happen as developers should never have
hardcoded breakpoints in retail code, but ...
If this happens, make sure a debugger gets connected, and the
system is booted /DEBUG.  This will let us see why this breakpoint is
happening.
Arguments:
Arg1: ffffffffc0000005, The exception code that was not handled
Arg2: fffff80d539520aa, The address that the exception occurred at
Arg3: ffffc50169df5be8, Exception Record Address
Arg4: ffffc50169df5420, Context Record Address

Debugging Details:
------------------


EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

FAULTING_IP: 
VBoxVideoW8+220aa
fffff80d`539520aa f348a5          rep movs qword ptr [rdi],qword ptr [rsi]

EXCEPTION_RECORD:  ffffc50169df5be8 -- (.exr 0xffffc50169df5be8)
ExceptionAddress: fffff80d539520aa (VBoxVideoW8+0x00000000000220aa)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: 000001332ae40000
Attempt to read from address 000001332ae40000

CONTEXT:  ffffc50169df5420 -- (.cxr 0xffffc50169df5420;r)
rax=ffffd4fe58f93bb4 rbx=ffffd4fe58f93bb4 rcx=000000001ffdc74a
rdx=00000000fffffe98 rsi=000001332ae3fffc rdi=ffffd4fe590afffc
rip=fffff80d539520aa rsp=ffffc50169df5e28 rbp=000001332a990000
 r8=00000000fffffe98  r9=0000000000000001 r10=000001332ad23bb4
r11=000000000000008a r12=0000000000001400 r13=0000000000001400
r14=00000000fffffe98 r15=0000000000000015
iopl=0         nv up ei pl nz na pe nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010202
VBoxVideoW8+0x220aa:
fffff80d`539520aa f348a5          rep movs qword ptr [rdi],qword ptr [rsi]
Last set context:
rax=ffffd4fe58f93bb4 rbx=ffffd4fe58f93bb4 rcx=000000001ffdc74a
rdx=00000000fffffe98 rsi=000001332ae3fffc rdi=ffffd4fe590afffc
rip=fffff80d539520aa rsp=ffffc50169df5e28 rbp=000001332a990000
 r8=00000000fffffe98  r9=0000000000000001 r10=000001332ad23bb4
r11=000000000000008a r12=0000000000001400 r13=0000000000001400
r14=00000000fffffe98 r15=0000000000000015
iopl=0         nv up ei pl nz na pe nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010202
VBoxVideoW8+0x220aa:
fffff80d`539520aa f348a5          rep movs qword ptr [rdi],qword ptr [rsi]
Resetting default scope

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  WIN8_DRIVER_FAULT

PROCESS_NAME:  csrss.exe

CURRENT_IRQL:  0

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

EXCEPTION_PARAMETER1:  0000000000000000

EXCEPTION_PARAMETER2:  000001332ae40000

READ_ADDRESS: unable to get nt!MmSpecialPoolStart
unable to get nt!MmSpecialPoolEnd
unable to get nt!MmPagedPoolEnd
unable to get nt!MmNonPagedPoolStart
unable to get nt!MmSizeOfNonPagedPoolInBytes
 000001332ae40000 

FOLLOWUP_IP: 
VBoxVideoW8+220aa
fffff80d`539520aa f348a5          rep movs qword ptr [rdi],qword ptr [rsi]

BUGCHECK_STR:  AV

ANALYSIS_VERSION: 6.3.9600.16384 (debuggers(dbg).130821-1623) amd64fre

EXCEPTION_STR:  0x0

LAST_CONTROL_TRANSFER:  from fffff80d539409d0 to fffff80d539520aa

STACK_TEXT:  
ffffc501`69df5e28 fffff80d`539409d0 : 00000000`00000000 ffffb20b`40ac4098 ffffb20b`40ac42b0 ffffc501`69df6150 : VBoxVideoW8+0x220aa
ffffc501`69df5e30 00000000`00000000 : ffffb20b`40ac4098 ffffb20b`40ac42b0 ffffc501`69df6150 00000366`000002ed : VBoxVideoW8+0x109d0


SYMBOL_STACK_INDEX:  0

SYMBOL_NAME:  VBoxVideoW8+220aa

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: VBoxVideoW8

IMAGE_NAME:  VBoxVideoW8.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  5790ef1b

STACK_COMMAND:  .cxr 0xffffc50169df5420 ; kb

FAILURE_BUCKET_ID:  AV_VBoxVideoW8+220aa

BUCKET_ID:  AV_VBoxVideoW8+220aa

ANALYSIS_SOURCE:  KM

FAILURE_ID_HASH_STRING:  km:av_vboxvideow8+220aa

FAILURE_ID_HASH:  {5cdf3284-7136-747e-4b02-4f8572de433d}

Followup: MachineOwner
---------
Last edited 6 months ago by frank (previous) (diff)

comment:13 in reply to: ↑ 11 ; follow-up: ↓ 14 Changed 6 months ago by tns2

Replying to tns2:

Note: I have been seeing what appears to be the same bug Since this Windows 10 preview build came out. However My host environment is a WINDOWS 10 system. AND HAS NOTHING TO DO WITH THE 3d OPTION being set or not, as it happens either way.

Windows 10 has gone on to later versions and Virtualbox moved from 5.1.9 to first 5.1.10 and now 5.1.12

Pretty much have to boot windows 10 preview into safe mode and replace the driver, as the system doesn't stay up long before it fails and restarts with the VB Video driver.

Note Windows 10 build went to 15007.rs In the process it reinstalled the VMBOX video driver. For the moment at least it seems to be working normally again. Hopefully I am not speaking too soon.

Last edited 6 months ago by tns2 (previous) (diff)

comment:14 in reply to: ↑ 13 Changed 6 months ago by Squall Leonhart

Replying to tns2:

Replying to tns2:

Note: I have been seeing what appears to be the same bug Since this Windows 10 preview build came out. However My host environment is a WINDOWS 10 system. AND HAS NOTHING TO DO WITH THE 3d OPTION being set or not, as it happens either way.

Windows 10 has gone on to later versions and Virtualbox moved from 5.1.9 to first 5.1.10 and now 5.1.12

Pretty much have to boot windows 10 preview into safe mode and replace the driver, as the system doesn't stay up long before it fails and restarts with the VB Video driver.

Note Windows 10 build went to 15007.rs In the process it reinstalled the VMBOX video driver. For the moment at least it seems to be working normally again. Hopefully I am not speaking too soon.

the change that was causing this has been pulled till a later build.

comment:15 Changed 6 months ago by frank

Thanks for the report and for providing a dump. Finally we were able to reproduce the problem. It seems that Windows delivered bogus rectangles (negative width) when talking to the (VBox) display driver. We found at least one place and currently looking for other places. The fix is part of the most recent 5.1 Guest Additions (>= 103104) which you can download here.

Feedback welcome!

comment:16 Changed 6 months ago by Squall Leonhart

Thanks Frank, I did notice that that 15002 became a touch more stable, but there were still moments where the bsod would occur, you could tell it was happening because the picture would shrink like it was doing a automatic resize and then bugcheck.

Will test these new additions posthaste :)

PS: you wrote 103104 instead of 113104.

Last edited 6 months ago by Squall Leonhart (previous) (diff)

comment:17 Changed 6 months ago by StanT

I've just installed guest additions 5.1.x revision 113104 on VB 5.1.10 r112025 hosted on Mageia 5.1 (Linux 4.4.39). Windows 10 15019 is now stable with 2D acceleration on and 3D acceleration off. Running in seamless mode on 2 FHD (1920x1080) displays. All that 'flicker' I was seeing with Modern UI apps is gone (think it was related to 3D acceleration).

All other guest additions goodies (clipboard, shared folders etc.) working fine too.

Thanks guys.

comment:18 Changed 6 months ago by ataraxy

I've just tried

  • Windows 10 Build 15025
  • with VirtualBox v5.1.15 build 113106 and the Guest Additions (and video driver) that come with that build
  • on a Windows 10 host

and everything looks to be back to normal.

Windows starts without 3D video acceleration enabled, and the screen displays clearly.

Thanks for fixing this!

comment:19 follow-up: ↓ 20 Changed 5 months ago by bhahlen

I tried that as well, and that worked with build 15025. However, since build 15042, the Video Driver bugs out again. Tried with 3D accelaration on and off, but unfortunately, no go.

comment:20 in reply to: ↑ 19 ; follow-up: ↓ 21 Changed 5 months ago by ataraxy

Replying to bhahlen:

I tried that as well, and that worked with build 15025. However, since build 15042, the Video Driver bugs out again. Tried with 3D accelaration on and off, but unfortunately, no go.

I just updated from build 15031 to 15046 (everything else the same as in comment 18) and everything is working.

comment:21 in reply to: ↑ 20 Changed 5 months ago by bhahlen

Replying to ataraxy:

Replying to bhahlen:

I tried that as well, and that worked with build 15025. However, since build 15042, the Video Driver bugs out again. Tried with 3D accelaration on and off, but unfortunately, no go.

I just updated from build 15031 to 15046 (everything else the same as in comment 18) and everything is working.

Just updated to 15048, but still not starting with the GA Video Driver installed. Booting with advanced options and then "Basic Video Driver" works without a problem. Tried updating to a newer version of GA (5.1.15-113648), but still no go. Although I use VBox 5.1.14, so maybe that could be it, I'll give that a try.

I'm on a Linux host.

comment:22 follow-up: ↓ 23 Changed 5 months ago by bhahlen

VirtualBox 5.1.15-113680 does not work either, neither with GA-5.1.15-113648. Booting with Basic Video Driver works, and then after login, everything works as it should.

comment:23 in reply to: ↑ 22 Changed 5 months ago by ataraxy

Replying to bhahlen:

VirtualBox 5.1.15-113680 does not work either, neither with GA-5.1.15-113648. Booting with Basic Video Driver works, and then after login, everything works as it should.

I'm still using the set up described above, and everything is working okay with build 15048.

So it looks like this is a problem with Linux hosts.

Getting a minidump (see comment 12) seemed to be crucial in getting the fix done so far, so if you can generate one, that would probably help a lot. Unfortunately, I don't know how you create one, or even if it is a VirtualBox or Windows thing. If anyone knows, could you please post instructions.

Thanks

comment:24 Changed 5 months ago by StanT

I have Windows 10 build 15048 working with VB 5.1.10 and guest additions 5.1.15 113648. Mageia 5.1 Linux host (kernel 4.4.50, Mate 1.8.1, nVidia 375.26). 64-bit Linux host and Windows guest. VB 3D acceleration off, 2D on. Seamless mode with 2 FHD displays.

Windows guest was a bit shaky immediately following update to latest build but full shutdown of both guest and host fixed that and it is running fine. It seems that all the problems I had with the VB display driver are resolved by recent (113104 and later) guest additions releases.

comment:25 Changed 5 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

This ticket got a bit complex. The VBox 5.1.16 Guest Additions contain a fix for the original problem. Please open a new ticket if you still experience problems with VBox 5.1.16.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use