VirtualBox

Ticket #15972 (closed defect: fixed)

Opened 14 months ago

Last modified 7 days ago

"VBoxManage storagectl --add sas" gets USB controller

Reported by: socratis Owned by:
Priority: major Component: VM control
Version: VirtualBox 5.1.6 Keywords: VBoxManage storagectl --add sas
Cc: Guest type: all
Host type: all

Description

Issue the command:

VBoxManage storagectl <uuid|name> --name <name> --add sas

without specifying the controller type. The command is perfectly accepted, the interface is created but the controller type is set to USB both in the tooltip and in the "VBoxManage showvminfo", but not in the GUI where it is shown as LSILogicSAS. What is a USB controller doing there? ;)

Change History

comment:1 Changed 14 months ago by socratis

Example:

$ VBoxManage showvminfo Minix
...
Storage Controller Name (0):            IDE
Storage Controller Type (0):            PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0):  2
Storage Controller Port Count (0):      2
Storage Controller Bootable (0):        on
...
$ VBoxManage storagectl Minix --name Test --add sas
$
$ VBoxManage showvminfo Minix
...
Storage Controller Name (0):            IDE
Storage Controller Type (0):            PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0):  2
Storage Controller Port Count (0):      2
Storage Controller Bootable (0):        on
Storage Controller Name (1):            Test
Storage Controller Type (1):            USB    <<<<<
Storage Controller Instance Number (1): 0
Storage Controller Max Port Count (1):  255
Storage Controller Port Count (1):      8
Storage Controller Bootable (1):        on
...

As stated before, in the GUI it is shown as an SAS interface with an LSILogicSAS controller, but in the tooltip it shows an SAS interface with a USB controller.

BTW, it would be really nice to show the interface type as well in the output of the VBoxManage AND in the GUI, instead of having to hover to show the tooltip.

comment:2 Changed 14 months ago by frank

Thanks for the report. Actually a typo. I only wonder why I didn't see such a report before. Anyway, the fix will be part of the next 5.1.x maintenance release.

comment:3 Changed 14 months ago by socratis

Is it going to have the added "interface" option displayed as well? I think it's rather trivial, no?

comment:4 Changed 14 months ago by Dsen

Hello socratis,

We had a bit of discussion in that regard and decided that it would be good to have a possibility to change existing controller bus same way one can change existing controller type in the GUI settings. That means similar combo-box above the type related one. Request is planned, but since that involves NLS changes as well, it will be done to 5.2, not earlier.

comment:5 Changed 14 months ago by socratis

Oh, I was only thinking of a read-only information string, both in the GUI and in the 'VBoxManage showvminfo', pretty much recreating the tooltip functionality. No NLS changes required, since it's already there in the tooltip, right?. I think so because I did the Greek translation of VBox. I'll have to double check.

But hey, your idea is better ;) Of course it is a lot more work and a lot more error prone to change "on-the-fly" so to speak the controller, instead of deleting an existing one and adding a new one. What do you do for example when you change a SATA controller with 5 devices attached to an IDE controller which has a max of 4? Just a quick 'ay chihuahua' example...

comment:6 Changed 13 months ago by frank

Fix is part of VBox 5.1.8.

comment:7 Changed 13 months ago by socratis

Confirmed as fixed in 5.1.8.

I also checked the NLS strings, and yes, the tooltip is a big string, not a bunch of smaller ones, so I guess it will have to wait until 5.2. Should we leave the ticket open to remember to include it in the "VirtualBox showvminfo", or open a new one?

comment:8 Changed 7 days ago by vushakov

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use