VirtualBox

Ticket #15956 (closed defect: fixed)

Opened 3 years ago

Last modified 4 months ago

USB Regression - Can't connect ST-Link/V2 JTag pod to Windows 7 Guest => fixed in SVN/next maintenance

Reported by: mkurtzsd Owned by:
Component: USB Version: VirtualBox 5.1.6
Keywords: STLink,64-bit,USB Cc:
Guest type: Windows Host type: Mac OS X

Description

I recently updated my VBox installation from 5.0.8 to 5.1.6 and can no longer connect my ST-Link/V2 JTag debugging device to VirtualBox. The device is recognized and appears in the Devices | USB menu. When I click on the entry to attach it to my guest, I get the following error:

Failed to attach the USB device STMicroelectronics STM32 STLink [0100] to the virtual machine Windows 7 (64-bit).

USB device 'STMicroelectronics STM32 STLink' with UUID {2a4ef47b-5431-4540-8a60-c48d2ed4593f} is busy with a previous request. Please try again later.

Result Code: NS_ERROR_INVALID_ARG (0x80070057)
Component: HostUSBDeviceWrap
Interface: IHostUSBDevice {c19073dd-cc7b-431b-98b2-951fda8eab89}
Callee: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

I have ensured that the 5.1.6 Extension Pack is installed, the Guest Additions are installed, I have deleted everything but the Name, Vendor ID, Product ID settings with the Remote selection set to "No" in the USB port settings for the device with no success. I have booted the Windows guest with and without the USB device connected (connecting after boot when booted without the device connected) and have the same issue. I have also tried setting the USB support to 1.1, 2.0, and 3.0 in the Ports | USB settings dialog.

If I uninstall VBox 5.1.6 and revert to v5.0.8 then the ST-Link will connect again. v5.0.8 is the last version that I have been able to get a connection with. I tried 5.0.26 and that didn't work either.

I have a Windows 7 (64-bit) guest on OS/X. I am running Mac OS/X v10.11.6 on a MacBook Pro (Retina, 15-inch, Late 2013).

Attachments

VBox.log Download (73.0 KB) - added by mkurtzsd 3 years ago.
v5.1.6 log file
VBox.log.3 Download (73.8 KB) - added by mkurtzsd 3 years ago.
v5.0.8 log file
Vbox.log Download (84.0 KB) - added by Nemo 4 months ago.

Change History

Changed 3 years ago by mkurtzsd

v5.1.6 log file

Changed 3 years ago by mkurtzsd

v5.0.8 log file

comment:1 Changed 2 years ago by aeichner

I don't see such issues with the USB devices I have here but I don't have a ST-Link JTag device to try with. Would be great if you could try to find out the exact version between 5.1.6 and 5.0.8 where this broke.

comment:2 Changed 2 years ago by Nebuchadnezzar

I want to confirm I have the same issues with Virtual Box 5.1.14 and STM32/STM8 programmer.. I downdgraded to 5.0.6 (clicked .6 instead of .8...) and it is now working.

comment:3 Changed 2 years ago by aeichner

We were able to reproduce the issue and are working on a fix. This regression was introduced with 5.0.18 (USB: properly purge non-ASCII characters from USB strings).

comment:4 Changed 2 years ago by aeichner

  • Summary changed from USB Regression - Can't connect ST-Link/V2 JTag pod to Windows 7 Guest to USB Regression - Can't connect ST-Link/V2 JTag pod to Windows 7 Guest => fixed in SVN/next maintenance

This issue will be fixed in the next 5.1.x and 5.0.x maintenance releases.

comment:5 Changed 2 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in VBox 5.1.16.

comment:6 Changed 4 months ago by Nemo

Hello,

I have similar issue on Windows 10 on Virtual Box Box 6.0

 https://ibb.co/C8Knk0N

Thanks

Last edited 4 months ago by Nemo (previous) (diff)

Changed 4 months ago by Nemo

comment:7 Changed 4 months ago by socratis

@Nemo,

  1. You do not have the same issue. You have a "Busy with a previous request" issue. Please read the following thread:  USB basics and troubleshooting, all of the posts. If you still have a problem after reading through the whole thing, please head to the  forums, and follow the advice of the last post and post the information requested. Please be sure to mention that you came from the bug tracker and include the ticket number.
  1. It's usually better and faster, if issues get first addressed in the  VirtualBox forums, a lot more eyes there. More than 95% of the issues are resolved over there, which keeps the developers focusing on the bug fixes and enhancements, and there is no need for another ticket to keep track of. For example, yours is not a bug and someone from the developers has to deal with it.
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use