VirtualBox

Ticket #15937 (closed defect: fixed)

Opened 8 months ago

Last modified 7 months ago

Default Ctrl-Alt-Del broken on MacBookPro

Reported by: socratis Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.6 Keywords: Ctrl-Alt-Del, MacBookPro
Cc: Guest type: all
Host type: Mac OS X

Description

You cannot send a Host-Del key on a MacBookPro which is translated to Host-fn-Bksp. Further investigation shows that:

  • You cannot send a Host-Bksp either, which means that it is not the fn key that is responsible alone.
  • You cannot set Host-(Function#) key.
  • You cannot set Host-(AnyNumber).
  • You can set Host-\, Host-=, etc.

Change History

comment:1 Changed 8 months ago by Dsen

Thank you for noticing that issue.
I think that's the same problem as #15938, and should be fixed in the nearest maintenance release.
Could you please confirm that the issue is fixed for you within the following test build:
https://www.virtualbox.org/download/testcase/VirtualBox-5.1.7-110731-OSX.dmg
Thanks in advance!

comment:2 Changed 8 months ago by socratis

Yes, it is fixed! Both that and #15938. You can close both bugs. I will update the related posts in the forums. Thank you!

comment:3 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.1.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use