VirtualBox

Ticket #15927 (new defect)

Opened 3 years ago

Last modified 20 months ago

USB Wifi Dongle drops connection after short period

Reported by: Briantb Owned by:
Component: USB Version: VirtualBox 5.1.6
Keywords: Cc:
Guest type: Linux Host type: Mac OS X

Description

Trying to use a  Think Penguin TPE-N150USB USB WIFI adapter in close proximity to my router.

The guest VM will recognize and use the adapter just fine. I can usually connect to my wifi, but the connection drops after 5-10 seconds (usually as soon as I try to access any over it). Subsequent attempts to connect to any WIFI connection will fail. Result is the same for any network I try to connect to, and on several different linux's, though primarily with fully up-to-date Ubuntu 16.04 ( Kernel 4.4 and 4.6 for grins and giggles). USB 2 and USB 3 both yield the same result.

I have ruled out a problem dongle since if I boot natively into the same version of linux, the wifi connection works flawlessly.

My problem seems unrelated to Ticket #9511 since my drivers load properly.

Not sure if its helpful, but I have a  Forum Post here with more info. Forum Moderator says he doesn't experience a similar issue with Linux Host, so perhaps the problem is specific only to Mac hardware?

(VirtualBox version 5.1.6 w/ latest Extension Pack and Guest Additions)

Please let me know if there is any further information I can provide, or any troubleshooting I should attempt.

Attachments

vbox.log.zip Download (24.7 KB) - added by Briantb 3 years ago.
Vbox Log

Change History

Changed 3 years ago by Briantb

Vbox Log

comment:1 Changed 2 years ago by tekion

I have the same problem with Alfa AWUS036NHA Atheros AR9271 802.11n WIRELESS-N USB Wi-Fi adapter. on USB 2.0 or 3.0. Guest OS: Linux. Host OS: Windows-7 Enterprise 64 bit.

Last edited 2 years ago by tekion (previous) (diff)

comment:2 Changed 20 months ago by aeichner

Can you please try with the latest 5.1 or 5.2 testbuild from here? We fixed an issue in our USB stack which could cause the drop outs you are seeing.

Btw., I can use the Wifi stick I have here just fine with the fix (didn't test it without it), it is not the same model but I guess they work mostly the same.

Last edited 20 months ago by aeichner (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use