VirtualBox

Ticket #159 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

Keyboard repeat rate in Ubuntu

Reported by: jtagg82 Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.6 Keywords: Keyboard, Ubuntu
Cc: Guest type: other
Host type: other

Description

In Ubuntu as well as in Kubuntu guests on WinXPSP2 host(both 6.10), I have a keyboard problem. It has a very fast repeat rate no matter what the keyboard settings are and typing 'hello' would give something like 'hhheeeeeeelloooo'. The problem isn't always there, but it is most of the time. Sometimes the keyboard stops working altogether in the guest.

Change History

comment:1 Changed 7 years ago by ferromax

Same happens to me on Vista build 6000 host.

comment:2 Changed 7 years ago by grin

I'm experiencing a similar problem with virtualbox 1.3.8 on Ubuntu Linux 6.10.

My problem is more extensive, whenever virtualbox is running my keyboard is 'flakey'. Sometimes I run into an unlimited repeat (also when key is released, not only with character keys but also with <tab>, <return>, <alt> and all the others.

The funny(?) thing is that when I type fast enough sometimes the characters get on the screen in a different order than what I typed (not a typo, checked several).

This is NOT only inside the virtual machine (windows XP) but also on my host! Whenever I stop VirtualBox the problem is corrected.

I hope that you have a solution for me!

comment:3 Changed 7 years ago by grin

I'm verry sorry to have reported this problem here. I didn't realize at first that it is a cpu-load related problem with Ubuntu.

There seems to be no concrete fix from Ubuntu yet (annoying) but there is a bugreport  39315in de Ubuntu support database.

Thanks for your great product, I'll go for a round of Ubuntu fixing!

(for people also having this problem, power management related tools like gnome-power-manager seems to solve the problem)

comment:4 Changed 7 years ago by michael

grin, thank you for finding that Launchpad issue. jtagg82, ferromax: could you try booting the Ubuntu guest with the (guest) kernel parameter "acpi=noirq" and see if you can reproduce the problems you mentioned - both the key repeat problem and the keyboard freeze problem? Perhaps you could add comments to this report to say whether or not it helped?

comment:5 Changed 7 years ago by sandervl73

Do any of you happen to use AMD Athlon X2 cpus?

comment:6 Changed 7 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate

Try again with 1.4.0. Sounds like a duplicate of other defects, so I'm closing it.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use