VirtualBox

Ticket #15872 (closed defect: fixed)

Opened 13 months ago

Last modified 9 months ago

LPT, Cannot attach to host driver (VERR_INTERNAL_ERROR_3)

Reported by: Electron-John Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.4 Keywords: LPT VERR_INTERNAL_ERROR_3 parallel (0x80004005)
Cc: Guest type: Windows
Host type: Windows

Description

Summary: I am setting up a virtual box (ver. 5.1.4r110228 (Qt5.5.1) ) to run older, expensive software on a virtual Windows 2000 machine. There is a physical parallel port dongle that is needed. I have found and followed the tutorial on setting up the port (Enabling and Configuring Parallel (LPTx) Ports). I get an error that looks internal to Virtual Box. The virtual machine will not even continue past the error.

What I have done after the error:

1) Researched the forums:

A) Found several posts about parallel ports but none addressed the internal error I was getting. Nevertheless I tried some of the suggestions to no avail. Ultimately, my most reliable forum post was the tutorial.

B) Found a stale ticket (4279 - now obsolete) that ultimately was no use.

2) Posted in VitualBox on Windows Hosts, titled "parallel device 0 cannot attach to host driver" by Electron-John, 27, Aug 2016, 23:26.

A) That post has all the details, and both the log file and hardening log file. (Copies attached to this ticket.)

3) I have found the following on Microsoft's developer pages:

A)  https://msdn.microsoft.com/en-us/library/windows/hardware/ff543952(v=vs.85).aspx[[BR]]

B) If the link doesn't work or is blocked, try web searching "features of system-supplied drivers" and look for a microsoft link that has "ff543952" in it. This is current as of 31, Aug. 2016)

C) I am not experienced enough to figure out, on 64 bit Windows hosts, if VirtualBox needs to supply a vendor-supplied parallel port driver. I do not fully comprehend what the workaround is for 64 bit Windows hosts.

At this point I do not know how to resolve the internal error.

I have attached the log files and a copy of the original post.

Thank you in advance.

Electron John

Attachments

OriginalPost.txt Download (1.7 KB) - added by Electron-John 13 months ago.
Original Post in Forum
VBoxHardening.7z Download (18.5 KB) - added by Electron-John 13 months ago.
Hardenign log file zipped wiht 7-zip
VBox.log Download (31.8 KB) - added by Electron-John 13 months ago.
Log file

Change History

Changed 13 months ago by Electron-John

Original Post in Forum

Changed 13 months ago by Electron-John

Hardenign log file zipped wiht 7-zip

Changed 13 months ago by Electron-John

Log file

comment:1 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

You use the wrong path! Use

\\.\PIPE\LPT1

instead of

LPT1:

comment:2 Changed 13 months ago by Electron-John

I will try it by typing:

>VBoxManage modifyvm "Windows 2000" --lptmode1 "\\.\PIPE\LPT1"

Last edited 13 months ago by Electron-John (previous) (diff)

comment:3 Changed 13 months ago by Electron-John

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Doesn't work for me. Now I get
Parallel#0 could not open '\\.\PIPE\LPT1' (VERR_FILE_NOT_FOUND).

Re-opening ticket.

Last edited 13 months ago by Electron-John (previous) (diff)

comment:4 Changed 13 months ago by frank

"File not found" means the device is not present. Perhaps wrong device name?

comment:5 Changed 13 months ago by frank

My mistake. 'lpt1' would be correct. Check with 'dir lpt1' if this device exists.

comment:6 Changed 13 months ago by Electron-John

C:>dir lpt1

Directory of \\.

File not found

Hardware manager shows LPT1 as normal operation with driver running properly. The driver is indicated to be from Microsoft Windows (see note below) version 6.1.7600.16385. It is installed in C:\Windows\system32\DRIVERS\paraport.sys. The base address of 0x378. The port came with the motherboard (purchased new 3 years ago).

I see that the driver is in the System32 folder. This seems to be in keeping with the note on MS website about the 64 bit systems not having a parallel port driver.

Does VirtualBox have a driver for 64 bit MS hosts? In the meantime, I am going to check for a 32 version of VirtualBox. Maybe I can get that version to pick up the 32 bit driver.

I will be off-line for the long weekend (in the US). I will have time to work more on this after that.

Thanks for looking into this frank. It is much appreciated.

EJ

comment:7 Changed 12 months ago by ItUsedToWork

Same issue here. The logs are basicly the same:
"HostParallel#0: Could not get direct access to the host parallel port!! (rc=VERR_INTERNAL_ERROR_3)"
After the Win10 Anniversary update && VirtualBox update from 5.0.? to 5.1.6, this error now occurs.

Last edited 12 months ago by ItUsedToWork (previous) (diff)

comment:8 Changed 10 months ago by klaus

This is a semi-duplicate of #16127 (due to initial user error by using the incorrect "LPT1:" instead of "LPT1", but would trigger the other issue after correcting the user error), and should be fixed with the latest Windows test build: https://www.virtualbox.org/wiki/Testbuilds

comment:9 Changed 9 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fix is part of VBox 5.1.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use