VirtualBox

Ticket #15837 (closed defect: fixed)

Opened 11 months ago

Last modified 7 months ago

Guest application window resizing behaves inconsistently while in seamless mode -> believed fixed in releases higher than 5.1.10

Reported by: thoms Owned by:
Priority: major Component: GUI/seamless
Version: VirtualBox 5.1.4 Keywords: guest resize seamless
Cc: Guest type: all
Host type: Linux

Description

Since VirtualBox 5.1.2 and including 5.1.4 (possibly also 5.1.0 -- did not test), attempting to resize a guest application window (browser or other app) results in unexpected resizing behavior when in seamless mode. Specifically, attempts to expand the application window (make wider or longer) will quickly lose pointer focus while dragging the window border frame unless the drag is performed very slowly. Conversely, attempts to shrink the same app window (make narrower or shorter) behave as expected, with the pointer maintaining focus during the entire drag operation. This behavior occurs only in seamless mode; resize operations in all other display modes behave as expected.

This issue appears to be independent of the installed guest additions version. The problem is reproducible using using VirtualBox 5.1.2 and 5.1.4 with GA 5.0.16, 5.1.2, 5.1.4. Problem occurs with 64-bit Linux and Windows (7 & 10) guests. Host platforms include fully updated 64-bit CentOS 6 hosts on Intel (Core i5/i7 Sandy Bridge thru Haswell), all using Intel on-chip GPUs and X.Org X11 Intel video driver (2.99.917-0.4.20151111). X.Org server 1.17.4-9.5.

Change History

comment:1 Changed 11 months ago by ...don

I am having a similar problem plus the second screen opens in a reduced size instead of full screen.

comment:2 Changed 11 months ago by paul43

I'm experiencing similar problems with 5.1.2 & 5.1.4. I can only get 800x600 resolution when booting the guest in seamless mode. Sending a controlvm setvideomodehint... to the guest sets the higher res but changes to a traditional window.

Host log says "GUI: UIMachineLogicNormal::sltCheckForRequestedVisualStateType: Rejecting 'seamless' as is it not yet supported.."

I get the same behavior on both a Fedora 23 and 24 host and Fedora 24 guest. I compiled the most recent guest additions from the iso on the guest.

comment:3 Changed 11 months ago by ...don

Still a problem in 5.1.5-110527. On one system on re-booting windows, both screens of dual screens display on same physical monitor. On another, the second screen opens in a reduced size instead of as full screen.

comment:4 Changed 8 months ago by virtualguy

I'm having the same issue as @thoms

The glitch occurs not only when upsizing windows but also when dragging them. This ONLY happens when the the window - and so the pointer - is moved towards areas of the screen that have no guest elements drawn. Hence the glitch does not occur when downsizing windows.

EXPLANATION: The pointer moves faster than the window is redrawn and so exits the VM. If you switch off "mouse integration" from the status bar before going seamless the glitch does not occur.

System: vbox-5.1 (no issues on 5.0) / linux host

comment:5 follow-up: ↓ 6 Changed 8 months ago by michael

Out of interest - if you move the mouse out of the guest window then back in without clicking anywhere, does the problem still happen?

comment:6 in reply to: ↑ 5 Changed 8 months ago by virtualguy

Replying to michael:

Out of interest - if you move the mouse out of the guest window then back in without clicking anywhere, does the problem still happen?

Yes the problem persists regardless of mouse interaction outside the guest.

Also when the pointer moves back into the guest the dragging of the window continues even if the mouse button was released while outside of the guest. You have to click the title bar to end the dragging focus of the window.

comment:7 Changed 8 months ago by michael

That is sad, because it does not fit in with my theory about what is causing this. Nonetheless, I prepared an attempted fix based on that theory. I was able to reproduce the problem myself without but not with the fix. I created test builds containing the fix<1>. Please still do try them out. If you use the shell script "run" installer you will have to uninstall your current version of VirtualBox first. This will not affect your virtual machines. There are no changes to the Additions, so no need to re-install them.

<1>
Generic 32-bit Linux https://www.virtualbox.org/download/testcase/VirtualBox-5.1.9-112051-Linux_x86.run
Generic 64-bit Linux https://www.virtualbox.org/download/testcase/VirtualBox-5.1.9-112051-Linux_amd64.run
EL5 64-bit Linux https://www.virtualbox.org/download/testcase/VirtualBox-5.1-5.1.9_112051_el5-1.x86_64.rpm
EL6 64-bit Linux https://www.virtualbox.org/download/testcase/VirtualBox-5.1-5.1.9_112051_el6-1.x86_64.rpm
EL7 64-bit Linux https://www.virtualbox.org/download/testcase/VirtualBox-5.1-5.1.9_112051_el7-1.x86_64.rpm

comment:8 Changed 7 months ago by michael

  • Summary changed from Guest application window resizing behaves inconsistently while in seamless mode to Guest application window resizing behaves inconsistently while in seamless mode -> believed fixed in releases higher than 5.1.10

I believe this should be fixed in the latest test builds<1> (revision 112223 and later). Please give them a try.

  1. https://www.virtualbox.org/wiki/Testbuilds

comment:9 Changed 7 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.1.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use