VirtualBox

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#15829 closed defect (invalid)

faulty mouse-cursor rendering in Manjarolinux host -> distribution problem

Reported by: manjaro_oberon Owned by:
Component: other Version: VirtualBox 5.1.4
Keywords: Cc:
Guest type: other Host type: other

Description

On Manjarolinux (Archlinux-based) with the guest using vbox-video it looks like the transparent parts of the xcursor are rendered solid black. When switching the guest to vesa-video instead, the rendering is correct but the cursor is "uncaptured" before reaching the horizontal edges of the guest-box. What you see in the second screenshot is the moment when the guest cursor has stopped on the way to the right edge and the host cursor has re-appeared outside of the guestbox. This issue is present since vbox v5.1

Build environment: linux44 or linux46 qt 5.7.0 glibc 2.24 libxcursor 1.1.14

Attachments (5)

VBox.log (120.5 KB ) - added by manjaro_oberon 8 years ago.
vb_mouse.jpg (2.5 KB ) - added by manjaro_oberon 8 years ago.
vbox_vesa.jpg (23.3 KB ) - added by manjaro_oberon 8 years ago.
vbmouse.png (25.3 KB ) - added by zlatkig 8 years ago.
VirtualBox windows with Ubuntu guest showing mouse pointer rendering issue
vbmouse2.png (73.3 KB ) - added by zlatkig 8 years ago.
Lower right corner of the VirtualBox window running Windows 7 and showing the mouse pointer rendering issue.

Download all attachments as: .zip

Change History (17)

by manjaro_oberon, 8 years ago

Attachment: VBox.log added

by manjaro_oberon, 8 years ago

Attachment: vb_mouse.jpg added

by manjaro_oberon, 8 years ago

Attachment: vbox_vesa.jpg added

comment:1 by zlatkig, 8 years ago

Confirming. My host is ArchLinux. This issue appears on every guest I tried. ArchLinux, Ubuntu, Windows 7 and 10 being examples of affected guests. Note that I activate 3D capabilities for the guests and use an X compositor in all Linux guests.

General 3D is not affected. Games work inside guests with reasonable performance and no visual issues. X compositor works and X window shadows are displayed correctly. Only the shadow around the mouse pointer appers as all black pixels instead of being composited with the background.

I attached a screenshot showing the upper right corner of the VirtualBox window with Ubuntu guest running inside. You can see how the mouse cursor looks like. It looks exactly the same on a Windows guest.

This issue started with the upgrade of the VirtualBox GUI to Qt 5.

Is there anything else I can do to help locate the issue?

by zlatkig, 8 years ago

Attachment: vbmouse.png added

VirtualBox windows with Ubuntu guest showing mouse pointer rendering issue

comment:2 by zlatkig, 8 years ago

Using VirtualBox 5.1.6 and the issue ist still there. Some observations:

If I disable the hardware cursor in a Linux guest, the cursor displays okay. Its movements are laggy, but the display artifacts are gone.

Also if I start any of the VMs using VBoxSDL interface, without Qt, the issue is gone.

It seems to be specific to Arch Linux host and derivates. The issue is not present on a Mac OS X host, using the same virtual machines and the same VirtualBox version. I have no access to other host platforms.

by zlatkig, 8 years ago

Attachment: vbmouse2.png added

Lower right corner of the VirtualBox window running Windows 7 and showing the mouse pointer rendering issue.

comment:3 by Olli, 8 years ago

Having exactly the same issue on Arch Linux host with VirtualBox 5.1.8 and Windows 7 (without 3D) and Windows 10 guests (with 3D).

comment:4 by zlatkig, 8 years ago

I was using Xfce on the host so far. Now using GNOME, I still see the same issue. The significant difference here is that Xfce runs on Xorg and GNOME runs on Wayland. This I think excludes both Xorg and Wayand as the cause.

I assume others who see this issue have an Intel GPU?

comment:5 by hamelg2, 8 years ago

Ditto here on Arch Linux host with VirtualBox 5.1.8. I have a nvidia GPU and using proprietary nvidia driver. Please fix the ugly mouse cursor.

comment:6 by Michael Thayer, 8 years ago

I'm afraid that this is not anything that the development team has seen so far. The only common factor I see is that everyone affected is running ArchLinux. For information, are you using packages provided by Arch (binary? source?) or downloaded from virtualbox.org? You might want to try the "all distributions" binary package we provide to see if it is also affected. A big difference there is that that one provides a bundled copy of Qt. Arch's version of Qt (which is it exactly?) is one potential place I see which could be causing this.

So far I'm afraid that the development team is not likely to investigate this. Things you could do which might (still no promises) change that is to show us that it affects a large number of users, that it affects non-Arch hosts and finding a quick and simple way for us to reproduce the problem. Another would be someone with programming skills investigating.

comment:7 by hamelg2, 8 years ago

Arch's version of Qt is the latest stable, currently 5.7.0. I have tested on XFCE and KDE, with/without compositor, this doesn't make any difference.

There is an open task on the archlinux bug tracker : https://bugs.archlinux.org/task/50120

and a thread in forums : https://forums.virtualbox.org/viewtopic.php?f=2&t=78750

Last edited 8 years ago by hamelg2 (previous) (diff)

in reply to:  7 comment:8 by Socratis, 8 years ago

Replying to hamelg2:

and a thread in forums : https://forums.virtualbox.org/viewtopic.php?f=2&t=78750

And in there there is a suggestion, the same one that 'michael' suggested before your post; try the AllDistributions package from VirtualBox.

There is a similar bug for OSX hosts (#15610), unfortunately there, only the official packages exist. Trying to see if it is the same source of the problem or not. (OSX Qt 5.6.2)

comment:9 by zlatkig, 8 years ago

This is definitely related to Arch's Qt packages. There is another unrelated application with the same symptoms: https://bitbucket.org/maproom/qmapshack/issues/136/tms-maps-are-rendered-a-bit-fuzzy

It seems that when Arch-distributed Qt is using a custom mouse cursor, it cannot handle an alpha channel value other than 0 ad 255 - and that only when hardware cursor is enabled.

I think this can be closed here. It is not a bug in VirtualBox and the progress can be followed on the Arch Linux bug tracker (link above).

comment:10 by Michael Thayer, 8 years ago

Resolution: invalid
Status: newclosed
Summary: faulty mouse-cursor rendering in Manjarolinux hostfaulty mouse-cursor rendering in Manjarolinux host -> distribution problem

Thank you for the feedback.

comment:11 by manjaro_oberon, 8 years ago

Just to let you know. Virtualbox update to 5.1.12 finally fixes this :D

comment:12 by manjaro_oberon, 8 years ago

No. ;) I take that back - I must have mixed something up. The issue is still present.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use