VirtualBox

Ticket #15815 (closed defect: duplicate)

Opened 3 years ago

Last modified 3 years ago

SELinux is preventing vboxdrv.sh from write access on the directory /etc/udev/rules.d.

Reported by: Billamay77 Owned by:
Component: other Version: VirtualBox 5.1.4
Keywords: selinux vboxdrv.sh init_t udev_rules_t write udev Cc:
Guest type: other Host type: other

Description

Installing VirtualBox VirtualBox-5.1.x86_64 5.1.4_110228_fedora24-1 on Fedora 24 I get:

SELinux is preventing vboxdrv.sh from write access on the directory /etc/udev/rules.d.

* Plugin catchall (100. confidence) suggests

If you believe that vboxdrv.sh should be allowed write access on the rules.d directory by default. Then you should report this as a bug. You can generate a local policy module to allow this access. Do allow this access for now by executing: # ausearch -c 'vboxdrv.sh' --raw | audit2allow -M my-vboxdrvsh # semodule -X 300 -i my-vboxdrvsh.pp

Additional Information: Source Context system_u:system_r:init_t:s0 Target Context system_u:object_r:udev_rules_t:s0 Target Objects /etc/udev/rules.d [ dir ] Source vboxdrv.sh Source Path vboxdrv.sh Port <Unknown> Host besasc Source RPM Packages Target RPM Packages systemd-udev-229-12.fc24.x86_64 Policy RPM selinux-policy-3.13.1-191.10.fc24.noarch Selinux Enabled True Policy Type targeted Enforcing Mode Enforcing Host Name besasc Platform Linux besasc 4.6.6-300.fc24.x86_64 #1 SMP Wed Aug

10 21:07:35 UTC 2016 x86_64 x86_64

Alert Count 67 First Seen 2016-07-20 22:33:01 CEST Last Seen 2016-08-18 09:12:02 CEST Local ID 43eddcf0-0e4d-4ea8-a94f-f9adaa8efc7a

Raw Audit Messages type=AVC msg=audit(1471504322.835:105): avc: denied { write } for pid=912 comm="vboxdrv.sh" name="rules.d" dev="dm-0" ino=1045793 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:udev_rules_t:s0 tclass=dir permissive=0

Hash: vboxdrv.sh,init_t,udev_rules_t,dir,write

Change History

comment:1 Changed 3 years ago by socratis

Duplicate of #15816, save the HostType and Component.

comment:2 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use