VirtualBox

Ticket #158 (closed defect: fixed)

Opened 7 years ago

Last modified 7 years ago

Ubuntu Guest Additions Xorg Drivers

Reported by: maztaim Owned by:
Priority: major Component: other
Version: VirtualBox 1.3.6 Keywords: guest additions xorg ubuntu
Cc: Guest type: other
Host type: other

Description

After running through the install successfully for Guest additions on Ubuntu, When starting xorg I get the following:

(EE) Failed to load module "vboxvideo" (module does not exist, 0)
(EE) Failed to load module "vboxmouse" (module does not exist, 0)
(EE) No drivers available.

So I thought, must be the xorg.conf.

Section "Input Device"
     ...
     Driver      "vboxvideo"
     ...
EndSection

Section "Device"
     ...
     Driver      "vboxvideo"
     ...
EndSection

Well. It works if I revert just those two offending lines. So I wonder about the drivers themselves.

So I did a little more digging:

find /usr/lib/xorg -ls | grep vbox
354511  32 -rw-r--r--  1 root     root       30832 Mar  3 02:29 /usr/lib/xorg/modules/input/vboxmouse_drv.o
354273  24 -rw-r--r--  1 root     root       23092 Mar  3 02:29 /usr/lib/xorg/modules/drivers/vboxvideo_drv.o

Sadly, I don't know much else other than it APPEARS alright. As far as I can tell, all looks as it should for an Ubuntu install...

Change History

comment:1 Changed 7 years ago by DracoBlue

Hello,

I am using Xubuntu 6.10 and it worked very well. Which version did you tried? With 1.3.6 VB.

Kind regards,

Jan (DracoBlue)

comment:2 Changed 7 years ago by frank

Please would you post your Xorg.0.log and your /etc/X11/xorg.conf? Thanks in advance.

comment:3 Changed 7 years ago by mike4711

It doesn't work for me as well. XP as host, Feisty Alpha 5 as guest

After installing the additions it says: Successfully installed the Virtualbox Guest Additions. But a reboot leaves me in the shell. startx says: Failed to load module "vboxvideo" (module does not exist , 0)

Failed to load module "vboxmouse" (module does not exist , 0)

comment:4 follow-up: ↓ 5 Changed 7 years ago by dranger003

Hello,

I have the same issue running Feisty Herd 4 and VirtualBox 1.3.6 (deb). After installing the VBoxLinuxAdditions the drivers installed fine.

The /usr/lib/xorg/modules/input/vboxmouse_drv.o & /usr/lib/xorg/modules/drivers/vboxvideo_drv.o both should have ".so" extensions instead of ".o" as all the other files in both directories.

Is this a new format for the X server used in Feisty to have drivers as ".so" instead of ".o" or is this an issue with VBox that doesn't compile the drivers correctly?

Thanks for any help! Dan.

comment:5 in reply to: ↑ 4 Changed 7 years ago by dranger003

And also, renaming (or symblinking) both files to have ".so" extensions doesn't work either (says "Loader failed"). This is really an issue with the format of the drivers.

comment:6 Changed 7 years ago by dranger003

Ok, I found a fix. Here's what I did:

1) Mount the VBoxAdditions.iso 2) Extract the ".so" driver files using VBoxLinuxAdditions.sh --noexec --target /tmp

(The files needed will be in /tmp)

3) Copy /tmp/vboxmouse_drv_71.so and /tmp/vboxvideo_drv_71.so to the appropriate paths

(e.g.: /usr/lib/xorg/modules/input/ and /usr/lib/xorg/modules/drivers/ respectively)

4) Symblink both files to remove the "_71" part in the filenames

(e.g.: ln -s vboxmouse_drv_71.so vboxmouse_drv.so - do the same for vboxvideo_drv_71.so)

Start your X server.

Cheers, Dan.

comment:7 Changed 7 years ago by rainbowbuilder

This fix worked fine on WinXP host, Ubuntu Herd5 guest on VirtualBox 1.3.6 Thanks much

gary

comment:8 Changed 7 years ago by frank

The problem is that Ubuntu Herd5 started to use Xorg 7.2.0 which is not properly detected by the install.sh script. This will be fixed in the next release.

comment:9 Changed 7 years ago by michael

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use