VirtualBox

Ticket #15789 (closed defect: fixed)

Opened 2 years ago

Last modified 2 years ago

Compile error in kLdrModMachO.c

Reported by: Bermond Owned by:
Component: other Version:
Keywords: Cc:
Guest type: all Host type: Linux

Description

I'm getting the following error when trying to compile VirtualBox using the SVN version:

/storage/linux/src/virtualbox-svn/src/libs/kStuff/kStuff/kLdr/kLdrModMachO.c:871:2693: error: self-comparison always evaluates to true [-Werror=tautological-compare]
                     VALIDATE_AND_ADD_SECTION(32);
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     ^ 
/storage/linux/src/virtualbox-svn/src/libs/kStuff/kStuff/kLdr/kLdrModMachO.c:923:2693: error: self-comparison always evaluates to true [-Werror=tautological-compare]
                     VALIDATE_AND_ADD_SECTION(64);
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     ^ 
cc1: all warnings being treated as errors
kmk: *** [/storage/linux/src/virtualbox-svn/out/linux.amd64/release/obj/VBox-kStuff/kStuff/kLdr/kLdrModMachO.o] Error 1

Using:

OS: Arch Linux x86_64

GCC: 6.1.1

VirtualBox: SVN

Change History

comment:1 Changed 2 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to fixed

Looks like it was fixed in between, can't reproduce here anymore on my Arch Linux host with gcc 6.1.1, closing as fixed. Please use the vbox-dev mailing list next time to report such issues.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use