VirtualBox

Ticket #15747 (closed defect: fixed)

Opened 15 months ago

Last modified 14 months ago

VirtualBox 5.0.26 won't boot Linux 4.6.4 on Fedora 24

Reported by: r2d3 Owned by:
Priority: major Component: VMM
Version: VirtualBox 5.0.26 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

  • Host: Fedora 24 Linux 4.6.4-301.fc24.x86_64
  • VirtualBox: 5.0.26 (also happens on 5.0.24)
  • Guest: Fedora 24 LXDE spin. Linux 4.6.4-301.fc24.x86_64

(Linux 4.6.3-300.fc24.x86_64 works!)

Change History

Changed 15 months ago by r2d3

Changed 15 months ago by r2d3

Changed 15 months ago by r2d3

Changed 15 months ago by r2d3

comment:1 Changed 15 months ago by r2d3

Same or similar problem on kernel 4.6.5-300

comment:2 Changed 15 months ago by r2d3

Figured out that the problem is the default IDE controller (+ CDROM) that is added for a new instance. If I remove the IDE controller and add a new CDROM to the SATA controller, everything works.

comment:3 Changed 15 months ago by frank

Cannot reproduce this with 5.0.27 nor 5.1.3. I'm not aware of any corresponding changes but could you test a test build from here? I used Fedora 24 with Linux 4.6.5-300.

comment:4 Changed 15 months ago by r2d3

I could reproduce on 5.0.26. I think the magic combo is the IDE controller AND USB 3.0.

Steps:

  1. Create New VM
    • Name: TestF24
    • Type: Linux
    • Version: Fedora (64-bit)
    • Create new disk, 8GB, dynamic
  2. Settings
    • Attach Live CD to IDE controller : Fedora LXDE Live CD x86_64-24-1.2.iso
    • USB -> enable 3.0
  3. Install to disk
  4. Shutdown
  5. Remove Live CD
  6. Start
  7. dnf update (this should get kernel 4.6.5-300 as of today)
  8. Reboot
  9. Error after 23s

comment:5 Changed 15 months ago by frank

Good catch! I see the same problem if I enable USB3.

comment:6 Changed 14 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

In our opinion this is a bug in the Linux kernel which was recently introduced. This bug will probably never be triggered on real hardware.

comment:7 Changed 14 months ago by frank

For reference, see  here. VBox 5.1.4 contains a workaround but once this patch is added to the kernel, our workaround is no longer necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use