VirtualBox

Ticket #15719 (closed defect: fixed)

Opened 10 months ago

Last modified 6 months ago

Immediate crash when pressing Alt+Num1

Reported by: fernandonajera Owned by:
Priority: major Component: other
Version: VirtualBox 5.1.2 Keywords: crash, alt
Cc: Guest type: other
Host type: other

Description

Using VirtualBox 5.1.2r108956 in a Windows 10 Pro Version 1511 (OS Build 10586.494)

I can reproduce with any guest, at any point, even when it is showing the "BIOS" splashscreen.

Just start a machine, make sure NumLock is ON and press-and-release ALT+Num1, in the same way you would use ALT+Num6+Num5 to produce a character 'A' (so: press ALT + press Num1 + release Num1 + release ALT).

VirtualBox crashes immediately when ALT is released with:

---------------------------
VirtualBox: VirtualBox.exe - Application Error
---------------------------
The instruction at 0x00007FFF783A49F9 referenced memory at 0x000000000298A3A0. The memory could not be read.


Click on OK to terminate the program
---------------------------
OK   
---------------------------

Note that this seems to be bound to the number you type. The number of a 'normal' character like 65 for 'A' works OK.

For me it's an important issue as I relay on the ALT+Num feature to type characters in other languages. If I make a mistake when typing the number (as it happened today) then the whole virtual machine crashes.

Attachments

VBox.log Download (67.0 KB) - added by fernandonajera 10 months ago.
VBoxHardening.log Download (324.4 KB) - added by fernandonajera 10 months ago.
VBox logs.zip Download (123.1 KB) - added by jhedges8 8 months ago.
VBox Log Files
VBox logs 2016-09-29 - 2016-09-30.zip Download (64.4 KB) - added by jhedges8 8 months ago.
VBox logs 2016-10-03 - 2016-10-05.zip Download (33.2 KB) - added by jhedges8 8 months ago.
capture20161010111523483.png Download (128.0 KB) - added by AK - 8 months ago.
VBOX crash
VMWin7-2016-10-12-07-29-12.log Download (107.2 KB) - added by AYSabre 8 months ago.
Latest crash log after Alt+F+C key combo was used.
VBox logs 2016-10-07 - 2016-10-12.zip Download (49.6 KB) - added by jhedges8 8 months ago.
VMWin7-2016-10-13-07-14-03.log Download (93.3 KB) - added by AYSabre 7 months ago.
Latest crash log after Alt+Left Arrow key combo was used.

Change History

Changed 10 months ago by fernandonajera

Changed 10 months ago by fernandonajera

comment:1 Changed 10 months ago by frank

Unfortunately I'm unable to reproduce this problem. Installed VBox 5.1.2 on Windows 10, NumLock on, started a Linux guest and booted to GRUB. NumLock is off. Enabled NumLock. Pressed Alt+1 and released. Nothing happens, no crash.

comment:2 Changed 8 months ago by jhedges8

I've been having these crashes every since I upgraded from 5.1.2 to 5.1.4. I have since upgraded to 5.1.6, and then yesterday to the latest test build 5.1.7-110927. All of them have crashed. The most common key combination that does it for me is Alt+Tab to switch windows, but it also happened once when I pressed Alt+LeftArrow. It doesn't seem to matter whether I have a second virtual screen enabled or not, and it also doesn't seem to matter whether I have audio enabled or not (I disabled it after reading a couple other tickets). The offending instruction address always ends in 49F9, if that helps. I can include screenshots of the error messages if needed, as they don't seem to be included in the log files.

Changed 8 months ago by jhedges8

VBox Log Files

comment:3 Changed 8 months ago by jhedges8

I've had four more crashes since yesterday. One was caused by Alt+DownArrow. It's frustrating to try to remember to use the mouse instead of Alt+Tab to switch windows. Note that it doesn't happen every time I press Alt+Tab. I am using Eclipse as an IDE, and it seems like most of the time it crashes when I switch from the Eclipse window to another. The Alt+DownArrow crash happened while I was using Terminator, though, so the window probably doesn't matter.

Changed 8 months ago by jhedges8

comment:4 Changed 8 months ago by jhedges8

Two more crashes since last time, but only because I've been getting better about not using the Alt key. I upgraded to the latest test build, 5.1.7-111038, but it didn't seem to help. I have had audio enabled for a while.

Changed 8 months ago by jhedges8

comment:5 follow-up: ↓ 26 Changed 8 months ago by frank

If we only would be able to reproduce the problem :-(

comment:6 Changed 8 months ago by AK -

Same error here.

VBOX 5.1.6 on Win10 with WIN81ENTERPRISE guest.

ALT + num and VBOX crashes.

See attachment.

Changed 8 months ago by AK -

VBOX crash

comment:7 Changed 8 months ago by AYSabre

Am having issues similar to those stated but with Alt+F (standard File menu for win apps which in my case is Visual Studio). Seems to happen with Alt+F, Alt+F+J (to load a recent solution), Alt+F+C (to close a file), etc.

Not sure exactly what causes this as it seems to happen randomly as I use the keyboard all day long. My original post is here:  https://forums.virtualbox.org/viewtopic.php?f=6&t=79123

I'll attach my log file as my VM just crashed this morning with Alt+F+C. Note that my host is Win7, my guest is Win7 and my development server is connected to via RDP from my guest and it runs Windows 2012 R2 Server. So the key combos that cause the crash happen while I'm on my remote RDP session within my guest.

Changed 8 months ago by AYSabre

Latest crash log after Alt+F+C key combo was used.

comment:8 Changed 8 months ago by jhedges8

I've had three crashes since my last comment. This morning I upgraded to the latest test build and didn't refrain from using the Alt key. For a while, I thought that the bug had been fixed, because everything was working fine with me using multiple Alt+Tab and Alt+ArrowKey combinations. It didn't last, though. A few minutes ago, I switched back to the VM after reading a pdf in Windows (which I had been doing all day) and tried to Alt+Tab to a different Linux window in the VM, and it crashed. Logs attached. I'm glad other people are posting here now. Maybe someone from Oracle will respond eventually.

Changed 8 months ago by jhedges8

comment:9 Changed 7 months ago by AYSabre

It just happened to me again with Alt+Left Arrow. Attached another log.

Changed 7 months ago by AYSabre

Latest crash log after Alt+Left Arrow key combo was used.

comment:10 Changed 7 months ago by butonic

Same here, Alt+Tab kills the vm

comment:11 Changed 7 months ago by mhanor

Someone from Oracle has already responded. In comment 1, Frank has mentioned that he's not able to reproduce the crash. Some of you, who do encounter the crash, must save a memory dump of the crashed process, compress it, upload it to a Google Drive account, set the access permissions and send the link to Frank. You can contact him via email at frank _dot_ mehnert _at_ oracle _dot_ com
On Windows hosts, you'll have to use  Process Explorer from Microsoft/Sysinternals, to manually save the memory dump. For other host types, read here
Don't forget to mention the bug ticket number, in your e-mail.

comment:12 Changed 7 months ago by AYSabre

Crashed again today with Alt+Tab. I've not used Process Explorer but seems straightforward. I assume the dump has to be done BEFORE clicking OK on the exception dialog? Also, which process would require the dump? VirtualBox.exe or VBoxSVC.exe? I'll assume it's VirtualBox.exe as it seems, after the crash, a "stray" instance of it stays loaded.

comment:13 Changed 7 months ago by mhanor

Yes, you need to save the memory dump before you close the exception dialog. On Windows host, a VM has a process tree made of 3 VirtualBox.exe processes. Most likely, the crashing process is the lowest (the last child) of that process tree. You can look at the Windows event viewer Application log, it should contain an event for the crash, so you can identify the exact process ID. You can also use Process Monitor, from Microsoft/Sysinternals, with two filters (CTRL+L), "Operation is - Process Start - then Include" and "Operation is - Process Exit - then Include" to look at how processes get spawned then terminated.
You need to run Process Explorer and Process Monitor as Administrator.

comment:14 Changed 7 months ago by jhedges8

The bug seems to be fixed in the latest test build (5.1.7-111360). I'm about to try out 5.1.8 now.

comment:15 Changed 7 months ago by jhedges8

5.1.8(r111374) just crashed on an Alt+Tab. I'm not able to create a mini dump because I can't get elevated permissions (it's a work computer).

comment:16 Changed 7 months ago by jhedges8

FYI: It's not fixed in test build 5.1.7-111360. I'll see if I can get it to crash later tonight on my home machine then generate a mini dump.

comment:17 Changed 7 months ago by Paul B.

I have exactly same problem from version 5.1.4 to version 5.1.8, I created duplicate ticket #166066. This problem ocurs in last version 5.1.8 too. Nobody has solution :-( I hope, it is not permanent feature.

comment:18 follow-up: ↓ 20 Changed 7 months ago by frank

Please re-read comment:11.

comment:19 follow-up: ↓ 23 Changed 7 months ago by Paul B.

I am not sure yet but I probably have something. Before two years I migrated from VMWare to VirtualBox and I changed VirtualBox host key from Rigth Ctrl to Left Ctrl + Left Alt. Yesterday morning I changed host key back to Right Ctrl and I had no crash. It is too fresh, maybe it means nothing, time will prove it. Has anyone of you remaped host key?

comment:20 in reply to: ↑ 18 Changed 7 months ago by Paul B.

Replying to frank:

Please re-read comment:11.

Everithing is in ticket #166066.

comment:21 follow-up: ↓ 22 Changed 7 months ago by mhanor

Paul B. what's your keyboard layout?

comment:22 in reply to: ↑ 21 Changed 7 months ago by Paul B.

Replying to mhanor:

Paul B. what's your keyboard layout?

In host and guest I use ENGLISH US and CZECH QWERTY. Almost time I use ENGLISH US.

comment:23 in reply to: ↑ 19 Changed 7 months ago by jhedges8

Replying to Paul B.:

I am not sure yet but I probably have something. Before two years I migrated from VMWare to VirtualBox and I changed VirtualBox host key from Rigth Ctrl to Left Ctrl + Left Alt. Yesterday morning I changed host key back to Right Ctrl and I had no crash. It is too fresh, maybe it means nothing, time will prove it. Has anyone of you remaped host key?

That's interesting. I remapped mine to the Pause/Break key.

comment:24 follow-up: ↓ 27 Changed 7 months ago by mhanor

Was the host key pressed at the moment of the crash, or at least was it pressed moments earlier to the crash?

comment:25 Changed 7 months ago by jhedges8

No, not for me. I don't use it very often. That's why I remapped it to the Pause key.

comment:26 in reply to: ↑ 5 Changed 7 months ago by jhedges8

Replying to frank:

If we only would be able to reproduce the problem :-(

Frank, I've had three crashes in the last couple days and have been able to get mini dumps from them. I sent you an email with a link to the file, as per the instructions above.

comment:27 in reply to: ↑ 24 Changed 7 months ago by Paul B.

Replying to mhanor:

Was the host key pressed at the moment of the crash, or at least was it pressed moments earlier to the crash?

I use host key only when I need to sign in to guest OS. Crash happens independently on time when host key was pressed. My VM crash when I have remaped host key and press Alt+Tab, but not in all times. Before 6 days I remaped host key back to default and crash doesn't occur again.

comment:28 Changed 7 months ago by Paul B.

Bad news. VM start crashing again even if default host key is set :-(

comment:29 follow-up: ↓ 32 Changed 7 months ago by amedvedev

Paul, could you collect a full memory dump for us? Most structures in the minidumps are missed.

comment:30 Changed 7 months ago by frank

Actually I think the provided dumps are sufficient, thank you! It seems like this is the same bug as described  here. We have upgraded Qt for our 5.1 branch from 5.5.1 to 5.6.2. Could you verify that this issue is fixed with the most recent 5.1 Windows test build (>= revision 111655)?

comment:31 Changed 7 months ago by jhedges8

That would explain why 5.1.2 started crashing after a while when I downgraded. I installed the latest test build yesterday, and so far no crashes. I'll try to start using alt+tab more (I've had to train myself to use the mouse instead) and let you know what happens in the next couple days.

comment:32 in reply to: ↑ 29 Changed 7 months ago by Paul B.

Replying to amedvedev:

Paul, could you collect a full memory dump for us? Most structures in the minidumps are missed.

Thats problem, full memory dump has over 7 GB but I try reproduce it in smaller VM.

comment:33 follow-up: ↓ 35 Changed 7 months ago by frank

Paul B, please try the latest 5.1.x test builds. As I wrote in comment:30 we are quite sure that we found and fixed the problem.

comment:34 Changed 7 months ago by jhedges8

Sorry, Frank. I've been busy at work. I'd like to report that I have had no crashes since installing the latest test build last week, and I have been using Alt key combinations without reservation. So it looks like the problem is fixed. Thanks for your help.

comment:35 in reply to: ↑ 33 Changed 6 months ago by Paul B.

Replying to frank:

Paul B, please try the latest 5.1.x test builds. As I wrote in comment:30 we are quite sure that we found and fixed the problem.

Hi Frank, I have same result as jhedges8, no crash after last test build installed. Many thanks.

comment:36 Changed 6 months ago by fernandonajera

OP here. With 5.1.8 I still had problems - several crashes per day.

I have installed the test build 5.1.9 r111896 (Qt5.6.2) a couple of hours ago.

My original problem (crash with 'wrong' ALT+number codes) is gone. And so far, the ALT-Tab crashes (that I also had) seem to be gone.

So thanks a lot for fixing this!

comment:37 Changed 6 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.1.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use