VirtualBox

Ticket #15683 (closed defect: fixed)

Opened 16 months ago

Last modified 13 months ago

rhgb boot option crashes gdm with EFI -> fixed in releases higher than 5.1.6

Reported by: FreddyW Owned by:
Priority: major Component: guest additions/x11/graphics
Version: VirtualBox 5.1.2 Keywords: rhgb gdm
Cc: Guest type: Linux
Host type: Linux

Description

Using Fedora 24 both as host and as guest (fully updated with testing repos), GDM (login screen) keeps crashing when using the rhgb boot option. Removing the rhgb option makes everything work as expected. Had this problem from the getgo with VB 5.1, 5.1.2 did not solve the issue. Happens with both 3D enabled as disabled. I am not using any form of xorg.conf file with custom settings.

Attachments

journalloggdmcrash.log.zip Download (177.5 KB) - added by FreddyW 16 months ago.
journal log
Xorg.0.log Download (8.4 KB) - added by FreddyW 16 months ago.
xorg log
VBox.log.1 Download (145.9 KB) - added by FreddyW 16 months ago.
Log file without iomem=relaxed
VBox.log Download (175.0 KB) - added by FreddyW 16 months ago.
Log file with iomem=relaxed
Fedora.vbox Download (11.5 KB) - added by FreddyW 16 months ago.
The XML file

Change History

Changed 16 months ago by FreddyW

journal log

Changed 16 months ago by FreddyW

xorg log

comment:1 Changed 16 months ago by michael

Could you please check to see whether this is still the case with the latest Additions test build? Thank you.

comment:2 Changed 16 months ago by FreddyW

tried with VBoxGuestAdditions_5.1.3-109087.iso but the issue remains. No GDM login screen with the rhgb boot option.

comment:3 Changed 16 months ago by michael

How does one enable the testing repositories? And is it reasonable to assume that the problem is with VirtualBox and not something unstable in the repository?

comment:4 Changed 16 months ago by FreddyW

dnf --enablerepo=update-testing update

I do think the problem is VirtualBox as the problem arose the minute I upgraded to VirtualBox-5.1. No problem whatsoever with VB-5.0. That being said, a Fedora 23 guest does not display this problem. It looks like a combination of Fedora24 (guest) and VB-5.1. After some more digging, it appears that using iomem=relaxed combined with rhgb does work.

comment:5 Changed 16 months ago by michael

No problem here. Before continuing, could you please check with Additions test build 109119 or later?

comment:6 Changed 16 months ago by michael

Test build<1> revision 109126 and later of the Additions contains a fix for a problem which could cause random (timing-related) failures, particularly in early boot.

<1> https://www.virtualbox.org/wiki/Testbuilds

comment:7 Changed 16 months ago by FreddyW

same issue, I need to either add iomem=relaxed or remove rhgb from the boot options.

comment:8 Changed 16 months ago by michael

Could you please upload a virtual machine log file and the machine XML?

Changed 16 months ago by FreddyW

Log file without iomem=relaxed

Changed 16 months ago by FreddyW

Log file with iomem=relaxed

Changed 16 months ago by FreddyW

The XML file

comment:9 follow-up: ↓ 10 Changed 16 months ago by michael

Test build 109138 has another fix. Probably not it, but you never know.

comment:10 in reply to: ↑ 9 Changed 16 months ago by FreddyW

Replying to michael:

Test build 109138 has another fix. Probably not it, but you never know.

Nope, unfortunately not it. Still needs iomem=relaxed.

comment:12 follow-up: ↓ 13 Changed 16 months ago by michael

I don't know anything about EFI by the way, so what do I need to do to make Fedora work with it? Just set it before installing the machine?

comment:13 in reply to: ↑ 12 Changed 16 months ago by FreddyW

Replying to michael:

I don't know anything about EFI by the way, so what do I need to do to make Fedora work with it? Just set it before installing the machine?

That would be (by far) the easiest way. I will try to do a fresh install while not using EFI.

comment:14 in reply to: ↑ 11 Changed 16 months ago by FreddyW

Replying to michael:

Try disabling EFI<1>.

<1>  https://forums.virtualbox.org/viewtopic.php?f=3&t=78427&p=368135#p368130

Looks like EFI indeed has something to do with it. A fresh install not using EFI works out-of-the-box, no special boot parameters needed.

comment:15 Changed 16 months ago by michael

  • Summary changed from rhgb boot option crashes gdm to rhgb boot option crashes gdm with EFI

comment:16 Changed 14 months ago by michael

Reproduced. Pressing escape during the splash screen also allowed me to boot. I think I can guess what the cause of this is: our graphics driver refuses to load if any of the Linux virtual consoles are in graphics mode (which to my understanding basically means that someone else has taken over the graphics card) to prevent fights with the VESA driver. Presumably the EFI splash screen also sets the graphics mode flag and unsets it if it is cancelled with escape. Now I just need to think about how to solve this.

comment:17 Changed 14 months ago by FreddyW

Thanks for not forgetting about this one. Very curious what can be done about it.

comment:18 Changed 14 months ago by michael

  • Summary changed from rhgb boot option crashes gdm with EFI to rhgb boot option crashes gdm with EFI -> fixed in releases higher than 5.1.6

I committed a fix for this. I removed the offending code (nearly the end of vbox_drv.c if you are interested) and just made sure (hopefully) that the driver does not get loaded when the X server is already running. Normally it should load long before that. When I get a chance to update the test builds, Additions build revision 110797 or later should contain the fix.

comment:19 follow-up: ↓ 20 Changed 14 months ago by frank

Please download the most recent 5.1.x Guest Additions from our test builds page and install it. It contains the fix. Feedback welcome!

comment:20 in reply to: ↑ 19 Changed 14 months ago by FreddyW

Replying to frank:

Please download the most recent 5.1.x Guest Additions from our test builds page and install it. It contains the fix. Feedback welcome!

Guest Additions test build 5.1.7-110797 does indeed seem to fix the issue, I can boot in rhgb mode without the iomem kernel parameter. Thanks for the fix!

comment:21 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 5.1.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use