VirtualBox

Opened 8 years ago

Last modified 3 years ago

#15665 reopened defect

Mouse pointer graphic is messed up

Reported by: Gordon M Owned by:
Component: GUI Version: VirtualBox 5.1.2
Keywords: Cc:
Guest type: Solaris Host type: Windows

Description

Host: Windows 7 Enterprise 64 bit Guest: Solaris 10

After installing 5.1.2, the graphic for the mouse pointer in my guest OS is messed up. It looks very bizarre. You can kind of see what the pointer should be, but it is heavily obscured by a bunch of dark "noise" that surrounds the pointer in a small rectangle.

I think this only happened when Mouse Integration was enabled.

Previous to the upgrade, I was using 5.0.16. I have now downgraded to 5.0.26, and the problem is no longer present. I can't imagine anyone who experiences this would consider it acceptable; I know that I won't be using any 5.1 versions unless this can be resolved.

Attachments (11)

vbox2b.jpg (97.2 KB ) - added by dnc 8 years ago.
vbox1b.jpg (231.4 KB ) - added by dnc 8 years ago.
solaris10.jpg (301.1 KB ) - added by iaina 8 years ago.
Solaris 10 guest
solaris11.jpg (268.8 KB ) - added by iaina 8 years ago.
Solaris 11 guest
vb_mouse.jpg (2.5 KB ) - added by manjaro_oberon 8 years ago.
vbox_vesa.jpg (23.3 KB ) - added by manjaro_oberon 8 years ago.
xcursor uncaptured on the way to right edge of guestbox
VBox.log (120.5 KB ) - added by manjaro_oberon 8 years ago.
persisting issue with vbox 5.14
Screenshot_10.png (17.6 KB ) - added by Uegene2 4 years ago.
2020-07-16 17_09_54.png (343.4 KB ) - added by radradish 4 years ago.
2020-07-16 19_53_47.jpg (46.0 KB ) - added by radradish 4 years ago.
cursor.png (256.9 KB ) - added by hArcAngel 4 years ago.

Download all attachments as: .zip

Change History (37)

comment:1 by Klaus Espenlaub, 8 years ago

Can you provide a screenshot (taken by some utility on the host which includes the mouse pointer)?

by dnc, 8 years ago

Attachment: vbox2b.jpg added

by dnc, 8 years ago

Attachment: vbox1b.jpg added

comment:2 by dnc, 8 years ago

Same problem, (went from 5.0.20 to 5.1.2) screenshot not possible as mouse pointer is not captured.

Problem occurs in text box area, (even in the text area of notepad) ie. the cursor I pointer symbol

The pointer appears over a black box, when the mouse if moved a trace is left behind but only appears where the black box is. The trace alos appears to be permanent, if returning a point previous moved over the old pointer trace is still there when the black box moves over it again.

comment:3 by dnc, 8 years ago

May relate to second graphics card, Ubuntu 16.04 has issues with HWCursor with a second card, trying to disable the HWCursor.

comment:4 by Carlos D., 8 years ago

I witnessed the same problem, using VirtualBox 5.1.2. Both Host (x64) and Guest (x86) are Windows 7.

In my case the garbled cursor appeared inside Paint.Net 1.4.10. Since PDN uses custom shaped cursors to resemble the selected tool, you cannot use it correctly, anymore. Switching hardware-accelerating inside PDN did maker no difference.

The Guest itself uses neither 3D nor 2D.

No screenshot since I had to roll back to 5.0.27, which fixes it instantly.

Version 0, edited 8 years ago by Carlos D. (next)

comment:5 by iaina, 8 years ago

Same problem here with 5.1 and 5.12 on Windows 7 64 bit host and guests running both Solaris 10 and Solaris 11. Reverting to 5.0.x (or upgrading to 5.1.x) guest additions does nothing to help. The problem only occurs when mouse integration is enabled; mouse pointers are fine with mouse integration disabled on both guests.

Various Red Hat and Fedora guests have no problem on the same system.

by iaina, 8 years ago

Attachment: solaris10.jpg added

Solaris 10 guest

by iaina, 8 years ago

Attachment: solaris11.jpg added

Solaris 11 guest

by manjaro_oberon, 8 years ago

Attachment: vb_mouse.jpg added

by manjaro_oberon, 8 years ago

Attachment: vbox_vesa.jpg added

xcursor uncaptured on the way to right edge of guestbox

comment:6 by manjaro_oberon, 8 years ago

We're experiencing the same problem on Manjarolinux (v5.1.2): As long as the guest uses vbox-video it looks like the transparent parts of the xcursor are rendered solid black. When using vesa-video instead the rendering is correct but the cursor is "uncaptured" before reaching the horizontal edges of the guest-box. What you see in the screenshot is the moment when the guest cursor has stopped on the way to the right edge and the host cursor has re-appeared outside of the guestbox.

Last edited 8 years ago by manjaro_oberon (previous) (diff)

comment:7 by darlor, 8 years ago

I have the same problem on all of my Linux VMs. Messed up cursor appears only when mouse integration is enabled. On VBox v5.0 cursors were ok.

comment:8 by sunlover, 8 years ago

This should be fixed in latest 5.1 builds (r109157+) from https://www.virtualbox.org/wiki/Testbuilds Please test. Thanks.

comment:9 by iaina, 8 years ago

Thanks sunlover. Fixed now for me testing with r109189. Solaris 10 & 11 both fine again.

comment:10 by darlor, 8 years ago

Yep... Fixed in r109189 for all my Linux VMs. Waiting for stable release. Thank you

comment:11 by Frank Mehnert, 8 years ago

Resolution: fixed
Status: newclosed

Fix is part of 5.1.4.

comment:12 by manjaro_oberon, 8 years ago

Resolution: fixed
Status: closedreopened

5.1.4 does not fix the issue for me. It's still exactly the same as in my comment of July 28

comment:13 by Frank Mehnert, 8 years ago

manjaro_oberon, please attach a VBox.log file for such a VM session.

by manjaro_oberon, 8 years ago

Attachment: VBox.log added

persisting issue with vbox 5.14

comment:14 by migemon, 8 years ago

Confirming vbox 5.14 solved this issue for me.

I used to get the corrupted mouse cursor under the following conditions: Machine: Macbook Pro 2015 Host: Windows 10 Guest: Windows 2012 R2 Display: Windows display scaling to 170%

My workaround before to resolve this: Display: Disable Windows scaling

comment:15 by Frank Mehnert, 8 years ago

Resolution: fixed
Status: reopenedclosed

manjaro_oberon, this ticket is about Solaris guests while your ticket is about a Linux guest. Furthermore, you are using a build probably by your Linux distribution.

Could you open a new ticket and add the VBox.log file there? Please also provide some information about the build environment there, for instance the exact version of the Qt library used. Thank you!

comment:17 by IgorIvanov, 4 years ago

Resolution: fixed
Status: closedreopened

Hi guys. I have to reopen this ticket.

I use: VirtualBox 6.1.4 (released February 19 2020)
Host: Windows 7 Pro x64 scaling 150% monitor (2560x1440) GPU - NVIDIA GeForce GTX 1050 Ti
Guest: Windows 7 Pro x64 scaling 150% (3D enabled GPU RAM 256MB)

And I have the same artifacts as shown on the attached files to this ticket.

I found a similar problem: and it says that the problem is solved in VirtualBox version 6.1.0 (released December 10 2019) called: GUI: Fixed / improved mouse pointer scaling

But in the current latest version, I have all the same problems.

A comment: The problem manifests itself when scaling is enabled in the guest. If you set the scaling to 100% in the guest OS (disable), then there is no problem! The problem only appears if the application uses non-standard cursors. If you turn on the mouse as a USB device, then there is no problem either! (but then I am left without a mouse in the host)

Last edited 4 years ago by IgorIvanov (previous) (diff)

comment:18 by IgorIvanov, 4 years ago

I have now downgraded to 6.1.0 (released December 10 2019) But the problem is present.

comment:19 by IgorIvanov, 4 years ago

I found a solution to the problem for myself. If you set a scale of 149% inside the guest OS, then this problem is not. If you put 150% - the problem is present. Initially, I needed 150%, but this does not work. I think I can leave 149.

But the problem, as we see, starts at 150% if I had not a 2K but a 4K monitor, I would need a scale of more than 150%. I think this is a problem, because models 4K and already even 8K monitors are already being released to the market.

by Uegene2, 4 years ago

Attachment: Screenshot_10.png added

comment:20 by Uegene2, 4 years ago

Host: Win10, Guest: Win10, VboxSVGA, 3D disabled. when mouse hover anything that is about to change mouse pointer to something other than standard arrow, it becomes like this:

with 3D Enabled, VM display goes to freeze and doesn't react on anything.


Version 6.1.6 r137129 (Qt5.6.2)

Last edited 4 years ago by Uegene2 (previous) (diff)

comment:21 by fandrei, 4 years ago

I'm having same problem in version 6.1.6. Host OS - Windows 7 and 10, guest OS - Windows 10. I can confirm that setting scale factor in guest OS to 149 fixes the problem almost completely (there still is some visual noise on the cursor when it's moving, but no visual noise when the cursor is motionless).

comment:22 by MattF, 4 years ago

Hello

I'm on Win 10, using version 6.1 of virtualbox and i'm having the exact same issue. but when i leave the window, the corrupted cursor returns to normal. I'm not sure if this issue is being worked on or not?

by radradish, 4 years ago

Attachment: 2020-07-16 17_09_54.png added

comment:23 by radradish, 4 years ago

I'm using VirtualBox 6.1.12 on latest Windows 10 Pro host with i7-7600U and latest Intel graphics drivers. In my virtual machine I have Windows 10, version 2004 (10.0.19041.0). This problem is persistent for a few months now. It happens only when cursor on client changes to something else than default - in text editor for example. 3D acceleration is disabled. Turning 3D acceleration on or off has no effect.

What's interesting - my laptop has a touch screen. I use VirtualBox on external HDMI display. When I leave this wrecked cursor on external display and then use touch input on main laptop display the glitch disappears.

I took some close-up photos of this glitch. Sometimes when moving cursor over active window area it changes into only a glitch for a moment or at very limited area. It's hard to reproduce. Most of the time it is custom cursor with a glitched stripe.

Also this glitch gets bigger when cursor is scaled up in mouse settings on host:

This glitch is not present when VirtualBox's window is positioned on laptop's display instead of an external monitor.

What solved this issue was setting main monitor (laptop) to 100% scaling in Windows instead of 125%. Now I have same 100% scaling on both displays.

Last edited 4 years ago by radradish (previous) (diff)

by radradish, 4 years ago

Attachment: 2020-07-16 19_53_47.jpg added

by hArcAngel, 4 years ago

Attachment: cursor.png added

comment:24 by hArcAngel, 4 years ago

The same behaviour occured here after moving my host os to my new notebook (without reinstall). Both of the old and new notebooks have touch screens and the scaling is 125% for both ones. There are just two differences: this cursor bug and a more annoying sudden guest freeze symptom.

The cursor bug disappeared after changing the scale to 100% but the guest freezineg is still exists.

Update 1: Reinstall to newest version (6.1.14) does not solve the cursor issue.

Update 2: Problem also exists in linux guest.

Update 3: Found a workaround for freezing: I desktop integration mode it not occurs.

Last edited 4 years ago by hArcAngel (previous) (diff)

comment:25 by blindahl, 4 years ago

having the same problem as radradish. scaling settings don't affect it - either in host OS or in guest (both Windows 10). moving the cursor rapidly changes the contents of the "overlay", but it never goes away - it's present on all cursor shapes AFAICT.

using vbox 6.1.16

update: installing the "guest additions" fixed the issue.

Last edited 4 years ago by blindahl (previous) (diff)

comment:26 by sedawk, 3 years ago

I have a similar problem in Windows 10.

After installing the cursor works fine in the normal size console screen, but when I select scaling in order to open a xymon console using Firefox and be able to see everything that is displayed, I get the shadow and that is not all, I get a similar behavior than when one install Linux with one keyboard and mouse and then plugin a different keyboard and mouse, and no matter what you do, you are unable to get the pointer to point at the same location that is highlighted. Sometimes the link that will be selected when you click is a combination of where the vertical location of the real and the horizontal location of the shadow meet, or visa versa. This makes it impossible to select anything.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use