VirtualBox

Ticket #15628 (closed defect: fixed)

Opened 17 months ago

Last modified 16 months ago

VirtualBox GUI "Aborts" VMs without GPU

Reported by: mustafacan Owned by:
Priority: critical Component: GUI
Version: VirtualBox 5.1.0 Keywords:
Cc: Guest type: all
Host type: all

Description

Steps to reproduce:

  1. Create a VM with any configuration.
  2. Remove VM's GPU with this command "VBoxManage modifyvm VM --graphicscontroller none"
  3. Start the VM with this command "VBoxManage.exe startvm VM --type headless"

At this point the VM will work without problems. You can connect to it with Serial or SSH to start working on it.

However, if you start the VirtualBox GUI at this point you'll receive an Application Error.

The instruction at 0x71105837 referenced memory at 0x00000010. The memory could not be read.

Click on OK to terminate the program

Then, GUI will Power off the VM instantly and show "Aborted" as VM's status.

(Note: I flagged this as critical, since powering off a VM without shutting down the Guest OS can result corruption of Guest OS.)

Attachments

minidump and log.zip Download (476.4 KB) - added by mustafacan 17 months ago.

Change History

Changed 17 months ago by mustafacan

comment:1 Changed 16 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in VBox 5.0.26. Fix will also be available in the next 5.1.x maintenance release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use