VirtualBox

Ticket #15574 (closed defect: fixed)

Opened 11 months ago

Last modified 10 months ago

Oh no! Something has gone wrong - guest addition 5.0.24 r108355 -> believed fixed in releases higher than 5.1.0

Reported by: Phoenix1708 Owned by:
Priority: blocker Component: guest additions/x11/graphics
Version: VirtualBox 5.0.24 Keywords: 3D acceleration
Cc: raynebc, cowbutt Guest type: Linux
Host type: Windows

Description

I only have one VM which is the from the RHEL 7 developer suite. When i boot the VM Virtualbox telling me that it's better to install the newer version of the guest addtion since I upgrated to VB 5.0.24.

My host is Windows 7 Enterprise.

After installing the guest addition I am unable to login and always getting the "Oh no! Something has gone wrong" screen.

If I disable the "3D acceleration" everything works fine.

Uploaded the VBox.log and VBoxSVC.log

Attachments

VBoxSVC.log Download (13.8 KB) - added by Phoenix1708 11 months ago.
VBox.log Download (98.4 KB) - added by Phoenix1708 11 months ago.
Xorg.0.log Download (48.6 KB) - added by Phoenix1708 11 months ago.
var_log_message.zip Download (353.2 KB) - added by Phoenix1708 11 months ago.

Change History

Changed 11 months ago by Phoenix1708

Changed 11 months ago by Phoenix1708

comment:1 Changed 11 months ago by michael

Please give as precise instructions as possible about how to reproduce this with a freshly installed virtual machine which is created as part of the instructions.

comment:2 Changed 11 months ago by michael

And please also attach /var/log/Xorg.0.log and the output of the systemd journal. (I think that contains all relevant system logging these days. Please check the dmesg output and /var/log/messages if it exists to be sure that they do not contain additional information.)

comment:3 Changed 11 months ago by Phoenix1708

Hi,

My computer is on

OS: Windows 7 Enterprise Graphics card: Intel(R) Graphics Family (driver version: 10.18.14.4139) Virtualbox: Version 5.0.24 r108355

I had this problem even with my old Centos 7 VM too so I guess the hosted VM shouldn't be the major issue.

I think the step is very simple:

  • Install Centos 7 or RHEL 7 on virtualbox 5.0.24.
  • Changed to maximum 128mb video memory
  • Host has 8 GB RAM and 4GB RAM allocated to the VM
  • Start the VM
  • When booting finsihed click "Inserting Guest Addition CD Image" from Device menu
  • Type in root password
  • Wait for the process to finish without reporting any warning or error
  • Shutdown the VM.
  • Enabled 3D acceleration
  • All other settings are left default
  • Start the VM get to the "Oh no! something has gone wrong" screen
  • Shutdown VM
  • Untick Enable 3D acceleration
  • Start VM everything back to normal

Havne't made the systemd journel persistent yet but hope these helps. Attached the logs

Last edited 11 months ago by Phoenix1708 (previous) (diff)

Changed 11 months ago by Phoenix1708

Changed 11 months ago by Phoenix1708

comment:4 Changed 11 months ago by DonC

To add on to this ticket, I am running on Windows 10 and using Oracle Linux 6 with the current (4.1.12-37.5.1.el6uek.x86_64) Kernel for UEK4. With the 3D acceleration turned on it simply stops at the "Starting certmonger" phase. It says "Okay" but it the system just sits there. When I turn 3D off, the system boots, but when the display window is resized, the linux display does not resize along with it.

DonC

Last edited 11 months ago by DonC (previous) (diff)

comment:5 Changed 11 months ago by michael

  • Cc raynebc, cowbutt added

comment:6 Changed 11 months ago by raynebc

Ticket #15526 documents similar problems occurring (although the problem comes and goes for unknown reasons) in Ubuntu 15 and 16.

comment:7 Changed 11 months ago by michael

Please try the latest 5.1 Guest Additions build from the Testbuilds page.

comment:8 Changed 11 months ago by raynebc

I updated one of my affected Ubuntu 15 VMs to guest additions 5.1.1-108756, and the only visual difference I'm seeing is that after trying and failing to start X several times (it cycles between text mode and a black screen), it goes back to showing the Ubuntu loading screen indefinitely.

comment:9 Changed 10 months ago by cowbutt

I've just done a bit of sleuthing, and it seems to come down to SELinux contexts not being set properly on /var/lib/VBoxGuestAdditions/lib/libGL.so.1 and libEGL.so.1, and the files in /opt/VBoxGuestAdditions-5.0.24/lib/ that they point to (i.e. VBoxEGL.so and VBoxOGL.so respectively) which causes gdm spawned by /usr/bin/gnome-session to fail. Setting them accordingly:

chcon -h system_u:object_r:lib_t:s0 /var/lib/VBoxGuestAdditions/lib/libGL.so.1

chcon -h system_u:object_r:lib_t:s0 /var/lib/VBoxGuestAdditions/lib/libEGL.so.1

chcon -h system_u:object_r:textrel_shlib_t:s0 /opt/VBoxGuestAdditions-5.0.24/lib/VBoxEGL.so

chcon -h system_u:object_r:textrel_shlib_t:s0 /opt/VBoxGuestAdditions-5.0.24/lib/VBoxOGL.so

allows gdm, gnome-session and an interactive session to work, but the contexts are reset on the next reboot.

Copying the files, setting appropriate contexts on them, and putting the path to them at the front of the ld search path (e.g. via /etc/ld.so.conf.d/000vboxvideo.conf [sic] allows gdm to run successfully across reboots.

However, some applications (notably Google Chrome, and VLC) have problems running the 5.0.24 Guest Additions; vlc causes the session to stop responding to anything but an Input->Keyboard->Insert Ctrl-Alt-Del, and Chrome causes a screen full of black and white rectangular areas.

Last edited 10 months ago by cowbutt (previous) (diff)

comment:10 follow-up: ↓ 11 Changed 10 months ago by michael

cowbutt: I take it you tried the test image without success (should work fine with VirtualBox 5.0 on the host). Other people should still try it, there might be several different issues here.

comment:11 in reply to: ↑ 10 Changed 10 months ago by cowbutt

Replying to michael:

cowbutt: I take it you tried the test image without success (should work fine with VirtualBox 5.0 on the host). Other people should still try it, there might be several different issues here.

I did try 5.1.1-108756 as well as 5.0.24. I seem to recall I couldn't get it working even with the workaround, but I've just tried again now and it's worked out-of-the-box - though I still get the problems with Chrome and VLC.

I think since I last tried 5.1.1-108756, I've also added 'iomem=relaxed' to the kernel boot line, uninstalled and reinstalled initial-setup and initial-setup-gui, and added a new SELinux policy, which might explain why it now works:

module gdm-vboxvideo 1.0;

require {

type unconfined_t;
type var_lib_t;
type init_t;
type xdm_t;
class lnk_file read;
class service enable;

}

#============= unconfined_t ==============
allow unconfined_t init_t:service enable;

#============= xdm_t ==============
allow xdm_t var_lib_t:lnk_file read;

That's pretty ugly, though, as I think it's totally legitimate for SELinux to prevent binaries from linking to shared libraries under /var/lib - shared libraries should live in /lib[64] or /usr/lib[64] and have SELinux file contexts set accordingly.

Last edited 10 months ago by cowbutt (previous) (diff)

comment:12 Changed 10 months ago by michael

I can reproduce this on CentOS 7 guests. Since you have started looking at this I wonder whether you have any ideas about possible solutions. The basic mechanism in use is that we wish to put our own GL libraries on the system without overwriting the system libraries and use the ld.so.conf.d mechanism to give ours priority over the system ones if 3D pass-through is detected.

So either SELinux has to be told to accept GDM using the libraries - using semanage fecontext to change the context of our libraries is probably preferable to the configuration file you gave above, but I am not an SELinux expert to know exactly what is needed - or some way to handle this which fulfils the requirements, works on all distributions and works with SELinux needs to be found.

Finding the right person at Redhat to ask probably makes sense.

comment:13 Changed 10 months ago by michael

  • Component changed from other to guest additions/x11/graphics
  • Summary changed from Oh no! Something has gone wrong - guest addition 5.0.24 r108355 to Oh no! Something has gone wrong - guest addition 5.0.24 r108355 -> believed fixed in releases higher than 5.1.0

This should be fixed in r62394.

comment:14 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:15 Changed 10 months ago by raynebc

  • Status changed from closed to reopened
  • Resolution fixed deleted

I tested the latest stable release of VirtualBox and the guest additions (5.1.2-108956), but the problem persists in Ubuntu 15 and 16.

When 3D acceleration is enabled in either VM when I boot, the OS tries several times to initialize the graphics mode then it gives up and permanently displays the Ubuntu splash screen. As usual, the only way to get a working GUI again is to disable the acceleration, replace guest additions with a compatible version (5.0.16) or remove guest additions entirely.

comment:16 Changed 10 months ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed

raynebc: I have re-opened your ticket, as it is clearly not the same issue after all. Closing this one again.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use