VirtualBox

Ticket #15571 (closed defect: fixed)

Opened 17 months ago

Last modified 16 months ago

Solaris 8 Generic_108529-05 installer crashes Vbox 5.0.24 if VT-x is enabled

Reported by: kumba Owned by:
Priority: minor Component: other
Version: VirtualBox 5.0.24 Keywords: solaris8, vt-x
Cc: Guest type: Solaris
Host type: Windows

Description

Discovered while trying to randomly boot a Solaris 8 x86 ISO I scrounged up on a Windows Server 2008R2 host. If the boot medium is SunOS 5.8 Generic_108529-05 and VT-x is enabled, then the installer will trigger a general protection fault when it tries to load the interactive installation. This fault also causes a NULL pointer deref attempt, which is caught by the Windows Host and that specific VM window is force-closed. The main VBox window then reports the Solaris 8 guest's status as "Aborted".

I have two screenshots, one of the VM window containing the Solaris 8 kernel panic details, and the second is the dialog popup showing the NULL pointer deref attempt. I'll also attach the VBox.log file, though it appears the VM dies earlier enough that nothing significant about the error was logged.

The problem is not present in a later release of Solaris 8, namely Generic_108529-11. Booting an install CD with that version works fine with VT-x enabled. So I assume the bug was more of a Solaris one, but I figured the crash generating a NULL deref attempt might be ticketable for you guys.

Attachments

VBox.log.sol8_108529-05_vtx_panic.txt Download (72.5 KB) - added by kumba 17 months ago.
VBox.log from the panic
solaris8-vbox-vtx-panic-20160704.png Download (33.0 KB) - added by kumba 17 months ago.
Screenshot of the Solaris 8 Generic_108529-05 installer triggering a panic if VT-x is enabled
solaris8-vbox-vtx-null-20160704.png Download (15.9 KB) - added by kumba 17 months ago.
Screenshot of the dialog from the Windows Host showing the NULL pointer deref info after the Sol8 panic

Change History

Changed 17 months ago by kumba

VBox.log from the panic

Changed 17 months ago by kumba

Screenshot of the Solaris 8 Generic_108529-05 installer triggering a panic if VT-x is enabled

Changed 17 months ago by kumba

Screenshot of the dialog from the Windows Host showing the NULL pointer deref info after the Sol8 panic

comment:1 Changed 17 months ago by kumba

Per michaln on the forums, the panic is a genuine Solaris 8 bug, described here:  http://www.os2museum.com/wp/solaris-2-6-7-and-8-crashes-on-pentium-4-and-later/

The Ticket's title needs to be changed to reflect the real bug, so I'd suggest this: "Kernel panic in Solaris 8 Generic_108529-05 installer causes NULL ptr deref in guest virtualbox.exe instance".

comment:2 Changed 17 months ago by michaln

This should be fixed in svn but needs a bit more testing. The VM process crash was indeed specific to hardware virtualization, though a bit indirectly. It was triggered by a failed task switch which the guest tried to perform. It looks like the guest panics too early, before everything is set up correctly, and ends up double faulting/triple faulting while processing the panic.

comment:3 Changed 16 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 5.0.26.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use