VirtualBox

Ticket #15529 (closed defect: fixed)

Opened 17 months ago

Last modified 13 months ago

Windows 10 guest keeps locking up

Reported by: tom.isaacson Owned by:
Priority: blocker Component: other
Version: VirtualBox 5.0.22 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I'm running Windows 7 x64 VMs on Ubuntu 16.04 LTS and it works fine. But recently I upgraded one of my VMs to Windows 10 x64 and since then the stability has been very bad. It will lockup during boot, operation, going to standby or shutdown and the only solution is to kill it.

The only thing I've found that seems to help is setting the number of CPUs to 1 (normally I use 2).

Attachments

VBox.log Download (197.9 KB) - added by MucGhuine 17 months ago.
VBox log
apic.txt Download (563 bytes) - added by MucGhuine 17 months ago.
info apic
ioapic.txt Download (2.5 KB) - added by MucGhuine 17 months ago.
info ioapic
VBox.2.log Download (121.4 KB) - added by alanbirtles 17 months ago.
non debug ubuntu guest crash
VBox.3.log Download (139.1 KB) - added by alanbirtles 17 months ago.
Windows 10 guest on OSX host 5.0.22
apic.2.txt Download (3.2 KB) - added by alanbirtles 17 months ago.
Windows 10 guest on OSX host 5.0.22
boinc_4a772633fe644d3a Clone 4b-2016-06-23-22-00-18.log Download (94.4 KB) - added by Jacob Klein 17 months ago.
boinc_138b3fd3ccbfa12c Clone 14b-2016-06-23-21-59-26.log Download (94.4 KB) - added by Jacob Klein 17 months ago.
pfauvm-2016-06-29-17-14-55.log Download (109.8 KB) - added by Ancow 17 months ago.
5.0.24 Debian testing guest, Win10 host
VBox.4.log Download (458.2 KB) - added by ...don 17 months ago.
VBox log
VBox.log.3 Download (112.1 KB) - added by Aiddog10 15 months ago.
Log of crash

Change History

comment:1 Changed 17 months ago by cbnbg

I have a similar problem with Ubuntu 16.04 host and Windows 10 pro guest (both with latest updates). But it's not an upgrade of win7. I used 5.0.20 before and had no problems. Now with 5.0.22 the VM freezes after boot. Freezes means that it's like a background wallpaper. No response to mouse or keyboard. Can't do anything than power off the VM. Sometimes it works for a minute. My current Workaround is to disable 3D-support in settings. Don't know if it's the same issue but the ticket title describes my problem.

comment:2 Changed 17 months ago by ...don

Similar issue. Linux host, Windows 10 guest. Was working with 5.0.20. Several minutes after startup top shows virtualbox taking 100% of the CPU and the system becomes unresponsive.

comment:3 Changed 17 months ago by frank

Is this lock-up reproducible? If so, please do the following: Start your VM with

VirtualBox --startvm VM_NAME --dbg

Then try to reproduce the hang. Once you've got the hang, open the 'Debug' menu (--dbg enabled this menu) and enter the following commands into the debug console:

  • info apic
  • info ioapic

Then copy and paste the debug output into a file and attach it to this defect. Please do also attach the VBox.log file of such a hanging VM session.

comment:4 Changed 17 months ago by stekman

I had to downgrade to 5.0.20 to get a stable system. For me the freeze comes under heavy load: Three instances of visual studio, two iis servers. I tried an upgrade to 5.1 beta 3 and had the same problem. The system is stable when downgraded to 5.0.20.

Changed 17 months ago by MucGhuine

VBox log

Changed 17 months ago by MucGhuine

info apic

Changed 17 months ago by MucGhuine

info ioapic

comment:5 Changed 17 months ago by MucGhuine

I have this problem too, Ubuntu Mate 16.04 host, Windows 10 guest. The hangs come faster each time round, yesterday there were several hours between each hang, this morning it was 40 minutes, this round was about 5 minutes long. I'll downgrade to 5.0.20 now, as I have to work with the vm. The attached VBox.log, apic.txt and ioapic.txt are the result of what frank requested in comment 3.

Last edited 17 months ago by MucGhuine (previous) (diff)

comment:6 Changed 17 months ago by frank

  • Priority changed from major to blocker

comment:7 Changed 17 months ago by alanbirtles

I may have just seen the same issue with an OSX host and Ubuntu guest, didn't have debugging enabled though

Changed 17 months ago by alanbirtles

non debug ubuntu guest crash

comment:8 Changed 17 months ago by frank

So far we have evidence that the new I/O-APIC code which was introduced in 5.0.22 causes a regression with certain guests. Unfortunately these edge cases were not detected by our tests. We are working on a fix.

comment:9 Changed 17 months ago by olem

Same issue (Linux Fedora host, Windows 10 guest, 4 cpus) after the 5.0.22 upgrade. Please tell me if my logs would help.

comment:10 Changed 17 months ago by MucGhuine

I see the 5.0.22 version is still offered from virtualbox.org and the repository, it might be advisable to pull this version, or at least post a warning, given the severity of this issue.

comment:11 Changed 17 months ago by frank

The most recent 5.0 test builds have a fix for this problem. Could you confirm?

Changed 17 months ago by alanbirtles

Windows 10 guest on OSX host 5.0.22

Changed 17 months ago by alanbirtles

Windows 10 guest on OSX host 5.0.22

comment:12 follow-up: ↓ 13 Changed 17 months ago by frank

alanbirtles, thanks for the logs. We don't need these log files anymore as we know the problem. I would be more interested in feedback from the latest test builds, see my previous comment. Thanks!

comment:13 in reply to: ↑ 12 Changed 17 months ago by alanbirtles

Replying to frank:

alanbirtles, thanks for the logs. We don't need these log files anymore as we know the problem. I would be more interested in feedback from the latest test builds, see my previous comment. Thanks!

Yes I'm running the new build now, just posted the logs in case they showed something different

comment:14 Changed 17 months ago by White-Tiger

Just for the sake of completeness, it's not host dependent as it'll also happen on Windows (8.1).

For me, it'll freeze shortly after logon and didn't seem to be related to the guest additions used in terms of old(.20) vs new(.22) (also didn't freeze in Safemode, nor on logon screen during my tries)

Furthermore, Virtualbox uses more than 1 entire CPU core when it "freezes" (about 13.8% - 14.4% CPU usage on an 8 core system)
and it might mess up the host's mouse cursor even with the VBox window being inactive (moves in slow motion with related delayed and queued input, but didn't happen all the time)

VBox 5.1 still has this issue
5.0.23 seems to work for now...

comment:15 Changed 17 months ago by frank

Thanks. At the moment I'm interested to know if the provided 5.0 test builds (see above) fix these hangs which were introduced with 5.0.22.

comment:16 Changed 17 months ago by cbnbg

"White-Tiger" answered: 5.0.23 seems to work for now...

The test build is 5.0.23...!?

I can't test it because I'm happy that my 5.0.22 runs stable now (without! graphics acceleration). And I need a running VM at the moment without experiments :-(.

comment:17 Changed 17 months ago by Jacob Klein

I'm not sure if this is the same issue as what I saw, frank could you check? Basically, after running v5.0.22 for a while, and then trying to use v5.0.23 Test Build 108212... my VMs wouldn't start from snapshots! They had the following error: Unsupported version 2 of data unit 'ioapic' (instance #0, pass 0xffffffff) (VERR_SSM_UNSUPPORTED_DATA_UNIT_VERSION).

I'll attach 2 startup logs that exhibited the behavior.

In order to correct it, I had to revert to backups of my VMs (that were never touched by v5.0.22), which I was smart enough to have ready. Now those backups are running v5.0.23 Test Build 108212 without problems.

Anyway, frank, do you happen to know if this is the same issue, or related somehow?

Last edited 17 months ago by Jacob Klein (previous) (diff)

Changed 17 months ago by Jacob Klein

Changed 17 months ago by Jacob Klein

comment:18 Changed 17 months ago by frank

Jacob, I'm aware of this issue and it was fixed in the meantime, sorry that the 108212 buids didn't contain the fix yet. The new I/O-APIC code also changed the version of the 'saved state' data of this component. When switching back to the old code, it has to handle the data from the new code properly of course. The 108298 builds (just uploaded) contain the fix so it's possible to load your saved state from 5.0.22.

comment:19 Changed 17 months ago by Jacob Klein

Excellent. I'll test the new 108298 builds now, to see if they can recover the 2 VMs that were crashing for me. I saved backups of them too -- backups of EVERYTHING, even backups of backups!

I'll report my results later today.

comment:20 Changed 17 months ago by wolfc

Hi - I have also been experiencing the same issue. Windows 7 32 bit guest, 3D support enabled (using the "experimental" option), two vcpus assigned. I'm trying the 5.0.23 test release and will also report back when I can be sure the crash issue has been resolved. Many thanks for your work on resolving it, it's been driving me crackers.

comment:21 Changed 17 months ago by Jacob Klein

Oracle VirtualBox v5.0.23 Test Build 108298 ... is able to successfully start my VM snapshots that had been giving the error: Unsupported version 2 of data unit 'ioapic' (instance #0, pass 0xffffffff) (VERR_SSM_UNSUPPORTED_DATA_UNIT_VERSION).

Thank you for fixing it.

Last edited 17 months ago by Jacob Klein (previous) (diff)

comment:22 Changed 17 months ago by frank

The latest 5.0 test builds have the new I/O-APIC code re-enabled but have an additional fix for the hang with Windows 10 + 3D enabled. I would be glad to see test results for these builds as well.

comment:23 Changed 17 months ago by olem

Hi - I've tested VirtualBox v5.0.23 Test Build 108337. My VM did not freeze, which fixes the issue I had in v5.0.22.

However, I had sound issues (I use Skype with voice chat in my Windows 10 VM, and can normally speak smoothly, however, with the test build, my voice was inaudible (very noisy). I downgraded to 5.0.20 and it works again.)

I don't know if it's an issue specific to version 5.0.23 or to the installer. Normally, I use Fedora RPM (e.g.  http://download.virtualbox.org/virtualbox/5.0.22/VirtualBox-5.0-5.0.22_108108_fedora22-1.x86_64.rpm) to install VirtualBox. There's no Fedora RPM for Tests builds, so I used the .run Linux installer (https://www.virtualbox.org/download/testcase/VirtualBox-5.0.23-108337-Linux_amd64.run), and the VirtualBox GUI was also different. So perhaps my sound issue is OS-specific or installer-specific and not version specific...

comment:24 Changed 17 months ago by frank

Hi olem, here is an F22 package like you are usually using. Could you check if it shows the same audio problems? The .run package might use another audio backend by default (a VBox.log file from both VM sessions would show it).

comment:25 Changed 17 months ago by olem

Thanks Frank, with the F22 package, I have no issue (sound ok + no freeze).

comment:26 Changed 17 months ago by Ancow

I just had this freeze again with VBox 5.0.23 r108298 running a current Debian testing on Win10. It was way more frequent with 5.0.22, but since it is the second freeze today, it does not appear to be gone for me.

I will try again with r108337 to see if it will make a difference.

comment:27 Changed 17 months ago by EPinci

I'm experiencing the same running Windows guest on a Windows host even with 5.0.24. I've attached relevant log at #15556.

Thank you.

comment:28 Changed 17 months ago by Ancow

I installed 5.0.24 today, hoping that the freeze would be gone. After running for almost seven hours, my VM froze again.

Note that I cannot SSH into the VM after the freeze and I have no discernible disk or CPU activity.

Last edited 17 months ago by Ancow (previous) (diff)

Changed 17 months ago by Ancow

5.0.24 Debian testing guest, Win10 host

comment:29 Changed 17 months ago by frank

Ancow, what you describe is most likely a complete different issue. This ticket is about Windows 10 guests and this problem should be fixed with 5.0.24. For your Debian guest problem please open a separate ticket.

comment:30 Changed 17 months ago by Ancow

I've created ticket #15560, but I'm fairly certain that they are related.

comment:31 Changed 17 months ago by cbnbg

Feedback to version 5.0.24.
Runs great now with Ubuntu 16.04 host and Windows 10 prof guest. No crashes. No hangs moving mouse between Windows desktop and host. No hangs at all. 3D and 2D accel. enabled! Thank you very much.

Last edited 17 months ago by cbnbg (previous) (diff)

comment:32 Changed 17 months ago by ...don

Has not reoccurred for me with 5.0.24.

comment:33 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback! I will close this ticket.

comment:34 Changed 17 months ago by ...don

Perhaps I spoke too soon. The system locked up last night while idle with the same symptoms - 100% CUP and unresponsive. I have attached the log.

Linux SuSE 64 bit host, 64 bit Windows 10 guest, 4 CPU, 2 displays, 3D & 2D enabled.

Changed 17 months ago by ...don

VBox log

comment:35 Changed 15 months ago by Aiddog10

I am running Windows 10 guest on OS X 10.11.6 and Windows just shuts down. I was just playing a non intensive game (Undertale) and it said Shutting Down and closed the VM after about 40 minutes of playing. I just added more ram (total of 7 GB) to the VM and now I have a total of 2 cores it can use (out of my 4). The execution cap is also at 100%. I have no idea what is going wrong and these specs should be way more than enough to play Undertale! Please help me! I will send the log like you told everyone else who it happens again.

Changed 15 months ago by Aiddog10

Log of crash

comment:36 Changed 15 months ago by Aiddog10

When it happened, it closed the VM so I couldn't do the info apic and info ioapic. But I do have the log file right here

comment:37 Changed 13 months ago by emsofo

I can confirm the this issue using latest Mageia development (cauldron) x64 based machine - running virtualbox 5.1.8 - Windows 10 guest (latest updates) - not only hangs but brings the whole host system to a halt as well!!! Mouse freezes and system is fully locked up (can't even switch to console) - only recourse is reboot using sysrq magic keys!!!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use